LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 09-20-2003, 04:27 AM   #1
NightShade737
LQ Newbie
 
Registered: Jun 2003
Location: Worcs, UK
Distribution: Gentoo
Posts: 29

Rep: Reputation: 15
Unhappy Gentoo Dependency Issue


I'm getting a really annoying problem with Gentoo....

Whenever something runs it complains about not being able to check dependencies (but still runs anyway) and tells me to run /sbin/depscan.sh but when I run that it says something close to -

'ash - invalid command on line 1176

then it gives lots of errors like not being able to find lots of basic system services.

The actual output of depscan -

Ragnarok root # /sbin/depscan.sh
* Caching service dependencies...
'ash: line 1175: syntax error near unexpected token `{
'ash: line 1175: ` depend() {
* Can't find service 'localmount' needed by 'gpm'; continuing...
* Can't find service 'localmount' needed by 'hdparm'; continuing...
* Can't find service 'checkroot' needed by 'hostname'; continuing...
* Can't find service 'localmount' needed by 'numlock'; continuing...
* Can't find service 'localmount' needed by 'alsasound'; continuing...
* Can't find service 'logger' needed by 'webmin'; continuing...
* Can't find service 'localmount' needed by 'rmnologin'; continuing...
* Can't find service 'modules' needed by 'aumix'; continuing...
* Can't find service 'clock' needed by 'bootmisc'; continuing...
* Can't find service 'localmount' needed by 'bootmisc'; continuing...
* Can't find service 'checkroot' needed by 'checkfs'; continuing...
* Can't find service 'modules' needed by 'checkfs'; continuing... [ ok ]

---------------------------------------------

And the output whenever I try to run anything via init.d -

* Could not get dependency info for "sshd"!
* Please run:

* # /sbin/depscan.sh

* to fix this.
* Could not get dependency info for "sshd"!
* Please run:

* # /sbin/depscan.sh

* to fix this.
* Starting sshd... [ !! ]

--------------------------------------------------
(ignore the fact it failed)


Any ideas as this is making a complete mess of everything.

Cheers,
NS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Correcting a yum dependency issue muppetmaster Fedora 3 11-02-2005 03:28 AM
Yum (yumex) dependency issue? linmix Linux - Software 2 02-03-2005 08:58 AM
rpm dependency issue afrodocter Linux - Software 1 04-15-2004 02:58 PM
How to troubleshoot dependency issue please? (Using YUM) davidas Linux - Newbie 2 03-29-2004 06:52 PM
rpm dependency issue edverb Linux - Newbie 9 03-04-2003 03:20 AM


All times are GMT -5. The time now is 11:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration