LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 02-15-2007, 11:28 PM   #1
des_a
Member
 
Registered: Sep 2006
Posts: 343

Rep: Reputation: 18
External USB Hard Drive Mounting Problem with SuSe Linux 9.0


I used to have my external USB hard drive on my machine that has Windows XP. That mostly works fine. I also have a SuSe Linux 9.0 server that I'm trying to get to work.

One of the new things I'm trying to do to my network is to start backing up everything at certain points on each computer. Then I can restore everything with one file (mainly).

I tried dd. dd worked for creating the files, but it complained of space issues when I tried to get it to work with the external hard drive. So I'm trying other programs like partimage.

Since it seems to want a server to send the data to over the network, I switched the drive to the server. That's because then it still only takes 2 computers to back up and not 3. It makes more sense.

So then I ran into difficulties. The drive works fine and everything, but I can't get it to mount with fstab. I can manually add the line, but it never uses it. It only wants to use it's hotplugging results which is an automatic line in the fstab. It mounts fine manually, but I want it to mount automatically.

How to I modify the proper scripts so that they will let me automatically mount the drive? They should automatically mount only external hard drives. The script is in perl language. It's located in /usr/sbin/checkhotmounts.

Here's a link to where I found information on what causes the problem: http://131.111.8.10/pub/doc/suse/sus...00000000000000
 
Old 02-16-2007, 03:17 PM   #2
des_a
Member
 
Registered: Sep 2006
Posts: 343

Original Poster
Rep: Reputation: 18
I found the answer! I just had to find where it checked to see if it was a harddisk or not, and then set the fstab options it was going to write to the right values (changing noauto to auto). Then I had to use YaST to enable hotplugging at boot instead of most of the runlevels. That was it!
 
Old 03-20-2007, 10:46 AM   #3
des_a
Member
 
Registered: Sep 2006
Posts: 343

Original Poster
Rep: Reputation: 18
I think a better solution is to just add it to the boot runlevel instead of replacing the other runlevels it runs on with only the boot runlevel. Otherwise, I still think I was right before. Well, if it doesn't boot, it's due to the runlevels I guess.
 
Old 03-20-2007, 11:03 AM   #4
des_a
Member
 
Registered: Sep 2006
Posts: 343

Original Poster
Rep: Reputation: 18
Maybe the runlevels are simply the wrong thing to change as I've been finding that it can cause errors. But the patch should be the right thing to do.
 
Old 03-20-2007, 11:05 AM   #5
des_a
Member
 
Registered: Sep 2006
Posts: 343

Original Poster
Rep: Reputation: 18
Or what if I just removed the entry altogether? Then it'd not know about hotplugging the disks though.
 
Old 03-20-2007, 11:39 AM   #6
des_a
Member
 
Registered: Sep 2006
Posts: 343

Original Poster
Rep: Reputation: 18
OK. So the the better solution I've come up with so far, is you add the line change, but then you delete the old hotplug fstab entry so that it will write a new fstab on bootup. Then you reboot once. That's part of the solution for sure so far.
 
Old 03-22-2007, 10:08 PM   #7
des_a
Member
 
Registered: Sep 2006
Posts: 343

Original Poster
Rep: Reputation: 18
I'm thinking adding submount to the /usr/sbin/checkhotmounts file fixed the problem best so far.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with mounting external hard drive in linux wearetheborg Linux - Hardware 6 12-29-2006 03:31 PM
Booting Suse 10.1 From USB External Hard Drive trickster009 Linux - Newbie 2 11-12-2006 02:25 PM
Mounting root filesystem from an external USB hard drive? ChrisHart Linux - Laptop and Netbook 6 04-02-2005 10:49 PM
Mounting USB Hard Drive in SuSE 9.1 Caboose447 Suse/Novell 4 12-13-2004 10:39 AM
Hanging Suse mounting external USB drive with RH9 on it ohagankh Linux - Hardware 3 04-13-2004 04:42 PM


All times are GMT -5. The time now is 10:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration