LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (http://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Debian Woody sound problem after clean install (http://www.linuxquestions.org/questions/linux-distributions-5/debian-woody-sound-problem-after-clean-install-30385/)

matix 09-14-2002 10:18 PM

Debian Woody sound problem after clean install
 
Greetings all !

I am new Debian Woody linux user of about a week.
I have installed a fairly default install off the 7 CDs onto 2
computer systems, both have the same problem.

The sound does not work.
Upon entering the desktop I get an informational message:

Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
The sound server will continue, using the null output device.

The message on both systems was somthing like permission
denied but I fixed that by adding the user to the sound group.

Both systems are lacking sound modules in: /lib/modules/2.2.20-idepci/

Both systems report nothing sound related from: #lsmod

Wow all that googling made me sound pretty smart just then 8)
Ok, time to go downhill :/

My assumptions are:
My kernel is not configured to use sound.
I dont have any sound modules installed.

My clueless questions are:
Can I give my kernel options using lilo to make it use sound?
Or do I need to compile my kernel, if so how does Debian do that?
(I vaguely recall something about compiling into a deb, then install from there)
Are there any Woody kernels pre-compiled floating around?
Can the sound modules be apt-get off the CDs, or do they need to be
compiled from source. If so where do I get the source, from the CDs?

I have not installed any compilers because I hate C. I assume I will
need to do so to compile things. What do I apt-get to get gcc working?
Is gcc the man for this job?

Please add letter perfect command line examples to answers.

Oh, and why in this day and age does Debian NOT install sound
on a desktop machine (even had games selected)?
(Just kidding - Debian evolution can take all the time it wants 8)

My answer to your question:
Yes I am an idiot, I know Debian is not suited to beginners. 8)

PS: Please give me a url to the expert.deb that you experts use to know
all the answers.

cheers and thanks in advance,
matix

dorward 09-14-2002 11:05 PM

Are you sure that no sound drivers are installed? It is possible that they are installed but not loaded. If so run
Code:

modconf
and install the relevent driver.

Failing that you can install a prebuilt kernel image (hopefully one that contains the driver you want!).
Code:

apt-get install kernel-image-2.4.18-686
Make sure you pick a kernel image suitable for your system!

Otherwise to compile your own kernel on a Debian system
Code:

apt-get install kernel-source
This should give you a message telling you to pick a real package along with a list of possibilities. Then
Code:

apt-get install kernel-package less gzip (and the package you picked from the above list)
zless /usr/share/doc/kernel-package/README.gz

read the instructions and do it.

matix 09-15-2002 01:30 AM

modconf brings up a nice blue screen which I remember seeing during the install.

It lists the following module categories:

block
net
fws
cdrom
misc

I have looked in each of the categories and can see nothing that I recognise as having anything to do with sound.

Am working on trying to apt-get a kernel image.
I can't find one in dselect, and apt get doesnt find one it just says:
Couldn't find package kernel-image-2.4.18-686

I need to figure out how to add more CDs to the /etc/apt/sources.list because I think I did not scan all the CDs during the install. After the fourth install it clicked that none of the other CDs were being used.

QUESTION:
Do I need to upgrade to kernel 2.4.x or should sound work fine under kernel 2.2.x. I have no idea about what kernel is what.

dorward 09-15-2002 02:41 AM

I suggest adding some Internet apt sources, the apt-spy tool shoud help you do this.

A 2.4 kernel should be find, but 2.2 should support most sound cards too.

matix 09-15-2002 03:29 AM

ok all those thinking about helping wait until I repost.

I have just discovered the uname command.
It reports that the kernel that I am using is:
kernel 2.2.20-idepci
Which, unless I'm mistaken means it does an absolute minimum of modules in it, during the intall.

btw: This was the default option when I hit enter to start the install process at the boot: prompt. Being new to it all, I had no idea what any of it meant. (I hit yes a lot during the install process 8-)

After I get myself sorted, hopefully all being well, I will post here to close this thread.

thank you for the timely responses, they were not on the money, but they made me think about the problem in the right way which led to a solution (i think- hope)

Cheers
matix

matix 09-15-2002 04:21 AM

Problem Solved

see previous post

am happy now 8-)

aliensub 09-15-2002 07:02 PM

For others with the same problem. Woody has the 2.2 kernel as default, so when you fresh install (boot from cd) write bf2.4 this will install it with the 2.4 kernel.
For a SB compatible soundcard, OSS module almost works every time.
When the system is installed, then as root write:
adduser foo audio
where foo is the user that should have the rights to using sound (remember debian is configured for security)

unolinuxguru 11-24-2002 01:31 AM

load the proper module for sound card
 
If you don't have the proper module loaded for your sound card, you will get this similiar error. "lsmod" shows the modules you are using, "modprobe" invokes a module (must be root). "modconf" will let you pick out the module you need to install via categories. i am running debian stable with a SB Live! Value card, and the module for this card is "emu10k1" for the chipset. i can find this out by checking out the dmesg, "dmesg | less" or looking into my "/proc/pci" file and looking through till I found my sound card, it sayd 'emu10k1' right next to it.

now that we know the module, we must make sure it loads everytime. adding "emu10k1" to my "/etc/modules" file seemed to do it, though there is also an "/etc/modutils/emu10k1" file that does the alias of the driver with 'sound', though shouldn't that be in /etc/modutils/aliases ? my /dev/dsp (sound) device has permissions crw-rw----, and is own'd by root to group 'audio', so they both have read/write permissions, but not all others, and no one has execute permissions. this seems to work for me, got that error message taken away. =) peace :Pengy:

macewan 11-24-2002 10:34 AM

i had same problem with es1371
during install instead of just hitting enter key (woody 3) you type bf24

the install the proper kernel module during the install process.

you need to add yourself to audio group also. other wise you get "permission denied: /dev/dsp" error if you boot kde or try to use sound.


All times are GMT -5. The time now is 08:43 PM.