LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (http://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   CentOS comps.xml (http://www.linuxquestions.org/questions/linux-distributions-5/centos-comps-xml-910250/)

mah454 10-26-2011 08:05 AM

CentOS comps.xml
 
Hello ...
I have a big problem with comps.xml .
I downloaded CentOS-6.0-i386-minimal.iso and extract this on $BASE
now download some package + dependency and add on $BASE/Packages .
and check dependency with this help :
Check RPM Dependency with out install
Note : I have not ony dependency

now edit comps.xml : (this is my comps.xml)
Code:

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE comps PUBLIC "-//CentOS//DTD Comps info//EN" "comps.dtd">
<comps>
  <group>
    <id>core</id>
    <name>Core</name>
 <description/>
    <default>true</default>
    <uservisible>false</uservisible>
    <packagelist>
                        <packagereq type="mandatory">acl</packagereq>
                        <packagereq type="mandatory">aic94xx-firmware</packagereq>
                        <packagereq type="mandatory">attr</packagereq>
                        <packagereq type="mandatory">audit</packagereq>
                        <packagereq type="mandatory">audit-libs</packagereq>
                        <packagereq type="mandatory">authconfig</packagereq>
                        <packagereq type="mandatory">basesystem</packagereq>
                        <packagereq type="mandatory">Base.xml</packagereq>
                        <packagereq type="mandatory">bash</packagereq>
                        <packagereq type="mandatory">bfa-firmware</packagereq>
                        <packagereq type="mandatory">binutils</packagereq>
                        <packagereq type="mandatory">bridge-utils</packagereq>
                        <packagereq type="mandatory">bzip2</packagereq>
                        <packagereq type="mandatory">bzip2-libs</packagereq>
                        <packagereq type="mandatory">ca-certificates</packagereq>
                        <packagereq type="mandatory">centos-release</packagereq>
                        <packagereq type="mandatory">checkpolicy</packagereq>
                        <packagereq type="mandatory">chkconfig</packagereq>
                        <packagereq type="mandatory">coreutils</packagereq>
                        <packagereq type="mandatory">coreutils-libs</packagereq>
                        <packagereq type="mandatory">cpio</packagereq>
                        <packagereq type="mandatory">cracklib</packagereq>
                        <packagereq type="mandatory">cracklib-dicts</packagereq>
                        <packagereq type="mandatory">cryptsetup-luks</packagereq>
                        <packagereq type="mandatory">cryptsetup-luks-libs</packagereq>
                        <packagereq type="mandatory">curl</packagereq>
                        <packagereq type="mandatory">cyrus-sasl-lib</packagereq>
                        <packagereq type="mandatory">dash</packagereq>
                        <packagereq type="mandatory">db4</packagereq>
                        <packagereq type="mandatory">db4-utils</packagereq>
                        <packagereq type="mandatory">dbus-glib</packagereq>
                        <packagereq type="mandatory">dbus-libs</packagereq>
                        <packagereq type="mandatory">deltarpm</packagereq>
                        <packagereq type="mandatory">device-mapper</packagereq>
                        <packagereq type="mandatory">device-mapper-event</packagereq>
                        <packagereq type="mandatory">device-mapper-event-libs</packagereq>
                        <packagereq type="mandatory">device-mapper-libs</packagereq>
                        <packagereq type="mandatory">device-mapper-multipath</packagereq>
                        <packagereq type="mandatory">device-mapper-multipath-libs</packagereq>
                        <packagereq type="mandatory">dhclient</packagereq>
                        <packagereq type="mandatory">diffutils</packagereq>
                        <packagereq type="mandatory">dracut</packagereq>
                        <packagereq type="mandatory">dracut-kernel</packagereq>
                        <packagereq type="mandatory">dracut-network</packagereq>
                        <packagereq type="mandatory">e2fsprogs</packagereq>
                        <packagereq type="mandatory">e2fsprogs-libs</packagereq>
                        <packagereq type="mandatory">efibootmgr</packagereq>
                        <packagereq type="mandatory">elfutils-libelf</packagereq>
                        <packagereq type="mandatory">ethtool</packagereq>
                        <packagereq type="mandatory">expat</packagereq>
                        <packagereq type="mandatory">fcoe-utils</packagereq>
                        <packagereq type="mandatory">file-libs</packagereq>
                        <packagereq type="mandatory">filesystem</packagereq>
                        <packagereq type="mandatory">findutils</packagereq>
                        <packagereq type="mandatory">fipscheck</packagereq>
                        <packagereq type="mandatory">fipscheck-lib</packagereq>
                        <packagereq type="mandatory">gamin</packagereq>
                        <packagereq type="mandatory">gawk</packagereq>
                        <packagereq type="mandatory">gdbm</packagereq>
                        <packagereq type="mandatory">glib2</packagereq>
                        <packagereq type="mandatory">glibc</packagereq>
                        <packagereq type="mandatory">glibc-common</packagereq>
                        <packagereq type="mandatory">gmp</packagereq>
                        <packagereq type="mandatory">gnupg2</packagereq>
                        <packagereq type="mandatory">gpgme</packagereq>
                        <packagereq type="mandatory">grep</packagereq>
                        <packagereq type="mandatory">groff</packagereq>
                        <packagereq type="mandatory">grub</packagereq>
                        <packagereq type="mandatory">grubby</packagereq>
                        <packagereq type="mandatory">gzip</packagereq>
                        <packagereq type="mandatory">hwdata</packagereq>
                        <packagereq type="mandatory">info</packagereq>
                        <packagereq type="mandatory">initscripts</packagereq>
                        <packagereq type="mandatory">iproute</packagereq>
                        <packagereq type="mandatory">iptables</packagereq>
                        <packagereq type="mandatory">iptables-ipv6</packagereq>
                        <packagereq type="default">iputils</packagereq>
                        <packagereq type="mandatory">iscsi-initiator-utils</packagereq>
                        <packagereq type="default">kbd</packagereq>
                        <packagereq type="default">kbd-misc</packagereq>
                        <packagereq type="mandatory">kernel</packagereq>
                        <packagereq type="mandatory">kernel-firmware</packagereq>
                        <packagereq type="mandatory">keyutils-libs</packagereq>
                        <packagereq type="mandatory">kpartx</packagereq>
                        <packagereq type="mandatory">krb5-libs</packagereq>
                        <packagereq type="default">less</packagereq>
                        <packagereq type="mandatory">libacl</packagereq>
                        <packagereq type="mandatory">libaio</packagereq>
                        <packagereq type="mandatory">libattr</packagereq>
                        <packagereq type="mandatory">libblkid</packagereq>
                        <packagereq type="mandatory">libcap</packagereq>
                        <packagereq type="mandatory">libcap-ng</packagereq>
                        <packagereq type="mandatory">libcgroup</packagereq>
                        <packagereq type="mandatory">libcom_err</packagereq>
                        <packagereq type="mandatory">libconfig</packagereq>
                        <packagereq type="mandatory">libcurl</packagereq>
                        <packagereq type="mandatory">libdrm</packagereq>
                        <packagereq type="mandatory">libedit</packagereq>
                        <packagereq type="mandatory">libevent</packagereq>
                        <packagereq type="mandatory">libffi</packagereq>
                        <packagereq type="mandatory">libgcc</packagereq>
                        <packagereq type="mandatory">libgcrypt</packagereq>
                        <packagereq type="mandatory">libgpg-error</packagereq>
                        <packagereq type="mandatory">libgssglue</packagereq>
                        <packagereq type="mandatory">libhbaapi</packagereq>
                        <packagereq type="default">libhbalinux</packagereq>
                        <packagereq type="mandatory">libidn</packagereq>
                        <packagereq type="mandatory">libnih</packagereq>
                        <packagereq type="mandatory">libpciaccess</packagereq>
                        <packagereq type="mandatory">libselinux</packagereq>
                        <packagereq type="mandatory">libselinux-utils</packagereq>
                        <packagereq type="mandatory">libsemanage</packagereq>
                        <packagereq type="mandatory">libsepol</packagereq>
                        <packagereq type="mandatory">libss</packagereq>
                        <packagereq type="mandatory">libssh2</packagereq>
                        <packagereq type="mandatory">libstdc++</packagereq>
                        <packagereq type="mandatory">libtirpc</packagereq>
                        <packagereq type="mandatory">libudev</packagereq>
                        <packagereq type="mandatory">libusb</packagereq>
                        <packagereq type="default">libuser</packagereq>
                        <packagereq type="mandatory">libutempter</packagereq>
                        <packagereq type="mandatory">libuuid</packagereq>
                        <packagereq type="mandatory">libxml2</packagereq>
                        <packagereq type="mandatory">lldpad</packagereq>
                        <packagereq type="mandatory">logrotate</packagereq>
                        <packagereq type="mandatory">lua</packagereq>
                        <packagereq type="mandatory">lvm2</packagereq>
                        <packagereq type="mandatory">lvm2-libs</packagereq>
                        <packagereq type="mandatory">m4</packagereq>
                        <packagereq type="mandatory">MAKEDEV</packagereq>
                        <packagereq type="mandatory">man</packagereq>
                        <packagereq type="mandatory">mdadm</packagereq>
                        <packagereq type="mandatory">mingetty</packagereq>
                        <packagereq type="mandatory">mlocate</packagereq>
                        <packagereq type="mandatory">module-init-tools</packagereq>
                        <packagereq type="mandatory">ncurses</packagereq>
                        <packagereq type="mandatory">ncurses-base</packagereq>
                        <packagereq type="mandatory">ncurses-libs</packagereq>
                        <packagereq type="mandatory">net-tools</packagereq>
                        <packagereq type="mandatory">newt</packagereq>
                        <packagereq type="mandatory">newt-python</packagereq>
                        <packagereq type="mandatory">nfs-utils</packagereq>
                        <packagereq type="mandatory">nfs-utils-lib</packagereq>
                        <packagereq type="mandatory">nspr</packagereq>
                        <packagereq type="mandatory">nss</packagereq>
                        <packagereq type="mandatory">nss-softokn</packagereq>
                        <packagereq type="mandatory">nss-softokn-freebl</packagereq>
                        <packagereq type="mandatory">nss-sysinit</packagereq>
                        <packagereq type="mandatory">nss-util</packagereq>
                        <packagereq type="mandatory">openldap</packagereq>
                        <packagereq type="mandatory">openssh</packagereq>
                        <packagereq type="default">openssh-clients</packagereq>
                        <packagereq type="mandatory">openssh-server</packagereq>
                        <packagereq type="mandatory">openssl</packagereq>
                        <packagereq type="mandatory">pam</packagereq>
                        <packagereq type="mandatory">passwd</packagereq>
                        <packagereq type="mandatory">pciutils-libs</packagereq>
                        <packagereq type="mandatory">pcre</packagereq>
                        <packagereq type="mandatory">perl</packagereq>
                        <packagereq type="mandatory">perl-DBI</packagereq>
                        <packagereq type="default">perl-libs</packagereq>
                        <packagereq type="mandatory">perl-Module-Pluggable</packagereq>
                        <packagereq type="mandatory">perl-Pod-Escapes</packagereq>
                        <packagereq type="mandatory">perl-Pod-Simple</packagereq>
                        <packagereq type="mandatory">perl-version</packagereq>
                        <packagereq type="mandatory">pinentry</packagereq>
                        <packagereq type="mandatory">plymouth</packagereq>
                        <packagereq type="mandatory">plymouth-core-libs</packagereq>
                        <packagereq type="mandatory">plymouth-scripts</packagereq>
                        <packagereq type="mandatory">policycoreutils</packagereq>
                        <packagereq type="mandatory">popt</packagereq>
                        <packagereq type="mandatory">procps</packagereq>
                        <packagereq type="mandatory">psmisc</packagereq>
                        <packagereq type="default">pth</packagereq>
                        <packagereq type="mandatory">pygpgme</packagereq>
                        <packagereq type="mandatory">python</packagereq>
                        <packagereq type="mandatory">python-iniparse</packagereq>
                        <packagereq type="mandatory">python-libs</packagereq>
                        <packagereq type="mandatory">python-pycurl</packagereq>
                        <packagereq type="default">python-urlgrabber</packagereq>
                        <packagereq type="default">ql2100-firmware</packagereq>
                        <packagereq type="default">ql2200-firmware</packagereq>
                        <packagereq type="default">ql23xx-firmware</packagereq>
                        <packagereq type="default">ql2400-firmware</packagereq>
                        <packagereq type="default">ql2500-firmware</packagereq>
                        <packagereq type="mandatory">readline</packagereq>
                        <packagereq type="mandatory">redhat-logos</packagereq>
                        <packagereq type="mandatory">rootfiles</packagereq>
                        <packagereq type="mandatory">rpcbind</packagereq>
                        <packagereq type="mandatory">rpm</packagereq>
                        <packagereq type="mandatory">rpm-libs</packagereq>
                        <packagereq type="mandatory">rpm-python</packagereq>
                        <packagereq type="mandatory">rsyslog</packagereq>
                        <packagereq type="mandatory">sed</packagereq>
                        <packagereq type="mandatory">selinux-policy</packagereq>
                        <packagereq type="mandatory">selinux-policy-targeted</packagereq>
                        <packagereq type="mandatory">setup</packagereq>
                        <packagereq type="mandatory">shadow-utils</packagereq>
                        <packagereq type="mandatory">slang</packagereq>
                        <packagereq type="mandatory">sqlite</packagereq>
                        <packagereq type="mandatory">system-config-firewall-base</packagereq>
                        <packagereq type="mandatory">sysvinit-tools</packagereq>
                        <packagereq type="mandatory">tar</packagereq>
                        <packagereq type="mandatory">tcp_wrappers-libs</packagereq>
                        <packagereq type="mandatory">tzdata</packagereq>
                        <packagereq type="mandatory">udev</packagereq>
                        <packagereq type="mandatory">upstart</packagereq>
                        <packagereq type="mandatory">ustr</packagereq>
                        <packagereq type="mandatory">util-linux-ng</packagereq>
                        <packagereq type="mandatory">vconfig</packagereq>
                        <packagereq type="mandatory">vim-minimal</packagereq>
                        <packagereq type="mandatory">which</packagereq>
                        <packagereq type="mandatory">xz</packagereq>
                        <packagereq type="mandatory">xz-libs</packagereq>
                        <packagereq type="mandatory">xz-lzma-compat</packagereq>
                        <packagereq type="mandatory">yum</packagereq>
                        <packagereq type="mandatory">yum-metadata-parser</packagereq>
                        <packagereq type="default">yum-plugin-fastestmirror</packagereq>
                        <packagereq type="mandatory">yum-presto</packagereq>
                        <packagereq type="mandatory">zlib</packagereq>
                        <packagereq type="default">abrt</packagereq>
                        <packagereq type="default">abrt-addon-ccpp</packagereq>
                        <packagereq type="default">abrt-addon-kerneloops</packagereq>
                        <packagereq type="default">abrt-addon-python</packagereq>
                        <packagereq type="default">abrt-cli</packagereq>
                        <packagereq type="default">abrt-libs</packagereq>
                        <packagereq type="default">abrt-plugin-logger</packagereq>
                        <packagereq type="default">abrt-plugin-rhtsupport</packagereq>
                        <packagereq type="default">abrt-plugin-sosreport</packagereq>
                        <packagereq type="default">acpid</packagereq>
                        <packagereq type="default">alsa-lib</packagereq>
                        <packagereq type="default">alsa-utils</packagereq>
                        <packagereq type="default">apr</packagereq>
                        <packagereq type="default">apr-util</packagereq>
                        <packagereq type="default">apr-util-ldap</packagereq>
                        <packagereq type="default">aspell</packagereq>
                        <packagereq type="default">at</packagereq>
                        <packagereq type="default">atk</packagereq>
                        <packagereq type="default">avahi</packagereq>
                        <packagereq type="default">avahi-libs</packagereq>
                        <packagereq type="default">b43-fwcutter</packagereq>
                        <packagereq type="default">bc</packagereq>
                        <packagereq type="default">bind-libs</packagereq>
                        <packagereq type="default">bind-utils</packagereq>
                        <packagereq type="default">blktrace</packagereq>
                        <packagereq type="default">busybox</packagereq>
                        <packagereq type="default">bwidget</packagereq>
                        <packagereq type="default">cairo</packagereq>
                        <packagereq type="default">centos-indexhtml</packagereq>
                        <packagereq type="default">compat-openldap</packagereq>
                        <packagereq type="default">compat-readline5</packagereq>
                        <packagereq type="default">ConsoleKit</packagereq>
                        <packagereq type="default">ConsoleKit-libs</packagereq>
                        <packagereq type="default">cpuspeed</packagereq>
                        <packagereq type="default">crda</packagereq>
                        <packagereq type="default">cronie</packagereq>
                        <packagereq type="default">cronie-anacron</packagereq>
                        <packagereq type="default">crontabs</packagereq>
                        <packagereq type="default">crypto-utils</packagereq>
                        <packagereq type="default">cups-libs</packagereq>
                        <packagereq type="default">cvs</packagereq>
                        <packagereq type="default">cyrus-sasl</packagereq>
                        <packagereq type="default">cyrus-sasl-plain</packagereq>
                        <packagereq type="default">dbus</packagereq>
                        <packagereq type="default">dbus-python</packagereq>
                        <packagereq type="default">desktop-file-utils</packagereq>
                        <packagereq type="default">dhcp</packagereq>
                        <packagereq type="default">dmidecode</packagereq>
                        <packagereq type="default">dmraid</packagereq>
                        <packagereq type="default">dmraid-events</packagereq>
                        <packagereq type="default">dosfstools</packagereq>
                        <packagereq type="default">ed</packagereq>
                        <packagereq type="default">eggdbus</packagereq>
                        <packagereq type="default">eject</packagereq>
                        <packagereq type="default">elfutils</packagereq>
                        <packagereq type="default">elfutils-devel</packagereq>
                        <packagereq type="default">elfutils-libelf-devel</packagereq>
                        <packagereq type="default">elfutils-libs</packagereq>
                        <packagereq type="default">file</packagereq>
                        <packagereq type="default">file-devel</packagereq>
                        <packagereq type="default">fontconfig</packagereq>
                        <packagereq type="default">fprintd</packagereq>
                        <packagereq type="default">fprintd-pam</packagereq>
                        <packagereq type="default">freetype</packagereq>
                        <packagereq type="default">gc</packagereq>
                        <packagereq type="default">gd</packagereq>
                        <packagereq type="default">gettext</packagereq>
                        <packagereq type="default">gnutls</packagereq>
                        <packagereq type="default">gpm-libs</packagereq>
                        <packagereq type="default">gtk2</packagereq>
                        <packagereq type="default">hal</packagereq>
                        <packagereq type="default">hal-info</packagereq>
                        <packagereq type="default">hal-libs</packagereq>
                        <packagereq type="default">hdparm</packagereq>
                        <packagereq type="default">hesiod</packagereq>
                        <packagereq type="default">hicolor-icon-theme</packagereq>
                        <packagereq type="default">httpd</packagereq>
                        <packagereq type="default">httpd-tools</packagereq>
                        <packagereq type="default">hunspell</packagereq>
                        <packagereq type="default">iptstate</packagereq>
                        <packagereq type="default">irqbalance</packagereq>
                        <packagereq type="default">iw</packagereq>
                        <packagereq type="default">jasper-libs</packagereq>
                        <packagereq type="default">kexec-tools</packagereq>
                        <packagereq type="default">keyutils-libs-devel</packagereq>
                        <packagereq type="default">krb5-devel</packagereq>
                        <packagereq type="default">libcom_err-devel</packagereq>
                        <packagereq type="default">libdaemon</packagereq>
                        <packagereq type="default">libfprint</packagereq>
                        <packagereq type="default">libglade2</packagereq>
                        <packagereq type="default">libgomp</packagereq>
                        <packagereq type="default">libjpeg</packagereq>
                        <packagereq type="default">libnetfilter_conntrack</packagereq>
                        <packagereq type="default">libnfnetlink</packagereq>
                        <packagereq type="default">libnl</packagereq>
                        <packagereq type="default">libpcap</packagereq>
                        <packagereq type="default">libpng</packagereq>
                        <packagereq type="default">libselinux-devel</packagereq>
                        <packagereq type="default">libsepol-devel</packagereq>
                        <packagereq type="default">libtar</packagereq>
                        <packagereq type="default">libtasn1</packagereq>
                        <packagereq type="default">libthai</packagereq>
                        <packagereq type="default">libtiff</packagereq>
                        <packagereq type="default">libtool-ltdl</packagereq>
                        <packagereq type="default">libusb1</packagereq>
                        <packagereq type="default">libX11</packagereq>
                        <packagereq type="default">libX11-common</packagereq>
                        <packagereq type="default">libXau</packagereq>
                        <packagereq type="default">libxcb</packagereq>
                        <packagereq type="default">libXcomposite</packagereq>
                        <packagereq type="default">libXcursor</packagereq>
                        <packagereq type="default">libXdamage</packagereq>
                        <packagereq type="default">libXext</packagereq>
                        <packagereq type="default">libXfixes</packagereq>
                        <packagereq type="default">libXft</packagereq>
                        <packagereq type="default">libXi</packagereq>
                        <packagereq type="default">libXinerama</packagereq>
                        <packagereq type="default">libxml2-python</packagereq>
                        <packagereq type="default">libXpm</packagereq>
                        <packagereq type="default">libXrandr</packagereq>
                        <packagereq type="default">libXrender</packagereq>
                        <packagereq type="default">lm_sensors-devel</packagereq>
                        <packagereq type="default">lm_sensors-libs</packagereq>
                        <packagereq type="mandatory">lsof</packagereq>
                        <packagereq type="default">lynx</packagereq>
                        <packagereq type="default">mailcap</packagereq>
                        <packagereq type="default">mailx</packagereq>
                        <packagereq type="default">make</packagereq>
                        <packagereq type="default">man-pages</packagereq>
                        <packagereq type="default">man-pages-overrides</packagereq>
                        <packagereq type="default">mdadm</packagereq>
                        <packagereq type="default">microcode_ctl</packagereq>
                        <packagereq type="default">mod_perl</packagereq>
                        <packagereq type="default">mod_ssl</packagereq>
                        <packagereq type="mandatory">mrtg</packagereq>
                        <packagereq type="default">mrtg-libs</packagereq>
                        <packagereq type="default">mtr</packagereq>
                        <packagereq type="default">mysql-libs</packagereq>
                        <packagereq type="default">nano</packagereq>
                        <packagereq type="default">net-snmp</packagereq>
                        <packagereq type="default">net-snmp-devel</packagereq>
                        <packagereq type="default">net-snmp-libs</packagereq>
                        <packagereq type="default">nmap</packagereq>
                        <packagereq type="default">ntsysv</packagereq>
                        <packagereq type="default">openssl098e</packagereq>
                        <packagereq type="default">openssl-devel</packagereq>
                        <packagereq type="default">pam_passwdqc</packagereq>
                        <packagereq type="default">pango</packagereq>
                        <packagereq type="default">parted</packagereq>
                        <packagereq type="default">patch</packagereq>
                        <packagereq type="default">pax</packagereq>
                        <packagereq type="default">pciutils</packagereq>
                        <packagereq type="default">pcmciautils</packagereq>
                        <packagereq type="default">perl-BSD-Resource</packagereq>
                        <packagereq type="default">perl-DBD-MySQL</packagereq>
                        <packagereq type="default">perl-devel</packagereq>
                        <packagereq type="default">perl-ExtUtils-MakeMaker</packagereq>
                        <packagereq type="default">perl-ExtUtils-ParseXS</packagereq>
                        <packagereq type="default">perl-IO-Socket-INET6</packagereq>
                        <packagereq type="default">perl-MailTools</packagereq>
                        <packagereq type="default">perl-Newt</packagereq>
                        <packagereq type="default">perl-SNMP_Session</packagereq>
                        <packagereq type="default">perl-Socket6</packagereq>
                        <packagereq type="default">perl-Test-Harness</packagereq>
                        <packagereq type="default">perl-TimeDate</packagereq>
                        <packagereq type="default">perl-URI</packagereq>
                        <packagereq type="default">php-common</packagereq>
                        <packagereq type="default">php-mysql</packagereq>
                        <packagereq type="default">php-pdo</packagereq>
                        <packagereq type="default">php-pgsql</packagereq>
                        <packagereq type="default">pinfo</packagereq>
                        <packagereq type="default">pixman</packagereq>
                        <packagereq type="default">pkgconfig</packagereq>
                        <packagereq type="default">pm-utils</packagereq>
                        <packagereq type="default">polkit</packagereq>
                        <packagereq type="default">popt-devel</packagereq>
                        <packagereq type="default">postfix</packagereq>
                        <packagereq type="default">postgresql-libs</packagereq>
                        <packagereq type="default">ppp</packagereq>
                        <packagereq type="default">prelink</packagereq>
                        <packagereq type="default">procmail</packagereq>
                        <packagereq type="default">psacct</packagereq>
                        <packagereq type="default">python-ethtool</packagereq>
                        <packagereq type="default">python-iwlib</packagereq>
                        <packagereq type="default">quota</packagereq>
                        <packagereq type="default">rdate</packagereq>
                        <packagereq type="default">readahead</packagereq>
                        <packagereq type="default">redhat-lsb</packagereq>
                        <packagereq type="default">rfkill</packagereq>
                        <packagereq type="default">rng-tools</packagereq>
                        <packagereq type="default">rpm-devel</packagereq>
                        <packagereq type="default">rsync</packagereq>
                        <packagereq type="default">rsyslog-mysql</packagereq>
                        <packagereq type="default">sendmail</packagereq>
                        <packagereq type="default">sendmail-cf</packagereq>
                        <packagereq type="default">setools</packagereq>
                        <packagereq type="default">setools-console</packagereq>
                        <packagereq type="default">setools-gui</packagereq>
                        <packagereq type="default">setools-libs</packagereq>
                        <packagereq type="default">setools-libs-tcl</packagereq>
                        <packagereq type="default">setserial</packagereq>
                        <packagereq type="default">setuptool</packagereq>
                        <packagereq type="default">sgml-common</packagereq>
                        <packagereq type="default">sgpio</packagereq>
                        <packagereq type="default">smartmontools</packagereq>
                        <packagereq type="default">sos</packagereq>
                        <packagereq type="default">sqlite-devel</packagereq>
                        <packagereq type="default">strace</packagereq>
                        <packagereq type="default">sysstat</packagereq>
                        <packagereq type="default">system-config-firewall-tui</packagereq>
                        <packagereq type="default">system-config-network-tui</packagereq>
                        <packagereq type="default">systemtap-runtime</packagereq>
                        <packagereq type="default">tcl</packagereq>
                        <packagereq type="default">tcpdump</packagereq>
                        <packagereq type="default">tcp_wrappers</packagereq>
                        <packagereq type="default">tcp_wrappers-devel</packagereq>
                        <packagereq type="default">tcsh</packagereq>
                        <packagereq type="default">time</packagereq>
                        <packagereq type="default">tk</packagereq>
                        <packagereq type="default">tmpwatch</packagereq>
                        <packagereq type="default">traceroute</packagereq>
                        <packagereq type="default">unixODBC</packagereq>
                        <packagereq type="default">unixODBC-devel</packagereq>
                        <packagereq type="default">unzip</packagereq>
                        <packagereq type="default">usbutils</packagereq>
                        <packagereq type="default">usermode</packagereq>
                        <packagereq type="default">vim-common</packagereq>
                        <packagereq type="default">vim-enhanced</packagereq>
                        <packagereq type="default">w3m</packagereq>
                        <packagereq type="default">wget</packagereq>
                        <packagereq type="default">wireless-tools</packagereq>
                        <packagereq type="default">words</packagereq>
                        <packagereq type="default">xdg-utils</packagereq>
                        <packagereq type="default">xml-common</packagereq>
                        <packagereq type="default">xmlrpc-c</packagereq>
                        <packagereq type="default">xmlrpc-c-client</packagereq>
                        <packagereq type="default">yum-utils</packagereq>
                        <packagereq type="default">zip</packagereq>
                        <packagereq type="default">zlib-devel</packagereq>
  </packagelist>
  </group>

<category>
    <id>core</id>
    <name>Core</name>
    <description>server packages set</description>
    <display_order>60</display_order>
    <grouplist>
      <groupid>core</groupid>
    </grouplist>
  </category>
</comps>

now create new repository and make bootable iso .
but when install new iso , I receive this message :
Quote:

The file Package-<Version>.rpm cannot be opened . Thie is due to a missing file a corrupt package or corrupt media . Okease verify your installation source .
If you exit , Your systen will be left in a inconsistent state that will likely require reinstallation .
for example : this error is for kbd package ...
I changed comps.xml <mandatory> to <default> but receive another error for another package !
If my comps.xml have problem . can you edit my comps.xml and give me better of this file !
because I can not fix this !:banghead:

kbp 10-26-2011 08:27 AM

When you ran createrepo did you use the '-g' switch ?

mah454 10-26-2011 09:17 AM

yes ...
I use this command :
Code:

createrepo -g $BASE/repodata/comps.xml -o . Packages/
this command worked without ony problem .

kbp 10-26-2011 09:51 AM

The message could have a couple of causes, have a read of this regarding editing comps.xml, also did you run genhdlist and pkgorder? Personally, I've never bothered going to the trouble of hacking the original repo on the media, it's simple enough to set up a new repo and add it. It could also be the way you created the iso, did you include the hidden file '.discinfo'?

mah454 10-29-2011 05:25 AM

I fixed this problem .
but receive another error :
Code:

A fatal error occured when installing the net-snmp-libs package. This could indicate errors when reading installation media. Setup cannot continue.

kbp 11-01-2011 06:25 PM

It may be worth posting how you fixed the problem in case someone else finds this thread .. can you confirm that the package is present and valid?

grejon04 08-01-2013 10:40 PM

Quote:

Originally Posted by mah454 (Post 4508843)
yes ...
I use this command :
Code:

createrepo -g $BASE/repodata/comps.xml -o . Packages/
this command worked without ony problem .

This is an old thread, but I recently was searching for this same issue, and this post comes up in top results, so I'll post this for closure, and hopefully this will save someone else time searching;

the solution is that while createrepo will work with that syntax, if that target is not the base of the build directory, you will get the corrupted error. You need to run createrepo with the build base directory as the target, and it will automatically find the rpm's in Packages.

Navigate to build dir, and:

Code:

createrepo -g comps.xml .
Will fix that issue.


All times are GMT -5. The time now is 06:06 AM.