LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (http://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Cent OS GLib 2.12.3 pkg-config --modversion glib-2.0' returned 2.22.2 (http://www.linuxquestions.org/questions/linux-distributions-5/cent-os-glib-2-12-3-pkg-config-modversion-glib-2-0-returned-2-22-2-a-760673/)

Styles 10-08-2009 08:42 PM

Cent OS GLib 2.12.3 pkg-config --modversion glib-2.0' returned 2.22.2
 
Alright, so I'm trying to install Irssi on my Cent OS box. I run cPanel on it too. I tried to install it, andi t said I don't have Glib installed, so I tried yum install glib-d* grabbed it. Then, it still didn't work and I read to manually install it. So I grabed the source, ./configure ... ect.. make ... make install.

Boom didn't work. I read further the pgkconfig needed to be updated so I then ran.

export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig

It went to compile Irss again, and got

Quote:

checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.7... yes
checking for GLIB - version >= 2.6.0...
*** 'pkg-config --modversion glib-2.0' returned 2.22.2, but GLIB (2.12.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no

*** If you don't have GLIB, you can get it from ftp://ftp.gtk.org/pub/glib/
*** We recommend you get the latest stable GLIB 2 version.
*** Compile and install it, and make sure pkg-config finds it,
*** by adding the path where the .pc file is located to PKG_CONFIG_PATH
I'm at a loss and I certainly don't want to break my cPanel install.

Any ideas // help? Have I already possibly broken it? I don't think GLib is required for cPanel... so I doubt it.

knudfl 10-09-2009 03:12 AM

Quote:

checking for GLIB - version >= 2.6.0
Means, that the system version is OK.
Should be any later than 2.6 or just version 2.6 !

# yum install glib2-devel
.. will provide 2.12.3.

( # 'yum install glib-d*' gets : "old style" = version 1.2.10.)
.....

And better delete all the glib-2.22 files in /usr/local/lib.
Having an extra glib2 in a system path can ( will ) trash
applications.
Extra glib / gtk versions are supposed to be created with e.g.
' .configure --prefix=/usr/local/glib222/ '
.....
Good luck.
.....


All times are GMT -5. The time now is 09:17 AM.