LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices



Reply
 
Search this Thread
Old 04-15-2005, 09:33 PM   #1
zhex900
LQ Newbie
 
Registered: Nov 2004
Posts: 16

Rep: Reputation: 0
Bring up eth0, but no network connection


I can bring up my eth0 but I only can ping itself. I cannot ping even the router. I have two ethernet cards, I want to get both of them working. Can some please help me. As you can see I am using static ip. I cannot even bring up eth0 using DHCP.

Code:
%cat /etc/resolv.conf
search nsw.optushome.com.au
nameserver 203.2.75.132
nameserver 198.142.0.51
Code:
%lspci | grep Ethernet
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL -8129/8139C/8139C+ (rev10)
00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL -8129/8139C/8139C+ (rev10)
Code:
%ifconfg
eth0 Link encap:Ethernet HWaddr 00:02:44:11:DD:24
inet6 addr: fe80::202:44ff:fe11:dd24/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:195 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b ) TX bytes:33386 (32.6 Kb)
Interrupt:9 Base address:0x9f00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:243 errors:0 dropped:0 overruns:0 frame:0
TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:20570 (20.0 Kb) TX bytes:20570 (20.0 Kb)
Code:
#cat /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.11
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
onBOOT=yes
MII_NOT_SUPPORTED=yes
Code:
# route
Kernel IP routing table
Destination        Gateway           Genmask     Flags Metric Ref Use Iface
192.168.0.0       * 255.255.255.0                  U 0 0 0 eth0
127.0.0.0           *                     255.0.0.0    U 0 0 0 lo
default               192.168.0.1      0.0.0.0       UG 0 0 0 eth0
Code:
%time /etc/init.d/network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Setting network parameters: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: [ OK ]
1.90user 0.66system 1:38.44elapsed 2%CPU (0avgtext+0avgdata 0maxresident)k
0inputs+0outputs (0major+64810minor)pagefaults 0swap
Code:
% /etc/init.d/network status
Configured devices:
lo eth0
Currently active devices:
lo eth0

Last edited by zhex900; 04-15-2005 at 09:35 PM.
 
Old 04-15-2005, 10:39 PM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
can you set it on the command line ifconfig eth0 192.168.0.11 netmask 255.255.255.0

Does that do anything? Basically it will let us know if the card just won't accept an IP.
 
Old 04-22-2005, 08:05 PM   #3
zhex900
LQ Newbie
 
Registered: Nov 2004
Posts: 16

Original Poster
Rep: Reputation: 0
It still doesn't work.

I can't even ping the gateway.
 
Old 04-22-2005, 08:34 PM   #4
ralvez
Member
 
Registered: Oct 2003
Location: Canada
Distribution: ArchLinux && Slackware 10.1
Posts: 298

Rep: Reputation: 30
In looking at the config files you show the only thing that does not seem correct is the line that states the info of your nic. It should show something like : inet addr:192.168.0.11 Bcast:192.168.0.255 Mask:255.255.255.0 but it does not, instead you get :eth0 Link encap:Ethernet HWaddr 00:02:44:11D:24
inet6 addr: fe80::202:44ff:fe11:dd24/64 Scope:Link

Assuming you have checked the obvious (wires, connectors, switch, etc.) I would replace the card just to make sure it is OK.
MHO.

R.
 
Old 04-24-2005, 09:12 AM   #5
zhex900
LQ Newbie
 
Registered: Nov 2004
Posts: 16

Original Poster
Rep: Reputation: 0
Thank you very much for you reminder. Silly me, the cable wasn't plugged in probably. Now it works fine.
 
Old 04-24-2005, 04:33 PM   #6
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
LMAO

I'll give you credit, at least you're big enough to admit it.

I think we've all pulled doh! like this one once or twice.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot bring up Eth0 jamespetts Linux - Networking 7 08-03-2004 06:42 AM
can not bring up eth0 summerfish Linux - Networking 2 07-19-2004 11:09 PM
failed to bring eth0 up k_brother Linux - Newbie 2 10-17-2003 11:30 AM
Cannot bring up eth0 using DHCP gigem2000 Linux - Networking 1 11-10-2001 08:51 AM
Can't bring up eth0 cyrano Linux - Networking 4 08-21-2001 11:21 AM


All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration