LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on...

Notices

Reply
 
Search this Thread
Old 12-23-2008, 08:11 AM   #1
keithmcd
LQ Newbie
 
Registered: May 2005
Location: /home/keith
Distribution: Debian Etch, SLC4, OS X 10.5
Posts: 24

Rep: Reputation: 15
Alter video card device id to load nv driver


Hi there,

I have a Scientific Linux machine (essentially RHEL4). I am not wanting to install the nvidia driver as I do not want to be updating the driver every time there is a kernel update. So, I'm trying to get the nv driver to work.

The problem is that the machines came with a Quadro NVS 290. This is slightly newer than the installed version of nv can handle. So, I'm trying to force it. I figure that if I can change the device_id of the card to 0165 (Quadro NVS 285) that that should work good as it's a close card and it's supported by the driver.

I've tried the following syntax along with a few variations with no results. It outputs what looks like a change, but when I probe for the value it's always the original value. (Need to change device_id from 042f to 0165)

Code:
$ sudo /sbin/setpci -v -s 1:0 device_id.W=0x0165
01:00.0:02 0165

$ /sbin/lspci -n
01:00.0 Class 0300: 10de:042f (rev a1)

$ /sbin/lspci -v
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 290 (rev a1) (prog-if 00 [VGA controller])
        Subsystem: nVidia Corporation: Unknown device 0492
        Flags: fast devsel, IRQ 169
        Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
        I/O ports at dc80 [size=128]
        Expansion ROM at fde00000 [disabled] [size=128K]
        Capabilities: <available only to root>
If this isn't possible, I'm up for suggestions on other ways to get this to work. These machines have to be updatable through yum without requiring constant recompilation which is why I thought this was the best way to avoid all that.

Thanks,
Keith
 
Old 12-24-2008, 06:09 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Do you have a need for hardware acceleration? If not then just use what your distribution provides. If you can get 32 bit color depth at the resolution that you want to use then stay with that. Hence the expression if it works then don't fix it.

If you have the "good" Nvidia module installed then move the "bad" one to some unusual place such as your home directory. That might force the o/s to load the one that you want.

Your /etc/X11/xorg.conf file should, in part, look like this.
Code:
Section "Device"
        Identifier      "Configured Video Device"
        Driver          "nv"
        Option          "NoLogo"        "True"
You could always use a distribution where graphic card driver management is more to your liking. Ubuntu/Kubuntu/Xubuntu/Edubuntu might be more satisfying for you.

In general, if the distribution that you are using doesn't do things the way that you want to do them then don't fight with your distribution. Rather, find one that does what you want without a lot of effort on your part.
 
Old 12-26-2008, 06:19 PM   #3
computer_freak_8
Member
 
Registered: Jul 2008
Location: Iowa
Distribution: Ubuntu 12.04 LTS 64-bit (Primary)
Posts: 80

Rep: Reputation: 15
Question Re: Forcing "nv" to work

Quote:
Originally Posted by keithmcd View Post
Hi there,

I have a Scientific Linux machine (essentially RHEL4). I am not wanting to install the nvidia driver as I do not want to be updating the driver every time there is a kernel update. So, I'm trying to get the nv driver to work.
[...]
I figure that if I can change the device_id of the card to 0165 (Quadro NVS 285) that that should work good as it's a close card and it's supported by the driver.
[...]
If this isn't possible, I'm up for suggestions on other ways to get this to work. These machines have to be updatable through yum without requiring constant recompilation which is why I thought this was the best way to avoid all that.
Well, I'm not sure about this, but here are my thoughts:

You could (maybe?) compile a kernel yourself, and then install the Nvidia driver, and then it wouldn't get updated through yum, so it wouldn't matter(?) Not sure if this would work/is possible; it's just one thought.

What I think might be better to try is, after backing up "/etc/X11/xorg.conf" and "/etc/modules", to do the following:
  1. Install the Nvidia driver, and let it configure the X configuration file
  2. Test it - you might need to remove "nv" and add "nvidia" in "/etc/modules"
  3. Once testing is successful, edit "/etc/X11/xorg.conf" (or whatever the X configuration file is) so that it says "nv" for the driver instead of "nvidia"
  4. Edit "/etc/modules" so that it uses "nv" instead of "nvidia"
  5. Test again. Hopefully, it retain the needed information to get the X server working with the "nv" driver
Or, yet another way: use the VESA driver... Maybe? Don't know if this would work or not, but it did in Kubuntu - if I remember correctly - at least for my card. (Click link in signature for specifications - I can never remember; that's why I put it there.)
 
Old 12-26-2008, 09:17 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,597

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
if the os was a new up to date os i would use the akmod-nvidia .that way it is auto rebuilt for each new kernel . there is no fussing with the driver.But for a RH4 ,maybe one could be recompiled for the system???
 
Old 01-14-2009, 12:38 PM   #5
keithmcd
LQ Newbie
 
Registered: May 2005
Location: /home/keith
Distribution: Debian Etch, SLC4, OS X 10.5
Posts: 24

Original Poster
Rep: Reputation: 15
Sorry for the long delay - I was on a long vacation.

The problem with using the stock nv driver is that for what is available, it does not support the specific model of video card in this system (NVidia Quadro NVS 290). The problem with using the official nvidia driver is that it refuses to compile a kernel module properly (it compiles the normal kernel module, but this system is running an smp kernel which it doesn't compile for).

I'll see if I can try akmod-nvidia, but it isn't available in the default yum repos we have and as these are used for scientific research I'd like to steer clear of randomly adding repos - even good ones like livna.

Anything that needs to be recompiled manually is not something I want to do.

Thanks,
Keith
 
Old 01-14-2009, 01:02 PM   #6
computer_freak_8
Member
 
Registered: Jul 2008
Location: Iowa
Distribution: Ubuntu 12.04 LTS 64-bit (Primary)
Posts: 80

Rep: Reputation: 15
Question VESA driver?

Did you try using the VESA driver?

Also, could you possibly write a script to have the Nvidia driver automatically re-compile every time you updated the kernel?
 
Old 01-15-2009, 12:56 PM   #7
keithmcd
LQ Newbie
 
Registered: May 2005
Location: /home/keith
Distribution: Debian Etch, SLC4, OS X 10.5
Posts: 24

Original Poster
Rep: Reputation: 15
The vesa driver appears to work - now to get it to work with widescreen resolutions...

I'd rather have an nvidia or nv driver, but it's not worth the trouble or complications.
 
Old 01-15-2009, 01:35 PM   #8
John VV
Guru
 
Registered: Aug 2005
Posts: 12,597

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
you could build the nvidia.run driver , if you can get the source for that old kernel
 
Old 01-16-2009, 01:04 PM   #9
computer_freak_8
Member
 
Registered: Jul 2008
Location: Iowa
Distribution: Ubuntu 12.04 LTS 64-bit (Primary)
Posts: 80

Rep: Reputation: 15
Lightbulb

Quote:
Originally Posted by keithmcd View Post
The vesa driver appears to work - now to get it to work with widescreen resolutions...
Post your X configuration file. I'll see what I can do. (The file's location is probably "/etc/X11/xorg.conf", but I'm not for sure.)

Also, make a backup of it, just in case.
 
Old 01-21-2009, 03:49 PM   #10
keithmcd
LQ Newbie
 
Registered: May 2005
Location: /home/keith
Distribution: Debian Etch, SLC4, OS X 10.5
Posts: 24

Original Poster
Rep: Reputation: 15
Ready to start looking for alternate repositories for SLC4 now...

Didn't check this post for a while but here's the xorg.conf if interested - pretty basic

Quote:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib64/modules/extensions/nvidia"
ModulePath "/usr/X11R6/lib64/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "glx"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Dell"
ModelName "DELL 2005FPW"
DisplaySize 434 270
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
ModeLine "1680x1050" 119.0 1680 1728 1760 1840 1050 1053 1059 1080
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "NVIDIA Quadro NVS 290"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
 
Old 01-21-2009, 05:13 PM   #11
computer_freak_8
Member
 
Registered: Jul 2008
Location: Iowa
Distribution: Ubuntu 12.04 LTS 64-bit (Primary)
Posts: 80

Rep: Reputation: 15
Arrow

Quote:
Originally Posted by keithmcd View Post
Didn't check this post for a while but here's the xorg.conf if interested - pretty basic
Hmmm... It looks like it should work with the widescreen resolutions - what is the native resolution of your monitor? If it is 1440 x 900, I'm not sure what the problem is, but if it is 1680 x 1050, than try changing this line:
Code:
Modes "1440x900" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
to this:
Code:
Modes "1680x1050" "1440x900" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
 
Old 01-22-2009, 07:53 AM   #12
keithmcd
LQ Newbie
 
Registered: May 2005
Location: /home/keith
Distribution: Debian Etch, SLC4, OS X 10.5
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the suggestion however it appears the driver refuses to use anything higher than 1024x768 as it's also the highest res to show up in Preferences -> Resolution.

/var/log/Xorg.0.log snippet
Quote:
(II) VESA(0): Not using mode "1680x1050" (no mode of this name)
(II) VESA(0): Not using mode "1440x900" (no mode of this name)
(II) VESA(0): Not using mode "1280x960" (no mode of this name)
(II) VESA(0): Not using mode "1152x864" (no mode of this name)
(II) VESA(0): Not using built-in mode "1600x1200" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1280x1024" (width too large for virtual size)
(--) VESA(0): Virtual size is 1024x768 (pitch 1024)
(**) VESA(0): *Built-in mode "1024x768"
(**) VESA(0): *Built-in mode "800x600"
(**) VESA(0): *Built-in mode "640x480"
(**) VESA(0): Display dimensions: (434, 270) mm
(**) VESA(0): DPI set to (59, 72)
(II) VESA(0): Attempting to use 75Hz refresh for mode "1024x768" (118)
(II) VESA(0): Attempting to use 72Hz refresh for mode "800x600" (115)
(II) VESA(0): Attempting to use 73Hz refresh for mode "640x480" (112)
 
Old 01-22-2009, 10:45 AM   #13
John VV
Guru
 
Registered: Aug 2005
Posts: 12,597

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
how about adding metamode
part of mine for fedora 9
Code:
Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "UseEvents" "False"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "AddARGBGLXVisuals" "true"
    Option         "metamodes" "1680x1050 +0+0;1440x900 +0+0;1152x864 +0+0;1024x768 +0+0; 800x600 +0+0"
    Option         "NVAGP" "3"
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1680x1050" "1440x900" "1280x960" "1152x864""1024x768" "832x624" "800x600" "720x400" 
    EndSubSection
EndSection
and according to nvidia this driver will work on that chipset
http://www.nvidia.com/object/linux_d...32_180.22.html

Last edited by John VV; 01-22-2009 at 10:52 AM.
 
Old 01-22-2009, 12:59 PM   #14
keithmcd
LQ Newbie
 
Registered: May 2005
Location: /home/keith
Distribution: Debian Etch, SLC4, OS X 10.5
Posts: 24

Original Poster
Rep: Reputation: 15
Thanks for the effort. metamodes tried and failed to yield anything new.

The problem with the nvidia driver (at least when i tried it last time) is that although it does compile the kernel module, it doesn't do it for the running kernel (SMP) - it only does it for the non-smp one. Therefore, it'a a PITA and on the next automatic yum update, the entire gui breaks.
 
Old 01-22-2009, 04:31 PM   #15
John VV
Guru
 
Registered: Aug 2005
Posts: 12,597

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
time to install a modern OS slc4 is just a bit out dated .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it possible to load a device driver into an offline kernel? thehobster Linux - Newbie 2 03-24-2008 06:50 PM
How can i load the vesa driver at bootup in Grub? Or, help w/ video card. sleekmason Linux - Software 5 12-03-2006 11:11 PM
Character Device driver: How to load it automatically ? shendeswanand Linux - Software 0 02-09-2006 09:59 PM
automatic driver load & device permissions xtravar Linux - Hardware 0 06-17-2005 12:30 PM
Gnome Wont load after video card driver change dietrichmd Linux - Software 2 10-18-2004 09:13 PM


All times are GMT -5. The time now is 11:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration