LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 02-14-2008, 06:59 AM   #1
klarsin
Member
 
Registered: Oct 2006
Distribution: Ubuntu / Mepis
Posts: 144

Rep: Reputation: 15
Zero key not working


I recently updated Edgy to version 2.6.15.29, and now the zero key on my old sony laptop dosnt work. It's a dual boot with Windows where the zero key works on Windows with all applications. I can, however, on Edgy get the key to work by pressing the 'windows menu key' but not the zero key by itself.
 
Old 02-14-2008, 10:56 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Toronto Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,779

Rep: Reputation: 415Reputation: 415Reputation: 415Reputation: 415Reputation: 415
What have you got defined in /etc/X11/xorg.conf for the keyboard?

Quote:
Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection
This has to match the hardware, and the layout. Be sure to carefully count the keys.

You have to edit this file as root.
 
Old 02-14-2008, 04:37 PM   #3
klarsin
Member
 
Registered: Oct 2006
Distribution: Ubuntu / Mepis
Posts: 144

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by camorri View Post
What have you got defined in /etc/X11/xorg.conf for the keyboard?



This has to match the hardware, and the layout. Be sure to carefully count the keys.

You have to edit this file as root.
This is copied from the desk computer but the sony laptop, which is the problem computer, shows the same. It dosnt look like your post.

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

I don't know what you meant by counting the keys, but it dosnt have 104 but I think 86, if that is what you meant. But the desk computer has 105 and says 104.
 
Old 02-14-2008, 06:42 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Toronto Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,779

Rep: Reputation: 415Reputation: 415Reputation: 415Reputation: 415Reputation: 415
You didn't tell me what hardware you had in the first post. Yes, I did mean count the buttons. I'm not sure how this is done a lap top. You probably don't have a numeric pad. Some lappies mark the num pad with a special shift combination.

I just had a look at my old Compaq laptop. The keyboard section on it looks identical to yours; line for line.

What desktop are you running? Some allow keyboard re-mapping. Just a thought, but the key that is failing may be re-mapped.

Can you get a zero our of the Num Pad? On my laptop I have to hold down shift, press num-lock, and then the numeric pad works. See if you can create a zero there.
 
Old 02-16-2008, 12:13 PM   #5
klarsin
Member
 
Registered: Oct 2006
Distribution: Ubuntu / Mepis
Posts: 144

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by camorri View Post
You didn't tell me what hardware you had in the first post. Yes, I did mean count the buttons. I'm not sure how this is done a lap top. You probably don't have a numeric pad. Some lappies mark the num pad with a special shift combination.

I just had a look at my old Compaq laptop. The keyboard section on it looks identical to yours; line for line.

What desktop are you running? Some allow keyboard re-mapping. Just a thought, but the key that is failing may be re-mapped.

Can you get a zero our of the Num Pad? On my laptop I have to hold down shift, press num-lock, and then the numeric pad works. See if you can create a zero there.
Hardware: I found this in device mgr: info.udi - strlist- IBM Enhanced (101-102-key, PS/2mouse support)

Desktop is Ubuntu gnome Edgy v2.6.15.29, and I don't see where to remap the desktop. The only thing I can think of is to "reconfigure Xserver and see if I can make an adjustment there, but don't know too much about that.

The numbers are the "row above keys' (not number pad) as in most laptops. Toggle number lock dosnt fix the problem. However I can get the zero to work by holding down the win key or sometimes the ctr key. I am doing my corporate books on this computer so I went out and bought an external USB number pad and it works just fine. So, the problem must be with the particular hardware support.

I wonder if I can install a keyboard remapping repair application that might be available for this version of Ubuntu?

Last edited by klarsin; 02-16-2008 at 12:15 PM.
 
Old 02-16-2008, 01:51 PM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Toronto Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,779

Rep: Reputation: 415Reputation: 415Reputation: 415Reputation: 415Reputation: 415
It is not too difficult to edit your /etc/X11/xorg.conf file. You will have to edit it as root. If this is a 101 or 102 key keyboard, try changing the entry for 'pc104' to 'pc102' and try again. You need to restart the xserver after the edit. The key combination of Ctrl + Alt + Backspace ( all together ) will restart your xserver, and cause the xorg.conf file to be re-read.

I don't use Gnome, so I can't tell you exactly what to look for to re-map keys. In KDE, there is something called Control Center, in there you can select many manufacturer specific keyboard layouts. There is a drop down list called Keyboard Model. In that list there are many manufacturer layouts that look after different layouts. I can only guess Gnome would have something similar. Have a look around to see if you can find it. If not, try a post that is specific to Gnome, and your model of machine and keyboard layout. Hopefully someone that knows Gnome can help.
 
Old 02-16-2008, 06:12 PM   #7
klarsin
Member
 
Registered: Oct 2006
Distribution: Ubuntu / Mepis
Posts: 144

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by camorri View Post
It is not too difficult to edit your /etc/X11/xorg.conf file. You will have to edit it as root. If this is a 101 or 102 key keyboard, try changing the entry for 'pc104' to 'pc102' and try again. You need to restart the xserver after the edit. The key combination of Ctrl + Alt + Backspace ( all together ) will restart your xserver, and cause the xorg.conf file to be re-read.
Unfortunately, I have never been able to access these files even after logging in as root. Ubuntu won't let me do it,and unless there is a specific command I don't know about. this has been frustrating for the past year Ive been with Ubuntu.
 
Old 02-16-2008, 07:22 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 11,801

Rep: Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923
"sudo gedit /etc/X11/xorg.conf" - has never failed (me).
 
Old 02-16-2008, 10:31 PM   #9
klarsin
Member
 
Registered: Oct 2006
Distribution: Ubuntu / Mepis
Posts: 144

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by syg00 View Post
"sudo gedit /etc/X11/xorg.conf" - has never failed (me).
Hmm, I had the wrong command. Yours worked. However the change from 104 to 102 didn't work, plus I changed a setting in the graphics as well that did work do well that I couldn't restart X server. So Iv'e resolved to reinstall the distro. There is nothing on this laptop that isn' saved or important anyway.

Thanks loads for your input, at least I got another good command.

KL
 
  


Reply

Tags
resolved


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Win key sometimes not working Caesar Tjalbo Linux - Newbie 2 03-01-2007 05:54 AM
acpi nearly working IBM thinkpad R40e 2684HVG no Fn key working, throttling OK Emmanuel_uk Linux - Laptop and Netbook 2 05-31-2006 01:41 AM
Control Key not working! pfeito Linux - General 2 04-06-2006 10:46 AM
Insert key not working Drunkalot Linux From Scratch 1 11-01-2005 10:45 AM
compose key not working jkobrien Linux - Hardware 1 08-05-2004 08:18 AM


All times are GMT -5. The time now is 11:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration