LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   xterm keyboard doesn't work if a mouse is over the window on the latest Fedora 10. (http://www.linuxquestions.org/questions/linux-desktop-74/xterm-keyboard-doesnt-work-if-a-mouse-is-over-the-window-on-the-latest-fedora-10-a-708960/)

Vaxon 03-03-2009 07:41 PM

xterm keyboard doesn't work if a mouse is over the window on the latest Fedora 10.
 
After the latest system update the keyboard stopped working in any GUI terminal window (xterm and others) if a mouse pointer is over it. I have a USB mouse and keyboard.

The latest update included:
Mar 04 02:46:06 Updated: gvfs-1.0.3-6.fc10.x86_64
Mar 04 02:46:07 Updated: audit-libs-1.7.12-1.fc10.x86_64
Mar 04 02:46:14 Updated: evolution-data-server-2.24.5-1.fc10.x86_64
Mar 04 02:46:15 Updated: 1:cups-libs-1.3.9-8.fc10.x86_64
Mar 04 02:46:15 Updated: SDL-1.2.13-7.fc10.x86_64
Mar 04 02:46:18 Updated: libgxim-0.3.2-3.fc10.x86_64
Mar 04 02:46:18 Updated: linuxwacom-0.8.0.3-8.fc10.x86_64
Mar 04 02:46:20 Updated: soprano-2.2.3-1.fc10.x86_64
Mar 04 02:46:24 Updated: gtkhtml3-3.24.5-1.fc10.x86_64
Mar 04 02:46:38 Updated: selinux-policy-3.5.13-46.fc10.noarch
Mar 04 02:46:42 Updated: evolution-data-server-doc-2.24.5-1.fc10.x86_64
Mar 04 02:46:43 Updated: kernel-firmware-2.6.27.19-170.2.35.fc10.noarch
Mar 04 02:47:01 Installed: system-config-date-1.9.36-1.fc10.noarch
Mar 04 02:47:02 Updated: audit-1.7.12-1.fc10.x86_64
Mar 04 02:47:28 Installed: kernel-2.6.27.19-170.2.35.fc10.x86_64
Mar 04 02:47:29 Updated: SDL-devel-1.2.13-7.fc10.x86_64
Mar 04 02:47:32 Updated: 1:cups-1.3.9-8.fc10.x86_64
Mar 04 02:47:34 Updated: kernel-headers-2.6.27.19-170.2.35.fc10.x86_64
Mar 04 02:47:35 Installed: system-config-date-docs-1.0.5-1.fc10.noarch
Mar 04 02:47:40 Installed: kernel-devel-2.6.27.19-170.2.35.fc10.x86_64
Mar 04 02:47:40 Updated: gvfs-obexftp-1.0.3-6.fc10.x86_64
Mar 04 02:47:40 Updated: audit-libs-python-1.7.12-1.fc10.x86_64
Mar 04 02:47:41 Updated: alsa-utils-1.0.19-2.fc10.x86_64
Mar 04 02:47:55 Updated: selinux-policy-targeted-3.5.13-46.fc10.noarch
Mar 04 02:47:55 Updated: gvfs-gphoto2-1.0.3-6.fc10.x86_64
Mar 04 02:47:55 Updated: gvfs-fuse-1.0.3-6.fc10.x86_64
Mar 04 02:47:56 Updated: gvfs-archive-1.0.3-6.fc10.x86_64
Mar 04 02:47:56 Updated: xmlto-0.0.21-4.fc10.x86_64
Mar 04 02:47:57 Updated: evolution-data-server-devel-2.24.5-1.fc10.x86_64
Mar 04 02:47:57 Updated: gvfs-smb-1.0.3-6.fc10.x86_64
Mar 04 02:47:57 Updated: xorg-x11-drv-vmmouse-12.6.3-3.fc10.x86_64
Mar 04 02:48:15 Installed: kernel-2.6.27.19-170.2.35.fc10.x86_64

Is it the xorg-x11-drv-vmmouse-12.6.3-3.fc10.x86_64?

Has anyone experienced anything close to my problem?
Any suggestions are greatly appreciated.

Thanks,
Vax.

user00 03-04-2009 08:30 AM

No keyboard on Fedora 10 after yum update
 
After a recent Fedora 10 yum update (kernel, SDL, NVIDIA drivers etc.) I can't use keyboard in most Linux games (usually when they are in full screen mode, in some even in window mode, only a few games or other software behaves normally in full screen mode though). I can't type to xterm when the mouse pointer is over it but GNOME Terminal works normally. I don't know where to file a bug report since I don't know whether this is a Xorg bug, SDL bug, kernel bug or what... Getting EXTREMELY frustrated...

The same bug affects both a PC desktop running Fedora 10 (keyboard type doesn't make any difference, Apple Alu USB keyboard doesn't work and PS2 keyboard doesn't work any better) and rev. 3 Santa Rosa MacBook Pro running Fedora 10.

dickey 06-05-2009 03:06 PM

Keyboard and mouse...
 
xterm's version isn't specified...

It's not clear whether other applications are affected,
or whether the other applications are running in xterm.

The only thing that comes to mind for xterm specifically
would be the pointerMode (resource) from #232 (2008/1/30).
xterm may be trying to use a different font for hiding
the mouse pointer, and failing due to Xorg's change to
the font packages (which made the fixed size fonts no
longer part of the default install).

You can test that part - xterm alone - by setting its
pointerMode resource to 0 (zero).


All times are GMT -5. The time now is 02:45 PM.