-   Linux - Desktop (
-   -   xterm does not open in home folder, instead opens in Documents folder (

hsiu 12-29-2010 09:59 AM

xterm does not open in home folder, instead opens in Documents folder

xterm, when launched via Alt+F2, and yeahconsole (a quake-like drop down console built upon xterm) open into my documents folder (~/Documents) instead of home (~). This is a minor irritation, but an irritation nonetheless.

Everything I read online says xterm should open to my home folder - any idea why it might not be, where a setting might need to be changed?

amani 12-29-2010 10:07 AM

All the settings will be in /etc/X11/app-defaults/XTerm

#man xterm

hsiu 01-01-2011 03:11 AM


Thanks for your reply.

I checked /etc/X11/app-defaults/XTerm and found a lot of options about menus and fonts, but nothing that looked like a likely candidate for affecting the default directory on opening.

I read the man page for xterm but didn't see any option listed there either which could be used in that way.

Any other ideas?

hsiu 01-12-2011 12:41 PM

I've determined that it opens to whichever folder is specified as XDG_DOCUMENTS_DIR in my ~/.config/user-dirs.dirs file. So, I can change that value to $HOME, which makes xterm open up in the home directory, but I think this is kind of hacky - I don't want to respecify which folder is my documents folder, I just want xterm to open in $HOME instead of XDG_DOCUMENTS_DIR.

Anybody have any ideas where/how xterm is getting the idea to open into XDG_DOCUMENTS_DIR?

amani 01-13-2011 10:00 AM


hsiu 01-16-2011 09:35 AM


Originally Posted by amani (Post 4222958)

Thanks amani, but neither of these environment variables seems to be set.

I found this, but it didn't help me much:

All times are GMT -5. The time now is 03:14 PM.