LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 01-03-2007, 12:08 PM   #1
laxrick
LQ Newbie
 
Registered: Sep 2005
Posts: 6

Rep: Reputation: 0
XServer won't start...


I'm such a n00b here's what I did...

I have Debian installed, and I use the KDE desktop. Everything was working fine, but I saw the 3D desktop program XGL and I tried to compile and install it. I ran a setup script, but apparently the script was not for Debian.

Now everytime I start Debian, Xserver cannot start because of an error in '/usr/X11R6/bin/X' because a file 'libx.au.06' or something similar does not exist. Basically, I want to have everything back the way it was before I installed this stupid script.

This is the script I ran:

http://sonique54.free.fr/xgl/setupxglen.sh

What can I do from the shell since I have no GUI anymore, to fix this instead of completely reinstalling the distro?
 
Old 01-03-2007, 12:27 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
There's a couple things to try:

1) I would do is go to /etc/X11/ directory (cd /etc/X11/). See if there is a file xorg.conf.old (or XF86Config-4.old for Sarge). It might be .0 or .bk or something else. You're basically looking to see if the script made a backup file. If there is one, you can try changing to root by su and enter password. Then do cp xorg.conf.old xorg.conf (adjust the filenames accordingly).

2) Try su to change to root. Then run dpkg-reconfigure xserver-xorg (or xserver-xfree86 for Sarge).

After each of those, do /etc/init.d/kdm restart as the root user to restart the x-server. Be CAREFUL when you are root! You have become all powerful! You can seriously hose your system!

You've been warned...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xserver-xfree86: Xserver could not start on my ATI-radeon video card Shankarrajus Debian 2 07-17-2006 07:00 AM
Xserver will not start heatrj Linux - Hardware 2 06-19-2006 10:18 AM
Cannot start Xserver hywaydave23 Red Hat 5 11-18-2005 10:33 AM
XServer do not start mcp_achindra Linux - Software 1 04-29-2004 06:24 AM
xserver does not start juerg.maier Linux - Newbie 3 02-23-2004 01:30 PM


All times are GMT -5. The time now is 09:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration