LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 05-03-2013, 05:46 AM   #1
tensigh
Member
 
Registered: Mar 2004
Location: Tokyo, Japan
Distribution: Backtrack 5 R3
Posts: 141

Rep: Reputation: 15
xscreensaver won't run automatically


Hello all,

I'm running Debian on a VM and xscreensaver won't run unless I manually start it. I have it set to run under System -> Preferences -> Startup Applications and I added it to /etc/rc.local, but no dice. /var/log/messages and /var/log/syslog don't show any errors.

Any suggestions? Not a major issue, but I just want to know why it won't start.
 
Old 05-03-2013, 09:50 PM   #2
jmccue
Member
 
Registered: Nov 2008
Location: US
Distribution: slackware
Posts: 135

Rep: Reputation: 36
Adding it to /etc/rc.local will not work, xscreensaver needs a X server to connect to. Depending upon how you get into X, you should add:
Quote:
xscreensaver &
to your ~/.xinitrc or ~/.xsession

HTH
John
 
Old 05-04-2013, 08:25 AM   #3
tensigh
Member
 
Registered: Mar 2004
Location: Tokyo, Japan
Distribution: Backtrack 5 R3
Posts: 141

Original Poster
Rep: Reputation: 15
Thanks for the tip, but still having a problem

Thanks for the tip. You're right, it makes sense I would need an X server running for it to work.

I don't have an .xinitrc or .xsessions file in my ~/ directory. I suppose I can create one.

Why would it not work being in Startup Applications?
 
Old 05-04-2013, 11:44 AM   #4
jmccue
Member
 
Registered: Nov 2008
Location: US
Distribution: slackware
Posts: 135

Rep: Reputation: 36
Quote:
Originally Posted by tensigh View Post
Why would it not work being in Startup Applications?
What is your desktop/Window Manager ? I suspect some desktops ignore .xsession/.xinitrc. I rarely use desktops, I have very little experience with gnome2/gnome3 so I cannot comment, but KDE has a method of starting apps when invoked, but I do not remember how to set it.

If using a window manager best to add it to .xsession/.xinitrc. But, if using fluxbox, you can add it to ~/.fluxbox/startup instead.

John
 
Old 05-04-2013, 10:29 PM   #5
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,098

Rep: Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538
If you are using a desktop environment, such as KDE or Gnome, look for an item called "Startup Applications" in the "control center" or "system settings" area. You should be able to add it there.
 
Old 06-01-2013, 10:58 AM   #6
tensigh
Member
 
Registered: Mar 2004
Location: Tokyo, Japan
Distribution: Backtrack 5 R3
Posts: 141

Original Poster
Rep: Reputation: 15
Original post

Quote:
Originally Posted by frankbell View Post
If you are using a desktop environment, such as KDE or Gnome, look for an item called "Startup Applications" in the "control center" or "system settings" area. You should be able to add it there.
Hey Frankbell,

Not sure if you saw it, but I put in my original post that I did put it in Startup Applications, but it still doesn't start. Thanks anyway.
 
Old 06-01-2013, 09:04 PM   #7
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,098

Rep: Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538
Sorry, I did miss that.

Here's a possible work-around.

Instead of putting xscreensaver in the startup applications item, put xscreensaver-demo (that's the configuration dialog) in there. When xscreensaver-demo starts, it should pop a dialog to the effect that "The xscreensaver daemon is not running. Do you want to start it now?" Click "Yes" and close the windows.

Try that and report back on what happens.
 
Old 06-02-2013, 08:41 AM   #8
tensigh
Member
 
Registered: Mar 2004
Location: Tokyo, Japan
Distribution: Backtrack 5 R3
Posts: 141

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by frankbell View Post
Sorry, I did miss that.

Here's a possible work-around.

Instead of putting xscreensaver in the startup applications item, put xscreensaver-demo (that's the configuration dialog) in there. When xscreensaver-demo starts, it should pop a dialog to the effect that "The xscreensaver daemon is not running. Do you want to start it now?" Click "Yes" and close the windows.

Try that and report back on what happens.
Frankbell,

Thank you. That would work but it still requires manually starting Xscreensaver. I can always drop to a terminal window and run /usr/bin/xscreensaver &. I'm trying to avoid having to manually start it. I also don't get why it requires me to do this; it's already in startup applications - shouldn't that be enough?
 
Old 06-02-2013, 09:17 PM   #9
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,098

Rep: Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538
Quote:
I also don't get why it requires me to do this; it's already in startup applications - shouldn't that be enough?
Yes.

If you want to dig deeper, here's a thought: make sure that xsceensaver is in startup applications, exit and restart the GUI. Then check the logs in /var/log.

I'd suggest particularly checking /var/log/messages and /var/log/Xorg.0.log. You might want to do that using the less command (for example, less /var/log/messages) so you can navigate back and forth through them.

I can't promise you'll turn up something, but you might. Also, there might be other suspects to interrogate, but those are the ones I'd start with.

Last edited by frankbell; 06-02-2013 at 09:19 PM.
 
Old 06-02-2013, 10:29 PM   #10
tensigh
Member
 
Registered: Mar 2004
Location: Tokyo, Japan
Distribution: Backtrack 5 R3
Posts: 141

Original Poster
Rep: Reputation: 15
Thanks for the tip.

Quote:
Originally Posted by frankbell View Post
Yes.

If you want to dig deeper, here's a thought: make sure that xsceensaver is in startup applications, exit and restart the GUI. Then check the logs in /var/log.

I'd suggest particularly checking /var/log/messages and /var/log/Xorg.0.log. You might want to do that using the less command (for example, less /var/log/messages) so you can navigate back and forth through them.

I can't promise you'll turn up something, but you might. Also, there might be other suspects to interrogate, but those are the ones I'd start with.
Thanks, Frankbell.

Actually, I already looked in /var/log recursively but didn't come up with anything. I love less, by the way, it rocks over more (less really is more!)
I do have it working on another system so I can comb through the config files on that system and see if I can figure out what I tweaked to get it to work. Since I installed that system about a year ago I couldn't find it in the history files.

Still can't figure out why it doesn't work with just startup applications, but I'll manage. Thanks for the tip.

Part of the problem is that these systems originally had the (lame) Gnome-screensaver installed, and these problems happened after replacing it with (the much better) Xscreensaver. Not a huge problem, but it's frustrating that something so seemingly simple takes up this much time.
 
Old 06-03-2013, 07:41 PM   #11
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,098

Rep: Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538
You may be on to something.

I have the same problem on my Mint machine and am using the workaround described. It also used to have Gnome-screensaver (I share your opinion of it).

I have similar removed and replaced Gnome-screensaver on Debian and Ubuntu, but not encountered this glich before.
 
Old 06-03-2013, 08:05 PM   #12
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,576
Blog Entries: 1

Rep: Reputation: Disabled
http://www.jwz.org/xscreensaver/man1.html is pretty explicit about setting this up.

Just an idea.
 
Old 06-03-2013, 08:39 PM   #13
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,098

Rep: Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538Reputation: 1538
Thanks. It's been a long time since I read that.

Perhaps the sections on enabling it from the display manager will help.

That still doesn't really speak to why it is not starting when added to Startup Applications.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xscreensaver won't run on start up for all users cocoyoh Linux - Desktop 0 06-21-2012 04:55 AM
How can i stop xscreensaver from automatically starting. deathalele Linux - Software 3 01-10-2010 06:19 AM
Running xscreensaver automatically on login mrhappy5 Linux - Desktop 12 05-22-2009 03:35 PM
Starting the xscreensaver daemon automatically in Etch swampdog2002 Debian 1 03-28-2008 10:03 PM
xmodmap won't run automatically txmjafg Linux - General 3 12-14-2003 10:44 PM


All times are GMT -5. The time now is 05:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration