LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 10-23-2010, 06:03 PM   #1
pauline123
LQ Newbie
 
Registered: Oct 2010
Distribution: Arch Linux
Posts: 6

Rep: Reputation: 1
Xorg resituates after initiation to the wrong position... nouveau driver...


The problem: Xorg loads fine after startx (options for openbox are in .xinitrc) and after a second (maybe less) it repositions itself slightly lower and shifts a little to the left (with a portion of that showing up on the right side of the screen).

Secondary problem (believe it might be related to first): My mouse once my X is loaded and has shifted is slightly lower than where the cursor is. So I have to position my mouse cursor a little higher than where I want to click.


P.S. I've recently switched distro's from an old (relatively to me) Ubuntu with a 2.4 linux kernel to an arch linux installation with a 2.6 kernel.

P.S.S. According to the archlinux repositories I should use the nouveau driver and not the legacy driver from nvidia (but I've tried both). However, please feel free to suggest anything.

Last edited by pauline123; 10-24-2010 at 01:03 AM. Reason: solved....
 
Old 10-24-2010, 01:02 AM   #2
pauline123
LQ Newbie
 
Registered: Oct 2010
Distribution: Arch Linux
Posts: 6

Original Poster
Rep: Reputation: 1
Solution found somehow

OK, well I know I'm gonna sound like an idiot for this especially after posting on here for help.

However.... The problem has been fixed. After A few more tries of installing them and tweaking nouveau and nvidia drivers 96xx, I had a brain-flash and copied some of the information that nvidia's installation allows you to make from nvidia-settings (creates a xorg.conf).

I copied as much information as I could that wasn't nvidia specific from it and entered that into my 10-monitors.conf in /etc/X11/xorg.conf.d/ . Restarted X with the command:

Code:
killall -USR1 /usr/bin/X
and voila! It works... Not sure which section it was but... meh.... and it seems to work fine for the monitor too... (Yes, I made sure that nothing looked dangerous for my monitor, its an old dinosaur [it'll probably outlive me].
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nouveau kernel driver Ordinary12 Ubuntu 38 01-20-2014 05:05 AM
Fedora 12 - Nouveau + Nvidia Driver Solution JoshGriffin Fedora 19 05-21-2010 08:29 AM
LXer: Using The Nouveau Driver In Ubuntu 9.04 LXer Syndicated Linux News 0 04-24-2009 03:41 PM
Wrong display position on my laptop Alkisx Slackware 6 11-23-2007 11:55 AM
LXer: Nouveau Driver Q&A LXer Syndicated Linux News 0 09-02-2007 08:30 PM


All times are GMT -5. The time now is 11:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration