LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Xorg or Gnome not properly detecting displays at startup. (http://www.linuxquestions.org/questions/linux-desktop-74/xorg-or-gnome-not-properly-detecting-displays-at-startup-816178/)

PeniWize 06-24-2010 02:09 PM

Xorg or Gnome not properly detecting displays at startup.
 
In Ubuntu 10.04, and an up to date Arch system, I’ve noticed that gnome and gdm seem to randomly detect either one or two monitors on my Dell E5500 laptop even though there is no VGA monitor connected to the VGA port (the laptop has a primary 1280x800 integrated display and a VGA port). When both monitors are detected, gdm places the login dialog box very far to the right so it is off screen. It usually appears when I press enter to select a user so I can see the box when I enter my password. Then after I log in, the gnome desktop panels show up on the primary (integrated) display, but often new windows will appear on the secondary display (unconnected VGA monitor) so I can’t see them. When I launch “Monitor Preferences” from “System | Preferences | Monitors” it correctly detects that there is no secondary (VGA) monitor attached and resets the desktop and repositions all windows on the primary display.

I’m not sure if this is a gnome or Xorg problem. Can anyone help me out with this?

Thanks!

Here is the output from lspci:

...
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
...

/var/log/Xorg.0.log reports:

[ 19.741] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
...
[ 20.740] (II) intel(0): [DRI2] DRI driver: i965
...
[ 20.808] (II) intel(0): [XvMC] xvmc_vld driver initialized.

This problem occurred with and without an xorg.conf file. Here is the xorg.conf file I'm using now. /etc/X11/Xorg.conf:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "SynapticsTouchpad" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/Type1"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "dri"
Load "dri2"
Load "record"
Load "dbe"
Load "synaptics"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
Identifier "SynapticsTouchpad"
Driver "synaptics"
Option "AlwaysCore" "true" # send events to CorePointer
Option "Protocol" "auto-dev"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Mobile 4 Series Chipset Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1280x800"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1280x800"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x800"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1280x800"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x800"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x800"
EndSubSection
EndSection

scrooge_74 07-16-2010 12:37 PM

No expert here, I guess you have to declare your other monitor or screen for it to work properly, I know gnome manages this a lot better than other desktops (I once saw a test using lxde and gnome) Gnome would pick up the right size much better than the other one


All times are GMT -5. The time now is 11:53 AM.