LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-19-2011, 03:16 PM   #1
alden_pease
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Squeeze/Debian Lenny
Posts: 16

Rep: Reputation: 0
Xorg fails to start. XKB error?


I am new to X11/Xorg (assuming they are the same thing), and installed it via "apt-get install xorg gdm". When I attempt to do either "startx" or "gdm" I get a few errors, which are printed below.

Code:
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/xorg
Fatal server error:
could not open default font 'fixed'
You may view the entire log here: http://aldenpease.me/logs/Xorg.0.log

Also, not printed in the log, I receive this on the monitor:
Code:
X: Unable to open wrapper config file /etc/X11/Xwrapper.config
That file does not exist.

Thank you for your help, and as additional information, I'm a noob to GUI's on linux. I always run apps by the command line, but there is one that only runs on the GUI. Thank you again.

Last edited by alden_pease; 03-19-2011 at 03:19 PM.
 
Old 03-20-2011, 11:47 AM   #2
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,071

Rep: Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788
What, if anything, have you got in /usr/share/X11/xkb/? It looks as if you needed to install more packages than you did.

For the font problem, have a look at
http://www.linuxquestions.org/questi...-fixed-391795/

Generally, you might get some ideas from
https://wiki.archlinux.org/index.php/Beginners'_Guide

I'm sorry I can't be more specific, never having installed X-Window by hand.
 
1 members found this post helpful.
Old 03-20-2011, 05:07 PM   #3
alden_pease
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Squeeze/Debian Lenny
Posts: 16

Original Poster
Rep: Reputation: 0
The folder /usr/share/X11/xkb/ does not exist, although it's parent does. I have attempted to install the xkb packages with apt, but it claims that they are already installed. Might it work if I copy the rule sets from one machine to the other, or are they generated dynamically? Thank you.
 
Old 03-21-2011, 08:43 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,665

Rep: Reputation: Disabled
AFAIK you can create a default set of xorg rules by issuing "xorg -config" (or "xorg -configure"; do a "man xorg"). It will create either a /etcX11/xorg.conf or a bunch of /etcX11/xorg.conf.d/* rules, depending on the xorg version you run (or even both?).

"gdm" is the gnome login-manager. That won't help you without gnome...
 
Old 03-21-2011, 01:53 PM   #5
alden_pease
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Squeeze/Debian Lenny
Posts: 16

Original Poster
Rep: Reputation: 0
I have gnome installed, and went through the trouble of reinstall Xorg and Gnome through aptitude, but I'm not quite sure that that was the best decision based on my screen output. I keep getting this:
Code:
expected keysym, got XF86_Switch_VT_1: line 8 of xfree86
expected keysym, got XF86_Switch_VT_2: line 11 of xfree86
...
> Warning: Multiple interpretations of "NoSymbol+AnyOfOrNone...
  Using last definition for duplicate fields.
...
Errors from xkbcomp are not fatal to the X server

Fatal server error:
could not open default font "fixed"
The log file has changed and now the only error is the font "fixed". I have tried many things to fix this, but to no avail. The updated log can be viewed here: http://aldenpease.me/logs/Xorg.0.2.log. Thank you.

Update: Here is the listing of my /usr/share/fonts/X11/misc directory: http://aldenpease.me/logs/misc.dir.ls.log. There is no "fixed" font in this folder, and issuing [# find / -name fixed] returned nothing. Here are the contents of fonts.dir: http://aldenpease.me/logs/fonts.dir.txt Thank you again.

Last edited by alden_pease; 03-21-2011 at 02:57 PM.
 
Old 03-22-2011, 04:33 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,665

Rep: Reputation: Disabled
Did you really install Xorg or XFree86? I know that internally there is some overlap but your post doesn't make that entirely clear. Did you try my suggestion and have a look at the (hopefully) resulting config-files?
 
Old 03-22-2011, 02:30 PM   #7
alden_pease
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Squeeze/Debian Lenny
Posts: 16

Original Poster
Rep: Reputation: 0
I installed Xorg, not XFree86 (besides the overlap). And the config file lead to nothing, besides the directories being used.

Xorg.conf
Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection

Section "Files"
	FontPath   "/usr/share/fonts/X11/misc/"
	FontPath   "/usr/share/fonts/X11/Type1/"
	FontPath   "/usr/share/fonts/X11/75dpi/"
	FontPath   "/usr/share/fonts/X11/100dpi/"
EndSection
http://aldenpease.me/logs/xorg.conf
 
Old 03-22-2011, 04:55 PM   #8
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,071

Rep: Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788
Quote:
Originally Posted by alden_pease View Post
The folder /usr/share/X11/xkb/ does not exist, although it's parent does. I have attempted to install the xkb packages with apt, but it claims that they are already installed. Might it work if I copy the rule sets from one machine to the other, or are they generated dynamically? Thank you.
The stuff in /usr/share/X11/xkb/ is pretty standard, so you could copy. They might be somewhere in /etc though: one never knows with Linux. Search for the directory "semantics" in /etc.

It might be quicker to just re-install!
 
Old 03-22-2011, 05:07 PM   #9
bluebox
Member
 
Registered: Jun 2004
Posts: 71

Rep: Reputation: 6
I'm not sure what's happening here ...

Quote:
Build Operating System: Linux Debian (xorg-server 2:1.4.2-10.lenny3)
looks like Debian Lenny ^^

"fixed" is just an alias. Do a
Code:
cat /etc/X11/fonts/misc/xfonts-base.alias
one line (the first line) should be
Code:
fixed        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
Can you reproduce this?

Now let's see where this iso8859-1 stuff hides ...

Code:
locate ISO8859-1.pcf
You should see a lot of files, all within /usr/share/fonts/X11/

Apparently your fonts are correctly placed within /usr/share/fonts/X11/misc

btw, X says "could not open" and not "could not find". What does dmesg say? Out of memory? Any hard drive defects?

Is the package "x-fonts-base" installed?

Quote:
Originally Posted by alden_pease View Post
and went through the trouble of reinstall Xorg and Gnome through aptitude,
Simple reinstallation won't help you. You need to remove Xorg with "--purge" option to delete all config files. Then do a new install.

Does
Code:
dpkg-reconfigure xserver-xorg
help?

Does
Code:
fc-cache --fv
help?

Is there a font server defined? What does
Code:
xfsinfo
say? (You do not need a font server ... but if you have one, it must be configured properly)

Quote:
Originally Posted by alden_pease View Post
> Warning: Multiple interpretations of "NoSymbol+AnyOfOrNone...
Using last definition for duplicate fields.
Next problem might by your keyboard not working ... but we'll see
 
Old 03-23-2011, 03:03 AM   #10
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,665

Rep: Reputation: Disabled
I'll leave you to the experts for your true troubles, but I noticed one small thing: The drivers for both keyboard and mouse should be the more modern "evdev". Try that one (edit your xorg.conf), it just might help.
 
Old 03-24-2011, 05:40 PM   #11
alden_pease
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Squeeze/Debian Lenny
Posts: 16

Original Poster
Rep: Reputation: 0
Okay, I have updates...

xfonts-base.alias does not exist anywhere on my system.
Code:
locate ISO8859-1.pcf
returns only files within the /usr/share/fonts/X11 directory: http://aldenpease.me/logs/locate_iso8859-1.txt
I have never used dmesg before, but it returned this: http://aldenpease.me/logs/dmesg.032411.055455.txt. The command I used was:
Code:
startx && dmesg > [the path]
And onto the subject of reinstall xorg and Gnome, I did purge everything (using aptitude).
Reconfiguring the xserver didn't help at all, it seamed to have had no effect.
Rebuilding the font cache with fc-cache --fv does not help.
And last of all, xfsinfo returns that there is no font server found.

Thank you for your help.
 
Old 03-28-2011, 02:37 AM   #12
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,665

Rep: Reputation: Disabled
Quote:
Originally Posted by alden_pease View Post
...xfsinfo returns that there is no font server found.
And is that the case? If so, did you install it? Did anything change?
 
Old 03-29-2011, 04:17 PM   #13
alden_pease
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Squeeze/Debian Lenny
Posts: 16

Original Poster
Rep: Reputation: 0
I installed the X Font Server and started it, but nothing has changed.
 
Old 03-30-2011, 11:38 AM   #14
bluebox
Member
 
Registered: Jun 2004
Posts: 71

Rep: Reputation: 6
Quote:
Originally Posted by alden_pease View Post
Okay, I have updates...

xfonts-base.alias does not exist anywhere on my system.
So, X can't find its fonts. Nothing new, we knew about it before, but now we know why.

Code:
$ dpkg -S xfonts-base.alias
xfonts-base: /etc/X11/fonts/misc/xfonts-base.alias
So, install "xfonts-base", or reinstall it.
 
Old 04-06-2011, 12:47 PM   #15
alden_pease
LQ Newbie
 
Registered: Mar 2011
Distribution: Debian Squeeze/Debian Lenny
Posts: 16

Original Poster
Rep: Reputation: 0
I have done so, and it has created the [/etc/X11/fonts/misc/xfonts-base.alias] file, but it is still failing to load the font "fixed".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xkb.Option in xorg.conf ignored on OpenBSD 4.8-release jdoe@ *BSD 1 11-14-2010 04:25 PM
fresh netinst of squeeze:X server fails to start, missing /dev/fb0, missing xorg.conf frumpus Debian 7 03-17-2010 12:36 PM
How to setup xorg xkb layout options per-user? 10110111 Linux - Desktop 1 10-28-2009 02:12 PM
Xorg.conf is edited on restart? x-server fails to start Linkhiei Linux - Hardware 2 10-07-2007 10:49 AM
xkb not switching keymap on non-root users (xorg) z3r0v3rs10n Linux - Software 0 05-21-2007 04:17 PM


All times are GMT -5. The time now is 01:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration