LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-30-2010, 08:28 AM   #1
abdoullah
Member
 
Registered: May 2009
Distribution: Gentoo, CentOS
Posts: 49

Rep: Reputation: 0
Xorg can't start


Hi Guys,
we have a CentOsS 5.5 server kernel 2.6.18-194.el5 #1 SMP.
All of the sudden we can't see the GUI, I forced the server to restart several times but it seems like Xorg is trying to start but can't, I can access the server through SSH, when i type TOP command I see that Xorg appear and disappear, in the screen I see the mouse for a while then the command line, It seems like xorg is struggling to start but i don't know how to help him starting , please give me some hints!!!
Thanks a lot for any help!
 
Old 11-30-2010, 08:35 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,530
Blog Entries: 2

Rep: Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024
To give you hints, we need more info. What graphics hardware? Which drivers are used? Your /var/log/Xorg.0.log?
 
Old 11-30-2010, 09:27 AM   #3
abdoullah
Member
 
Registered: May 2009
Distribution: Gentoo, CentOS
Posts: 49

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by TobiSGD View Post
To give you hints, we need more info. What graphics hardware? Which drivers are used? Your /var/log/Xorg.0.log?
Thanks for the reply,
the hardware is : VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
for the driver I think it's RADEON, as when i started Xorg I saw RADEON setting up the config.
the log is attached.( I did kill Xorg and started it gain, so you may find this in there).
Thank you once more!
Attached Files
File Type: log Xorg.0.log (55.5 KB, 9 views)
 
Old 11-30-2010, 10:21 AM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
There's no indication of anything failing in that log file. Perhaps your window manager or desktop environment is exiting immediately. Which one are you trying to use? What happens if you try
Code:
xinit /full/path/to/xterm
? The full path is probably /usr/X11R6/bin/xterm or /usr/bin/xterm.

Adam
 
Old 11-30-2010, 10:52 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,530
Blog Entries: 2

Rep: Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024Reputation: 4024
It seems to me that after initializing the hardware the display constantly changes from virtual terminal to X and back again.
This is constantly repeated in your logs, bold text from me:
Quote:
(**) RADEON(0): RADEONSaveScreen(2)
(**) RADEON(0): RADEONLeaveVT
(**) RADEON(0): RADEONRestore
(**) RADEON(0): RADEONRestoreMode()
(**) RADEON(0): RADEONRestoreMemMapRegisters() :
(**) RADEON(0): MC_FB_LOCATION : 0xffff0000
(**) RADEON(0): MC_AGP_LOCATION : 0x003fffc0
(**) RADEON(0): Map Changed ! Applying ...
(**) RADEON(0): Map applied, resetting engine ...
(**) RADEON(0): Updating display base addresses...
(**) RADEON(0): Memory map updated.
(**) RADEON(0): Programming CRTC1, offset: 0x00000000
(**) RADEON(0): Wrote: 0x0000000c 0x00030065 0x00000000 (0x0000a500)
(**) RADEON(0): Wrote: rd=12, fd=101, pd=3
(**) RADEON(0): Ok, leaving now...
(II) Open ACPI successful (/var/run/acpid.socket)
(**) RADEON(0): RADEONEnterVT
(**) RADEON(0): RADEONModeInit()
1024x768 78.80 1024 1040 1136 1312 768 769 772 800 (24,32) +H +V
1024x768 78.80 1024 1040 1136 1312 768 769 772 800 (24,32) +H +V
(**) RADEON(0): Pitch = 8388736 bytes (virtualX = 1024, displayWidth = 1024)
(**) RADEON(0): dc=7880, of=31520, fd=140, pd=4
(**) RADEON(0): RADEONInit returns 0x5591ab0
(**) RADEON(0): RADEONRestoreMode()
(**) RADEON(0): RADEONRestoreMemMapRegisters() :
(**) RADEON(0): MC_FB_LOCATION : 0xe3ffe000
(**) RADEON(0): MC_AGP_LOCATION : 0xffffffc0
(**) RADEON(0): Map Changed ! Applying ...
(**) RADEON(0): Map applied, resetting engine ...
(**) RADEON(0): Updating display base addresses...
(**) RADEON(0): Memory map updated.
(**) RADEON(0): Programming CRTC1, offset: 0x00000000
(**) RADEON(0): Wrote: 0x0000000c 0x0002008c 0x00000000 (0x0000a500)
(**) RADEON(0): Wrote: rd=12, fd=140, pd=2
(**) RADEON(0): GRPH_BUFFER_CNTL from 20005c5c to 20095c5c
(**) RADEON(0): EngineRestore (32/32)
But I don't have a clue why it is doing that. May be anybody else has an idea?
 
Old 11-30-2010, 12:56 PM   #6
impert
Member
 
Registered: Feb 2009
Posts: 282

Rep: Reputation: 53
Code:
RADEONRestoreMemMapRegisters() : 
(**) RADEON(0):   MC_FB_LOCATION   : 0xe3ffe000
(**) RADEON(0):   MC_AGP_LOCATION  : 0xffffffc0
(**) RADEON(0):   Map Changed ! Applying ...
(**) RADEON(0):   Map applied, resetting engine ...
(**) RADEON(0): Updating display base addresses...
(**) RADEON(0): Memory map updated.
It seems to be something to do with the memory map FB and AGP cycling between addresses.
 
Old 11-30-2010, 03:11 PM   #7
abdoullah
Member
 
Registered: May 2009
Distribution: Gentoo, CentOS
Posts: 49

Original Poster
Rep: Reputation: 0
I really appreciate guys your answers, i did try the command Adam suggested and i got this:

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

I did delete this before but issue was not fixed!!!
So i hope somebody will have a path to diagnose more the issue!
Thanks!
 
Old 11-30-2010, 03:55 PM   #8
abdoullah
Member
 
Registered: May 2009
Distribution: Gentoo, CentOS
Posts: 49

Original Poster
Rep: Reputation: 0
Hi Guys,
I tried killing Xorg but i couldn't and when i see the processes running, it says:

root 16615 11.8 0.0 88076 5304 tty8 Ss+ 12:55 0:00 /usr/bin/Xorg :1 -br -audit 0 -auth /var/gdm/:1.Xauth -nolisten tcp vt8

i hope this can help you help me !
 
Old 11-30-2010, 06:55 PM   #9
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I have 2 ideas.

A) Since according to the Xorg.0.log file, direct rendering isn't used, add "nomodeset" to your kernel boot option. (You can enter it to the kernel line when booting up, if it helps, add it to your grub config file /boot/grub/menu.lst or /boot/grub/grub.conf) I have found that this helps with video problems if you use NVidia or ATI graphics.

B)
Quote:
using VT number 7
The xorg.0.log file indicated that it was using VT7, while the last line you posted is saying VT 8 is being used. I wonder if using VT7 instead will help. Use the `pstree' command to locate the parent (script) process of the /usr/bin/Xorg command. There may be a setting in /etc/inittab or a file in /etc/sysconfig/ where you can make the change. (Sorry, I'm not running CentOS & am not familiar with distro specific config files)

Last edited by jschiwal; 11-30-2010 at 09:49 PM. Reason: tree -> pstree
 
Old 11-30-2010, 07:30 PM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
His kernel and Xorg are too old for modesetting to even come into play. "nomodeset" won't make a difference. I did notice that Xorg is running as server :1, which suggests that server :0 was running at some point.

To the OP, do you have a display manager (xdm/gdm/kdm) starting up when you reboot?

Adam
 
Old 12-01-2010, 08:40 AM   #11
abdoullah
Member
 
Registered: May 2009
Distribution: Gentoo, CentOS
Posts: 49

Original Poster
Rep: Reputation: 0
Hi Guys,
Thanks for your suggestions!
to jschiwal:
I did try nomodeset boot option (I did put it in the files you said like that:kernel /vmlinuz-2.6.18-194.el5 ro nomodeset root=/dev/VolGroup00/LogVol00 rhgb quiet crashkernel=128M@16M; I guess this how it should be, i've never have to do that )
however i didn't change anything as adamk75 said, still showing mouse then terminal just switching in between there.

to adamk75:
yes I do have a gdm, I checked and it says already running.
 
Old 12-01-2010, 08:43 AM   #12
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Before you do any further testing, I'd highly recommend disabling gdm and rebooting to make sure that X is not starting up by default. Then try the command I gave above "xinit /full/path/to/xterm"

Adam
 
Old 12-01-2010, 09:30 AM   #13
abdoullah
Member
 
Registered: May 2009
Distribution: Gentoo, CentOS
Posts: 49

Original Poster
Rep: Reputation: 0
If you mean by disabling, prevent gdm from running at startup: I tried disabling gdm using ntsysv and chkconfig but i couldn't.
but if you mean just using gdm-stop (which i don't think what you mean), I did try it but no success, I even tried to kill all gdm processes but i throws this :

root 9037 0.0 0.0 255356 4132 ? Sl 06:23 0:00 /usr/libexec/gdm-rh-security-token-helper
root 9423 0.0 0.0 255356 4124 ? Sl 06:26 0:00 /usr/libexec/gdm-rh-security-token-helper
root 10403 0.4 0.0 167600 2592 ? Ss 06:32 0:00 /usr/sbin/gdm-binary -nodaemon
root 10435 0.0 0.0 167600 1328 ? S 06:32 0:00 /usr/sbin/gdm-binary -nodaemon
root 10437 0.2 0.0 255356 4132 ? Sl 06:32 0:00 /usr/libexec/gdm-rh-security-token-helper
root 10455 0.0 0.0 3780 380 ? Ss 06:32 0:00 /usr/libexec/gdmopen -l /bin/sh -c /usr/bin/whiptail --yesno 'There already appears to be an X server running on display :0. Should another display number by tried? Answering no will cause GDM to attempt starting the server on :0 again. (You can change consoles by pressing Ctrl-Alt plus a function key, such as Ctrl-Alt-F7 to go to console 7. X servers usually run on consoles 7 and higher.)

can you give me a hint how to disable gdm?
 
Old 12-01-2010, 09:32 AM   #14
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
I meant disabling gdm from starting up at all when you boot up your machine. I do not know how to do this on CentOS, frankly, but ntsysv and chkconfig do sound like the correct mechanisms.

Adam
 
Old 12-01-2010, 09:39 AM   #15
abdoullah
Member
 
Registered: May 2009
Distribution: Gentoo, CentOS
Posts: 49

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by adamk75 View Post
I meant disabling gdm from starting up at all when you boot up your machine. I do not know how to do this on CentOS, frankly, but ntsysv and chkconfig do sound like the correct mechanisms.

Adam
Thanks Adam,
the thing is i tried using ntsysv but i can't see it at all, i cannot even see gnome. iwth chkconfig it says smthing like not applicable or...
anybody know how to prevent gdm from starting at boot or a solution to the whole issue? please help?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Some drivers don't start in Xorg 7.4 on LFS 6.3 with installed Xorg 6.9 10110111 Linux From Scratch 1 10-29-2010 03:55 AM
DualHead = Xorg will not start Hammett Linux - Software 1 08-02-2007 08:53 AM
xorg wont start any more lowebb Linux - General 1 08-23-2006 03:31 AM
Xorg wont start mapster Linux - Newbie 4 09-17-2005 08:02 AM
xorg Won't Start!! Urgent!! kasra_23 Linux - Newbie 5 05-02-2005 06:55 PM


All times are GMT -5. The time now is 05:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration