LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 01-31-2007, 04:12 PM   #1
itzig
Member
 
Registered: Jan 2006
Location: spaceship earth
Distribution: slackware 10.2, suse 9.2
Posts: 72

Rep: Reputation: 15
XMMS won't play next track


Hi ! I have xmms 1.2.10, running on suse 10.1. It used to work fine, but I since I set up my madman library, it stoppes after every song played. If I set it to repeat it repeats the same song over and over again. Any ideas what could be causing this?

txs!
 
Old 01-31-2007, 06:00 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I wasn't familiar with Madman, so I looked it up using Google. From the description, is says that it uses xmms as its backend player. It may replace the xmms playlist component to work. This is just a guess.

Try starting madman from the console and see if any errors are printed; but at first glance, it sounds to me that you need to use it from madman to play a playlist and not standalone. In other words, the playlist should be in the frontend and not loaded into xmms which is being used as a backend player.
 
Old 02-01-2007, 10:06 AM   #3
itzig
Member
 
Registered: Jan 2006
Location: spaceship earth
Distribution: slackware 10.2, suse 9.2
Posts: 72

Original Poster
Rep: Reputation: 15
thank you! i get no errors starting form the command line..
how can switch from backend to frontend?
 
Old 02-01-2007, 11:31 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Does running xmms directly work.
 
Old 02-04-2007, 11:18 AM   #5
itzig
Member
 
Registered: Jan 2006
Location: spaceship earth
Distribution: slackware 10.2, suse 9.2
Posts: 72

Original Poster
Rep: Reputation: 15
good question! I guess no. I added files without madman. it still stops after every track, and when I set it to repeat, it repeats one song all over again..
I did not do that b4 I started using madman, it must have to do with that somehow, I just don't know what!
 
Old 02-05-2007, 12:00 PM   #6
itzig
Member
 
Registered: Jan 2006
Location: spaceship earth
Distribution: slackware 10.2, suse 9.2
Posts: 72

Original Poster
Rep: Reputation: 15
would reinstalling xmms help?
 
Old 02-07-2007, 11:49 AM   #7
itzig
Member
 
Registered: Jan 2006
Location: spaceship earth
Distribution: slackware 10.2, suse 9.2
Posts: 72

Original Poster
Rep: Reputation: 15
solution: right click xmms, and uncheck 'no playlist advance' under options
 
Old 08-01-2010, 05:31 PM   #8
taz82
LQ Newbie
 
Registered: Aug 2010
Posts: 1

Rep: Reputation: 0
I have searched wide for an answer to this question.

I did not find such...

So I investigated this, and soon i isolated the problem (in my case)

I think all with the problem uses Alsa as output? Right?

I tried using diskwriter plugin & OSS, then XMMS changes track just fine..

Either XMMS dislikes newer ALSA-versions or someting else does not work the way it's supposed to...

I selected eSound output, and that works fine in Ubuntu 10.04 x64. However, the Spectrum analyzer slows down but that I can live with

This post is for all guys/girls googling for an answer "mostly"!

// Taz
 
Old 08-04-2010, 03:43 PM   #9
Zedrick
LQ Newbie
 
Registered: Aug 2010
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by taz82 View Post
I think all with the problem uses Alsa as output? Right?
Yes. Thanks a lot for your input. I've been a linux user since 1995, and I'm sticking to xmms even though it's not in the ubuntu repos anymore, and this was very annoying. Switching to OSS (+ unchecking no plalist advance for the 50th time) helped, thanks.

Now, excuse me while I go and beat my head to the wall for not trying this before.

Last edited by Zedrick; 08-04-2010 at 03:44 PM.
 
Old 02-18-2011, 05:29 PM   #10
robsku
LQ Newbie
 
Registered: Jul 2009
Location: Helsinki
Distribution: Debian GNU/Linux & Fedora 7
Posts: 3

Rep: Reputation: 0
Cool Thanks + questions

Quote:
Originally Posted by itzig View Post
solution: right click xmms, and uncheck 'no playlist advance' under options
Thank you, this solved the issue for me! Background:

Recently I bumped into this same issue - I'm not sure when I noticed it first time but I'm pretty sure that since last summer (I know it worked correctly last summer) I have not upgraded my XMMS installation (well, xmms itself has not been developed) so I'm betting that it's an issue with audio libraries it uses. If anyone can confirm this (or if anyone can prove me wrong) I'd be very interested to know what version/package of which program/library brought this issue on since I know I have used xmms for years (even this particular package/repository for over 2 years, or however long it has been since it was dropped from official repos, not sure if it was Debian 4/Etch or 5/Lenny time). And what causes this/why does it do so - and what is "advance playlist" option supposed to do (certainly not this) if it worked correctly anyway?

My distro: Was Debian 5 (Lenny) when I first noticed the issue. Early in january I installed Debian 5 from scratch and only now after upgrading to Debian 6 (Squeeze) I installed mp3 and other proprietary codecs and was faced with same issue again - I almost installed another audio player but thank god I googled about the issue first and found this thread with search for "xmms does not play next song".

My XMMS installation:
As everyone probably knows XMMS is not supported by major distros - I have used a 3rd party repository for .deb builds of xmms since Debian removed xmms from their official distributions - for those interested, xmms can be obtained from repository at http://www.pvv.ntnu.no/~knuta/xmms - it does not seem to have been updated to Debian Squeeze (6), but for Lenny (5) I used following line in /etc/sources.list
deb http://www.pvv.ntnu.no/~knuta/xmms/lenny ./

Now if anyone could just point me to a .deb with xmms-sid or whatever the plugin for playing sid files (c-64 tunes) was/is named - I used to have it on Red Hat/Fedora since before 2004 but have never installed it on debian when I switched distro...
Now my copy of High Voltage SID Collection is just using HD space for nothing...
 
Old 08-30-2013, 05:12 AM   #11
durval
LQ Newbie
 
Registered: Mar 2012
Posts: 7

Rep: Reputation: Disabled
Another way to fix it, and how it got broken in the first place...

Hi,

Quote:
Originally Posted by itzig View Post
solution: right click xmms, and uncheck 'no playlist advance' under options
I found that by myself, but in the ~/.xmms/config file: there was a "no_playlist_advance=TRUE" line there, I simply stopped xmms, changed that line to FALSE, and restarted xmms and now it's behaving normally (i.e., advancing to the next track after playing the current one).

I think I also found how my XMMS ended up getting that braindamaged setting turned on: there's a keyboard accelerator (^N) that will toggle it, and I use this key combination in another program... so I probably toggled it by pressing ^N while having XMMS as the active window instead of that other program... color me stupid, or rather, color XMMS accelerator settings stupid for putting an accelerator for something that's so rarely used (and even less desired, I guess) :-)

But now it's fixed for good ;-)

Cheers,
--
Durval Menezes.

Last edited by durval; 08-30-2013 at 05:13 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TOSlink track change with ALSA and XMMS OdieQ Linux - Hardware 0 06-13-2005 07:03 AM
How to get Xmms to play more than one track? DavidTempler Linux - Newbie 8 04-27-2004 11:40 PM
xmms won't play the last track of the cd Kovacs Slackware 1 02-22-2004 01:58 AM
xmms: sort by track number ianunderwood Linux - Software 1 08-16-2003 03:33 PM
can't add track in xmms ! ShiShi *BSD 3 03-08-2003 11:38 AM


All times are GMT -5. The time now is 12:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration