LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 05-31-2008, 04:56 PM   #1
nolrai
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
Unhappy Xlib: extension "GLX" missing on display ":0.0".


So, after upgrading to Hardy Heron, I tried updating my graphics drivers to the propitiatory ones, but the configeration manager that came with the driver totaly messed up my system. (at one point I was down to 640x420 resolution) Going back to the default xorg.conf most every thing got fixed, but now when I run "wine dwarfort.exe" I get:
Xlib: extension "GLX" missing on display ":0.0".
err:wgl:X11DRV_WineGL_InitOpenglInfo couldn't initialize OpenGL, expect problems
err:wgl:X11DRV_wglGetProcAddress No libGL on this box - disabling OpenGL support !
err:wgl:X11DRV_wglGetProcAddress No libGL on this box - disabling OpenGL support !
err:wgl:X11DRV_wglGetProcAddress No libGL on this box - disabling OpenGL support !
err:wgl:X11DRV_ChoosePixelFormat No libGL on this box - disabling OpenGL support !

I definitely have libGL installed so I don't know whats up
heres my xorg.conf:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
Load "dbe"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

Am I missing something?
 
Old 05-31-2008, 07:22 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
My guess is that when you ran the nvidia-installer program, you didn't carry through with the option to replace the glx library with nvidia's version.
for example:
a file like libglx.so.1.0.9746 may need to be installed (the version is probably different).

The upgrade will have installed a different kernel. So the installer program needed to install the nvidia kernel module for that kernel. That part probably went OK because you do see a video output using the "nvidia" driver in xorg.conf.

Another possibility is a problem with the xorg.conf file. The installer includes a program "nvidia-xconfig" that might clear up your resolution problems. I think your problem may have two parts. An XGL problem and a screen resolution problem.

Your Screen section does seem to be missing the resolutions you want:
Code:
Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       15
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
EndSection
The Monitor & Device sections loop pretty barren as well.
Code:
Section "Modes"
    Identifier         "Modes[0]"
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "HP"
    ModelName      "ZV5000"
    UseModes       "Modes[0]"
    DisplaySize     332    207
    HorizSync       32.0 - 48.0
    VertRefresh     40.0 - 70.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "GeForce4 440 Go 64M"
    Screen          0
EndSection
The Monitor section usually contains the vertical & horizontal frequency ranges. The Modes section if any may be empty as in my case. If your monitor has a non-standard resolution, you may need to run "gtf <horizontal_pixels> <vertical_pixels> <refresh_rate> -x" to generate a custom mode line. That line can be entered in the Modes section and then it's label entered in the Screen.Display subsections. If you do this, drop the trailing ".00" from the label.
Code:
gtf 1280 800 60 -x

From:
  # 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
  Modeline "1280x800_60.00"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
To:
  # 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
  Modeline "1280x800_60"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync

...

SubSection     "Display"
        Depth       24
        Modes      "1280x800_60" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
 
Old 06-12-2008, 08:53 PM   #3
nolrai
LQ Newbie
 
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Unhappy

Unfortunately, putting in those pieces that you provided just broke the .xconf, and caused me to be limited to 800X640 (or there about).
Is there any way to just undo what ever the installer did that broke glx library?
I definitely did follow through and installed nvida's version from the installer but it still doesn't work.
Any other ideas?
Right now i can get 12800x800 so that's fine, but I would very much like to get XGL working again.
 
Old 06-15-2008, 02:18 AM   #4
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
Quote:
Going back to the default xorg.conf most every thing got fixed, but now when I run "wine dwarfort.exe" I get:
Xlib: extension "GLX" missing on display ":0.0".
If I'm reading the quote above correctly, your using the xorg.conf file which has the "nv" or "vesa" driver specified in the device section. This configuration will not give you what you're after. After installing the Nvidia proprietary drivers you should change this to "nvidia" as it appears in the configuration you posted. But that /etc/X11/xorg.conf file is missing allot, such as monitor's horizontal and vertical refresh rates and display modes in the screen section.

Simply copying someone else's configurations can break your system.
The route I suggest you take is to gather up the information regarding your monitor's refresh rates, if you can't get it on-line or from documentation on hand you can accept default values during the configuration of your graphics. Save a copy of all xorg.conf files you have and run a configuration utility to draw up a good working /etc/X11/xorg.conf file. Then install the Nvidia proprietary drivers and saying no to letting it re-write the configuration file during setup, then you'll edit it by hand.
To re-configure your graphics to get all the right information, follow these steps:

1: run command: sudo dpkg-reconfigure xserver-xorg, go through all the steps and input whatever information you can from documentation you have, for any question you don't know the answer, hit the enter key to accept the default values. At the display modes section, use the space key to enable the mode you need and some of the lower ones as the generic driver may not be capable of displaying the high one, example: "1280x1024" "1024x768" "800x600" "640x480".
By using this configuration utility, you'll straighten out your xorg.conf file and get some necessary information, but all the 3D options will disappear. You should now be using the generic "nv" driver.

2: Un-install any proprietary driver stuff from previous attempts. Example: If you were using NVIDIA-Linux-x86-96.43.05-pkg1.run, run command in same directory as the script in single user mode (command line mode only): sh NVIDIA-Linux-x86-96.43.05-pkg1.run --uninstall.

3: Install the proprietary drivers making sure to have kernel-headers installed with command: sh NVIDIA-Linux-x86-96.43.05-pkg1.run, if it asks for confirmation to rewrite the configuration file, say no!.

4: Edit the /etc/X11/xorg.conf file with command: sudo vim /etc/X11/xorg.conf. Change the driver in the device section to "nvidia" from "nv". Add acceleration options to appropriate sections like/similar to what you had before and comment out again the 'load "dri"' part. Add the extensions section but this time enable composite. Save the file and try the graphics.
Below is my Debian xorg.conf file to show what it should typically look like to enable glx and acceleration.
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Sat May 26 01:03:50 PDT 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"

	# path to defoma fonts
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/X11R6/lib/X11/fonts/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/usr/X11R6/lib/X11/fonts/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load           "bitmap"
    Load	   "dbe"
    Load           "ddc"
    Load	   "evdev"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load	   "record"
    Load	   "type1"
    Load           "vbe"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
    Option         "Device" "/dev/input/mice"
    Option         "Protocol" "ImPS/2"
    Option         "Emulate3Buttons" "true"
EndSection

Section "Monitor"
    Identifier     "Dell 1905FP"
    HorizSync       28.0 - 64.0
    VertRefresh     43.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "NVIDIA GeForce 6800"
    Driver         "nvidia"
    Option         "XAANoOffscreenPixmaps" "true"
    Option         "AllowGLXWithComposite" "true"
    Option         "TripleBuffer" "true"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA GeForce 6800"
    Monitor        "Dell 1905FP"
    Option         "AddARGBGLXVisuals" "true"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection
The "DPMS" option is for monitors using the digital interface.

Last edited by Junior Hacker; 06-15-2008 at 02:32 AM. Reason: Added info, changed editor from graphical type to command line type.
 
Old 06-19-2008, 05:10 PM   #5
nolrai
LQ Newbie
 
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
OK I tried those steps, but they didn't work.

Right now my xorg.conf is blank and I get as good resolution as I need, but still get that error with "extension "GLX" missing".

First, when I uninstalled it gave a lot of error messages but did uninstall something.

When I run dpkg-reconfigure, all it asks about is the keyboard and mouse. It doesn't seem to set up the display at all.
The xorg.conf from failsafeDexconf has more info in it!

am messing around, but i dont need the new drivers is there any way to get back to where i was before i tried to install them? (I assume that is what the uninstall was supposed to do, sigh.)
 
Old 06-21-2008, 01:29 AM   #6
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
Quote:
When I run dpkg-reconfigure
Have you tried using command: sudo dpkg-reconfigure xserver-xorg
Quote:
am messing around, but i dont need the new drivers is there any way to get back to where i was before i tried to install them?
Have you tried using command: sudo dpkg-reconfigure xserver-xorg
This should bring you back to original or better configuration.
 
  


Reply

Tags
heron, nvidia, opengl, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: extension "GLX" missing on display ":0.0". jrk5050 Linux - Hardware 5 05-09-2008 12:19 AM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". HELP! badgerbox76 Linux - Newbie 35 03-08-2007 03:27 AM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". badgerbox76 Linux - Games 13 01-11-2006 05:47 PM
Xlib: extension "GLX" missing on display ":0.0" Evohack Linux - Software 18 10-23-2003 11:10 PM


All times are GMT -5. The time now is 01:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration