LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   XGL needed for Beryl is conflicting with OpenGL needed for Cedega (http://www.linuxquestions.org/questions/linux-desktop-74/xgl-needed-for-beryl-is-conflicting-with-opengl-needed-for-cedega-569969/)

chunkeydelight 07-16-2007 11:16 PM

XGL needed for Beryl is conflicting with OpenGL needed for Cedega
 
well i've managed to figure out how to install Beryl on Ubuntu Feisty Fawn... and how to get it so XGL runs with my session in order for Beryl to work.... but then when i go into Cedega and run the tests it says the OpenGL fails due to certain reasons.... i've been tryin to figure it out with various forums and found out about the xlginfo command..... and w/e i type that into my terminal i get this messege at the top:

Code:

Xlib:  extension "XFree86-DRI" missing on display ":1.0".
display: :1  screen: 0
direct rendering: No

after a lil thinking i realized that i had to create a script /usr/local/bin that allowed me to use XGL with my desktop and it forced 'display: 1'..... so i changed it in the script to goto 'display 0' and when i do the direct rendering says yes and Cedega works fine.... but when i do the XGL was jus an extra window in my environment...... i've tried so much over and over with different things i can't even remember anymore...... i'm jus so burnt out from tinking....... i've looked in my xorg.conf file and it doesn't help me much since i'm not entirely sure wut it means to me... but i'll post it and the XGL script incase that helps too

XGL Script:
Code:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

xorg.conf:
Code:

Section "ServerLayout"
        Identifier    "Default Layout"
        Screen        "Default Screen" 0 0
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
        InputDevice    "stylus" "SendCoreEvents"
        InputDevice    "cursor" "SendCoreEvents"
        InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

        # path to defoma fonts
        FontPath    "/usr/share/fonts/X11/misc"
        FontPath    "/usr/share/fonts/X11/cyrillic"
        FontPath    "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/X11/Type1"
        FontPath    "/usr/share/fonts/X11/100dpi"
        FontPath    "/usr/share/fonts/X11/75dpi"
        FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load  "i2c"
        Load  "bitmap"
        Load  "ddc"
        Load  "dri"
        Load  "extmod"
        Load  "freetype"
        Load  "glx"
        Load  "int10"
        Load  "vbe"
EndSection

Section "InputDevice"
        Identifier  "Generic Keyboard"
        Driver      "kbd"
        Option            "CoreKeyboard"
        Option            "XkbRules" "xorg"
        Option            "XkbModel" "pc105"
        Option            "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Configured Mouse"
        Driver      "mouse"
        Option            "CorePointer"
        Option            "Device" "/dev/input/mice"
        Option            "Protocol" "ImPS/2"
        Option            "ZAxisMapping" "4 5"
        Option            "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
        Identifier  "stylus"
        Driver      "wacom"
        Option            "Device" "/dev/input/wacom"
        Option            "Type" "stylus"
        Option            "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Identifier  "eraser"
        Driver      "wacom"
        Option            "Device" "/dev/input/wacom"
        Option            "Type" "eraser"
        Option            "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
        Identifier  "cursor"
        Driver      "wacom"
        Option            "Device" "/dev/input/wacom"
        Option            "Type" "cursor"
        Option            "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
        Identifier  "SyncMaster"
        Option            "DPMS"
EndSection

Section "Device"
        Identifier  "Generic Video Card"
        Driver      "fglrx"
        Option            "VideoOverlay" "on"
        Option            "OpenGLOverlay" "on"
        BusID      "PCI:6:0:0"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device    "Generic Video Card"
        Monitor    "SyncMaster"
        DefaultDepth    24
        SubSection "Display"
                Depth    1
                Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth    4
                Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth    8
                Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth    15
                Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth    16
                Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth    24
                Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Mode        0666
EndSection

Section "Extensions"
        Option            "Composite" "0"
EndSection


dahveed3 07-17-2007 10:54 PM

XGL kind of usurps the openGL for itself. When you want to play OpenGL games just adjust your settings to return xorg to being in charge and to start your GUI without Beryl, reboot and play your games. When done, return XGL to being in charge and to have Beryl run, reboot, and you're back to your 3D desktop.

That's just the price of waiting for ATI to produce drivers that either can use AIGLX or its own GLX as NVidia does.

In the meantime XGL does a very nice job for our 3D desktops but must be turned off, along with our composite manager (Compiz, Beryl, Compiz-Fusion), to play our 3D games.

Hence my switch to NVidia a couple of months ago. No more hastle with changing back and forth is necessary, plus my games have much better frame rates on Linux and more of them work than with ATI.

I'm on Debian Lenny now. Back when I used XGL and ATI I was running OpenSUSE. OpenSUSE has a neat tool called OpenSUSE XGL settings that handles both switching to XGL and back and activating Beryl. Another tool was YaST, which has a setting in /etc/sysconfig_editor that allows you to switch back and forth from Xorg to XGL within the GUI without writing your own script. Very nice.

I think Ubuntu has Desktop Effects in the Gnome Control Center but that is more for Compiz use. Still, you can get it done with a simple script as well. I think the Gentoo wiki described the system file you need to edit. He wrote that you can put both entries (with XGL and with Xorg) in there and simply put the # mark in front of the one you don't want the system to use when you bootup. I forget exactly which file to edit but if you head over there and look for Beryl and XGL info I'm sure you'll find his how to.

chunkeydelight 07-18-2007 05:50 AM

well... thanks for the advice..... i was hoping that there would be another way of doing it so that i can keep Beryl running while playing WoW or w/e..... also.... with that script... i can change the session w/e i want... i jus have to change it w/e i log in... so i could even reboot the xserver (or w/e it's called. i can't really remember).... i may play around with it a lil more and c if i can't get them both to work together
i wish i knew more about this but i'm still in the beginner stages with linux all together


All times are GMT -5. The time now is 11:05 PM.