LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Xfce4-panel-1.0.pc (http://www.linuxquestions.org/questions/linux-desktop-74/xfce4-panel-1-0-pc-632620/)

The Gargantuan 04-03-2008 12:46 AM

Xfce4-panel-1.0.pc
 
Note: I am using Xfce on Slackware.

I was on the Xfce website and downloaded a package that would put a battery icon in my system tray so I could tell how much life I had on my laptop. So I downloaded and when I went to compile, I got this at the end of the output:

Code:

checking for pkg-config... /usr/bin/pkg-config
checking for xfce4-panel-1.0 >= 3.99.2... Package xfce4-panel-1.0 was not found in the pkg-config search path. Perhaps you should add the directory containing `xfce4-panel-1.0.pc' to the PKG_CONFIG_PATH environment variable No package 'xfce4-panel-1.0' found
configure: error: Library requirements (xfce4-panel-1.0 >= 3.99.2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

So I did a pkg-config --list-all and found that I had this file
Code:

libxfce4panel-1.0
but not the
Code:

xfce4-panel-1.0.pc
I've spent all evening on google trying to find a solution. It seems that many people run across this problem when trying to install things for xfce but no one has posted a solution for me.

Thanks for any help!
Tom

weibullguy 04-03-2008 11:47 AM

I'm guessing you're using version 4.4 of XFCE and trying to install the battery plugin for version 4.2. There is no xfce4-panel-1.0.pc file in version 4.4; it is now libxfce4panel-1.0.pc. The current stable release for the battery plugin is 0.5.0 (http://goodies.xfce.org/projects/pan...battery-plugin). Try using that.

The Gargantuan 04-04-2008 02:12 AM

Quote:

Originally Posted by weibullguy (Post 3109642)
I'm guessing you're using version 4.4 of XFCE and trying to install the battery plugin for version 4.2. There is no xfce4-panel-1.0.pc file in version 4.4; it is now libxfce4panel-1.0.pc. The current stable release for the battery plugin is 0.5.0 (http://goodies.xfce.org/projects/pan...battery-plugin). Try using that.

Thanks man. That is the update, but turns out that apm isn't working with my kernel so I have to recompile. Yay.


All times are GMT -5. The time now is 05:33 PM.