LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-30-2009, 11:31 AM   #1
hln
LQ Newbie
 
Registered: Sep 2009
Distribution: Slackware 13.0
Posts: 9

Rep: Reputation: 0
XFCE4 error "Failed to mount <name_of_CD-ROM>" in Slackware 13.0


Using XFCE4 on Slackware 13.0 x86 on a machine with x64 capability

When attempting to use CD-ROM I insert the disk into the tray and attempt to access the files using the Thunar application from XFCE4. When I click on the tab indicating the CD in the drive I receive this error message:

Failed to mount "UBCD410".
Rejected send message, 1 matched rules; type="method_call", sender=":1.30" (uid=1000 pid=4261 comm="exo-mount -n -h /org/freedesktop/Hal/devices/volum") interface="org.freedesktop.Hal.Device.Volume" member="Mount" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=3316 comm="/usr/sbin/hald --daemon=yes ")).


(Above was copied and pasted to avoid errors.)

I have no idea that error message means. What I do know is that it is attempting to auto mount the CD and being rejected (by HAL?). If it is a HAL problem then I will need detailed instructions because that is a topic that I am not experienced in.

This seems to be an XFCE4 problem or KDE problem because the drive can be mounted through the command line. The Thunar application has been configured through preferences to auto mount removable media.

I would like a simple explanation of what is going wrong but a solution is still my top priority.
 
Old 09-30-2009, 07:50 PM   #2
erbngeek
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 2
This is generally a permissions issue. Try adding yourself to the plugdev group. Actually the adduser script does have an option for other groups to be added to a new user account. Just hit the up arrow at the right time during the setup. Since you already have an account setup you can run the following as root and it should do the trick.

usermod -G floppy,audio,video,cdrom,plugdev,power,netdev <your login name>

BTW, those are the default groups that come up if you hit the up arrow when running the adduser script.

Enjoy!
 
Old 10-01-2009, 08:48 AM   #3
hln
LQ Newbie
 
Registered: Sep 2009
Distribution: Slackware 13.0
Posts: 9

Original Poster
Rep: Reputation: 0
Still getting the same error messages when attempting to auto-mount the CD on a non-root account, but this does seem to be a user-rights problem because logging in as root does not give me any problems. I am out of ideas, anyone have suggestions.

Last edited by hln; 10-01-2009 at 08:50 AM.
 
Old 10-01-2009, 09:06 AM   #4
hln
LQ Newbie
 
Registered: Sep 2009
Distribution: Slackware 13.0
Posts: 9

Original Poster
Rep: Reputation: 0
Quick Fix

Added a new user with suggested groups using adduser instead of adding groups to the user with usermod. The new user is able to use the drive without difficulty, but the edited user is still unable to use the drive. It is a fix but I would also like an explanation of why the system works like this, anyone have an answer?
 
Old 10-01-2009, 10:19 AM   #5
hln
LQ Newbie
 
Registered: Sep 2009
Distribution: Slackware 13.0
Posts: 9

Original Poster
Rep: Reputation: 0
I cannot unmount or eject the CD. When I press the eject button on the drive I get this message:

Failed to eject "/org/freedesktop/Hal/devices/storage_serial_2006082400".

Given device "/org/freedesktop/Hal/devices/storage_serial_2006082400" is not a volume or drive.

There is a disk in there and I am in these groups:

bash-3.1$ groups
users floppy audio video cdrom plugdev power netdev

What could I do aside from logging in as root.

Last edited by hln; 10-01-2009 at 10:24 AM.
 
Old 10-01-2009, 12:52 PM   #6
erbngeek
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 2
Did you reboot?

I just did some extensive testing on this. It appears that the hal does some stuff depending on existing group permisstions when it initialized. I tried just restarting hald (/etc/rc.d/rc.hald restart) but that didn't seem to work. There must be more that I'm overlooking, but I didn't have any more time to investigate, but after adding the additional groups and then rebooting everything worked fine. So try a reboot.

I also get the error message when trying to eject using the physical button to eject, but the right-click->Eject Volume works just fine!
 
Old 10-01-2009, 01:14 PM   #7
hln
LQ Newbie
 
Registered: Sep 2009
Distribution: Slackware 13.0
Posts: 9

Original Poster
Rep: Reputation: 0
At least I can get the tray open, still odd how the button will only work for the first few minutes after I log in, after that only right click -> eject will work. Thanks for the help, but further explanation will also be greatly appreciated; especially if you can get the button on the drive to work.

I didn't know just how secure Linux was until dealing with this.

Last edited by hln; 10-01-2009 at 01:15 PM.
 
Old 10-01-2009, 01:44 PM   #8
erbngeek
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 2
I think the system rejects the eject button if the resource is in use. Have you made sure the disk is unmounted before hitting the button. In any case I think it's a good idea as I have sometimes blown an installation (ie Windows) by simply bumping the button. I understand wanting convenience, but as you mention security, there is usually a good reason something is the way it is, especially in Slackware.

The old battle of convenience or ease of use vs. security.


That's about all I got for you.
 
Old 10-01-2009, 01:59 PM   #9
hln
LQ Newbie
 
Registered: Sep 2009
Distribution: Slackware 13.0
Posts: 9

Original Poster
Rep: Reputation: 0
Good point, just going to have to let users know to eject the disk through the file manager. Though it may be nice to have the OS load the CD into a folder instead of mounting it, so users can eject the disk. But that brings up more problems and should be saved for another thread.
 
Old 10-01-2009, 04:08 PM   #10
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Try leaving the mounted CD folder prior the eject button.

Default Linux behavior for years was to disable eject button. Unmounting CD first is/was only proper course of action.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"failed to execute child process" "Input/output error" fl.bratu Fedora 4 12-15-2008 04:03 AM
"Failed Dependency error" while installing RPM for "DateTime" perl modules giridhargopal.cj Linux - Newbie 7 11-19-2008 12:05 AM
Slackware 11.0, cant mount dvd-rom: "no medium" wnk Linux - Hardware 8 07-26-2007 02:17 PM
Problems w/ Installation -- "Unable to detect and mount CD-ROM"? Sabriel Dyrim Ubuntu 1 09-20-2005 03:38 PM
CD ROM mount error: "no medium found"????? RonRussell Linux - Hardware 8 07-01-2002 12:34 PM


All times are GMT -5. The time now is 01:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration