LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 05-15-2010, 03:00 PM   #1
mowestusa
Member
 
Registered: May 2005
Distribution: Ubuntu Server 11.04
Posts: 33
Blog Entries: 11

Rep: Reputation: 15
XFCE will not start from GDM in Debian Sid


I would appreciate any help that you can offer. When starting XFCE from GDM it starts loading, but then stops about the time the desktop should appear. This is a copy of the file: ~/.xsession-errors

Code:
/etc/gdm/Xsession: Beginning session setup...
/usr/bin/startxfce4: X server already running on display :0
<stdin>:1:3: error: invalid preprocessing directive #Those
<stdin>:2:3: error: invalid preprocessing directive #or
<stdin>:3:3: error: invalid preprocessing directive #Xft
<stdin>:4:3: error: invalid preprocessing directive #Xft

(xfwm4:2087): libxfcegui4-WARNING **: ICE I/O Error

(xfwm4:2087): libxfcegui4-WARNING **: Disconnected from session manager.

(xfce4-settings-helper:2090): libxfcegui4-WARNING **: ICE I/O Error

(xfce4-settings-helper:2090): libxfcegui4-WARNING **: Disconnected from session manager.

(xfce4-panel:2094): libxfcegui4-WARNING **: ICE I/O Error

(xfce4-panel:2094): libxfcegui4-WARNING **: Disconnected from session manager.
Segmentation fault
Your help in fixing my XFCE install would be great. I can on the same machine boot into Fluxbox without issue. I haven't tried installing Gnome because this machine is a Celeron 500 with only 256megs of ram.
 
Old 05-15-2010, 07:48 PM   #2
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , Various Puppys (MacPup,Slack0),MX-14
Posts: 2,577
Blog Entries: 16

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Please press CTRL + ALT + F1 and login. The password will not be displayed. Then type

rm -r /home/(your user name goes here)/.ICEauthority

and press enter.

After that press CTRL + ALT + F7 and login again. You should be able to login again.

What you will be doing is removing the ICEauthority file. In case you are wondering what I am suggesting.


If you want to go gui instead. Just boot up live cd and delete ~/.ICEauthority using file manager.

Here is a shot of mine but I use Icewm and slim in AntiX

Attachment 3576

Last edited by rokytnji; 11-18-2011 at 07:06 PM.
 
Old 05-15-2010, 08:15 PM   #3
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , Various Puppys (MacPup,Slack0),MX-14
Posts: 2,577
Blog Entries: 16

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
On another note. Apt-get upgrade is Sid seems to be broken this weekend. Just a cautionary note.

http://people.skolelinux.org/pere/bl..._unstable.html

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581704
 
Old 05-17-2010, 07:44 AM   #4
mowestusa
Member
 
Registered: May 2005
Distribution: Ubuntu Server 11.04
Posts: 33
Blog Entries: 11

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rokytnji View Post
Please press CTRL + ALT + F1 and login. The password will not be displayed. Then type

rm -r /home/(your user name goes here)/.ICEauthority

and press enter.

After that press CTRL + ALT + F7 and login again. You should be able to login again.

What you will be doing is removing the ICEauthority file.
Thanks this fixed it perfectly. I will have to look up the .ICEauthority file. I have no idea what it does or why it would have stopped working suddenly. Thanks a lot for the fix. I'm in XFCE right now as I type this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using debian-sid/fluxbox; How to start a terminal app from menu?? linus72 Linux - General 5 09-23-2009 11:38 AM
xorg dosent start after upgrade, debian sid. IM baack! Linux - Software 4 07-11-2009 04:20 AM
emerald won't start at gnome boot - Debian Sid pietruszewski Linux - Desktop 1 05-15-2008 12:21 PM
DEBIAN: GDM won't start, fglrx needs libstdc++.so.5, but not found oguzhanozgul Linux - Newbie 3 02-06-2007 01:52 AM


All times are GMT -5. The time now is 09:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration