LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   XFCE will not start from GDM in Debian Sid (http://www.linuxquestions.org/questions/linux-desktop-74/xfce-will-not-start-from-gdm-in-debian-sid-808051/)

mowestusa 05-15-2010 03:00 PM

XFCE will not start from GDM in Debian Sid
 
I would appreciate any help that you can offer. When starting XFCE from GDM it starts loading, but then stops about the time the desktop should appear. This is a copy of the file: ~/.xsession-errors

Code:

/etc/gdm/Xsession: Beginning session setup...
/usr/bin/startxfce4: X server already running on display :0
<stdin>:1:3: error: invalid preprocessing directive #Those
<stdin>:2:3: error: invalid preprocessing directive #or
<stdin>:3:3: error: invalid preprocessing directive #Xft
<stdin>:4:3: error: invalid preprocessing directive #Xft

(xfwm4:2087): libxfcegui4-WARNING **: ICE I/O Error

(xfwm4:2087): libxfcegui4-WARNING **: Disconnected from session manager.

(xfce4-settings-helper:2090): libxfcegui4-WARNING **: ICE I/O Error

(xfce4-settings-helper:2090): libxfcegui4-WARNING **: Disconnected from session manager.

(xfce4-panel:2094): libxfcegui4-WARNING **: ICE I/O Error

(xfce4-panel:2094): libxfcegui4-WARNING **: Disconnected from session manager.
Segmentation fault

Your help in fixing my XFCE install would be great. I can on the same machine boot into Fluxbox without issue. I haven't tried installing Gnome because this machine is a Celeron 500 with only 256megs of ram.

rokytnji 05-15-2010 07:48 PM

Please press CTRL + ALT + F1 and login. The password will not be displayed. Then type

rm -r /home/(your user name goes here)/.ICEauthority

and press enter.

After that press CTRL + ALT + F7 and login again. You should be able to login again.

What you will be doing is removing the ICEauthority file. In case you are wondering what I am suggesting.


If you want to go gui instead. Just boot up live cd and delete ~/.ICEauthority using file manager.

Here is a shot of mine but I use Icewm and slim in AntiX

Attachment 3576

rokytnji 05-15-2010 08:15 PM

On another note. Apt-get upgrade is Sid seems to be broken this weekend. Just a cautionary note.

http://people.skolelinux.org/pere/bl..._unstable.html

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581704

mowestusa 05-17-2010 07:44 AM

Quote:

Originally Posted by rokytnji (Post 3970138)
Please press CTRL + ALT + F1 and login. The password will not be displayed. Then type

rm -r /home/(your user name goes here)/.ICEauthority

and press enter.

After that press CTRL + ALT + F7 and login again. You should be able to login again.

What you will be doing is removing the ICEauthority file.

Thanks this fixed it perfectly. I will have to look up the .ICEauthority file. I have no idea what it does or why it would have stopped working suddenly. Thanks a lot for the fix. I'm in XFCE right now as I type this.


All times are GMT -5. The time now is 05:44 AM.