LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   X starts without xorg.conf, however with aticonfig, resultant xorg.conf hangs (http://www.linuxquestions.org/questions/linux-desktop-74/x-starts-without-xorg-conf-however-with-aticonfig-resultant-xorg-conf-hangs-4175421769/)

linuxbird 08-12-2012 07:07 PM

X starts without xorg.conf, however with aticonfig, resultant xorg.conf hangs
 
When I start with an aticonfig created xorg.conf, I get a message that fglrx cannot find a matching device.

However when I start X without a xorg.conf, things start OK. I'll need an xorg.conf, because I am running multi-headed. Right now I am just trying to get X up with one monitor.

The ATI card is a 6770 series. And I can query it with xrandr when X starts without a xorg.conf file.

I am using Slackware -current

Anyone have any experience with this?

TobiSGD 08-12-2012 07:18 PM

Do you have the radeon driver blacklisted?

linuxbird 08-12-2012 07:19 PM

Quote:

Originally Posted by TobiSGD (Post 4752725)
Do you have the radeon driver blacklisted?

Yes I do.

sKaar 08-23-2012 05:28 AM

startx without a config, it'd make a temporary one, startup, find it. compare it to the one aticonfig made, post the differences?

i remember reading that there was some work to make an xorg.conf unnecessary, just start it up, and it works, maybe it's doing that, and the two methods are butting heads.


All times are GMT -5. The time now is 02:02 PM.