LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Wubi Installed Ubuntu Doesn't Allow choose OS (http://www.linuxquestions.org/questions/linux-desktop-74/wubi-installed-ubuntu-doesnt-allow-choose-os-934759/)

webmanoffesto 03-16-2012 05:48 AM

Wubi Installed Ubuntu Doesn't Allow choose OS
 
I'm running a recent version of Ubuntu as a dualboot (Wubi installed). Now when I reboot my computer I get to the screen (GRUB?) where Windows 7 is the default OS and I can down-arrow to boot into Ubuntu. But the down-arrow (and up arrow and letter keys) don't do anything, so the computer does a default boot into W7. I want to bet back to Ubuntu without reinstalling it. What should I do?

webmanoffesto

yancek 03-16-2012 11:22 AM

Do the arrows work once booted or is it just during the boot process that they fail?
You can modify the /etc/default/grub folder to change the default option. Since you can't boot Ubuntu, you would need to use your Ubuntu CD to access the installed partition. Take a look at this site, particularly Section 12.1. It discusses reinstalling but you would use basically the same method(s) to mount and access the partition to modify the file.

syg00 03-16-2012 09:51 PM

Except it's a wubi installation. No partition, just a loop mount I believe.
Never used it, but there used to be a wubi only thread on the ubuntu forums - here it is. It's mega - like 99 pages mega ...

(BTW yancek, you forgot to include the link).

jefro 03-16-2012 10:02 PM

Wubi seems to be OK for some people.

It is a windows application that should correctly install grub and linux.

This grub should not be unusual. Not all keyboards work however. First thing I'd do is look at bios and see if there is any "legacy" usb or such like keyboard usb. This assumes you have a usb keyboard. Assumes standard keyboard.

If you have a PS/2 then kind of hard to say. It could be quite a number of issues. Bad cd, data or chipset or maybe odd keyboard.

Post specs of system. Tell us if you see normal keyboard lights. See if you can change state of numblock at boot.

If you boot to a live linux cd, does it work correctly. It should correctly.

You can boot to Windows and use programs to remove. All else fails consider a virtual machine or a standard dual boot. Remember the wubi was supposed to be a more safe way to run linux. A dual boot can cause some issues.

webmanoffesto 04-11-2012 03:11 AM

Now this is weird. I uninstalled WUBI (like uninstalling an app in Windows, and I used Revo Uninstaller. Then I installed WUBI using a newly downloaded Ubuntu distro (11.10). I rebooted, and I still can't select Ubuntu (in order to not boot into Windows 7).

TommyC7 04-11-2012 04:02 AM

I thought wubi.exe made a few folders that aren't deleted after you remove the program. I could be wrong though as it's been a long time since I used wubi on an old computer.

webmanoffesto 04-15-2012 09:39 AM

Problem Solved
 
Problem solved by using either an old keyboard with PS/2 connector, or by using new USB Keyboard with a PS/2 adapter plugged into the PS/2 jack.

TobiSGD 04-15-2012 10:13 AM

I wouldn't consider that a solution, rather a work-around. May I ask you for the manufacturer and model of your mainboard?

webmanoffesto 04-16-2012 02:36 AM

SIW Portable says

ASRock ConRoe1333-D667 R2.0
http://www.asrock.com/mb/overview.as...33-D667%20R2.0
BIOS - 4Mb AMI BIOS
- AMI Legal BIOS
- Supports "Plug and Play"
- ACPI 1.1 Compliance Wake Up Events
- Supports Jumperfree
- SMBIOS 2.3.1 Support

TobiSGD 04-16-2012 08:19 AM

Try that:
- Attach your PS/2-keyboard, start the machine and go into the BIOS (F2-key)
- Press left to go to the "Advanced" page
- Go into the "USB Configuration" sub-menu
- Enable the option "Legacy USB support"
- Press F10 to save the settings and confirm the security question.

Now your USB keyboard should work.

webmanoffesto 04-17-2012 07:37 AM

It Worked! Thanks :-)
 
Quote:

Originally Posted by TobiSGD (Post 4654072)
Try this:
- Attach your PS/2-keyboard, start the machine and go into the BIOS (F2-key)
- Press left to go to the "Advanced" page
- Go into the "USB Configuration" sub-menu
- Enable the option "Legacy USB support"
- Press F10 to save the settings and confirm the security question.
Now your USB keyboard should work.

That worked great. Thanks so much.


All times are GMT -5. The time now is 09:55 AM.