LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-16-2012, 05:48 AM   #1
webmanoffesto
LQ Newbie
 
Registered: May 2010
Posts: 10

Rep: Reputation: 0
Wubi Installed Ubuntu Doesn't Allow choose OS


I'm running a recent version of Ubuntu as a dualboot (Wubi installed). Now when I reboot my computer I get to the screen (GRUB?) where Windows 7 is the default OS and I can down-arrow to boot into Ubuntu. But the down-arrow (and up arrow and letter keys) don't do anything, so the computer does a default boot into W7. I want to bet back to Ubuntu without reinstalling it. What should I do?

webmanoffesto
 
Old 03-16-2012, 11:22 AM   #2
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,525

Rep: Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702
Do the arrows work once booted or is it just during the boot process that they fail?
You can modify the /etc/default/grub folder to change the default option. Since you can't boot Ubuntu, you would need to use your Ubuntu CD to access the installed partition. Take a look at this site, particularly Section 12.1. It discusses reinstalling but you would use basically the same method(s) to mount and access the partition to modify the file.
 
Old 03-16-2012, 09:51 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,102

Rep: Reputation: 982Reputation: 982Reputation: 982Reputation: 982Reputation: 982Reputation: 982Reputation: 982Reputation: 982
Except it's a wubi installation. No partition, just a loop mount I believe.
Never used it, but there used to be a wubi only thread on the ubuntu forums - here it is. It's mega - like 99 pages mega ...

(BTW yancek, you forgot to include the link).
 
Old 03-16-2012, 10:02 PM   #4
jefro
Guru
 
Registered: Mar 2008
Posts: 11,098

Rep: Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362Reputation: 1362
Wubi seems to be OK for some people.

It is a windows application that should correctly install grub and linux.

This grub should not be unusual. Not all keyboards work however. First thing I'd do is look at bios and see if there is any "legacy" usb or such like keyboard usb. This assumes you have a usb keyboard. Assumes standard keyboard.

If you have a PS/2 then kind of hard to say. It could be quite a number of issues. Bad cd, data or chipset or maybe odd keyboard.

Post specs of system. Tell us if you see normal keyboard lights. See if you can change state of numblock at boot.

If you boot to a live linux cd, does it work correctly. It should correctly.

You can boot to Windows and use programs to remove. All else fails consider a virtual machine or a standard dual boot. Remember the wubi was supposed to be a more safe way to run linux. A dual boot can cause some issues.
 
Old 04-11-2012, 03:11 AM   #5
webmanoffesto
LQ Newbie
 
Registered: May 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Now this is weird. I uninstalled WUBI (like uninstalling an app in Windows, and I used Revo Uninstaller. Then I installed WUBI using a newly downloaded Ubuntu distro (11.10). I rebooted, and I still can't select Ubuntu (in order to not boot into Windows 7).
 
Old 04-11-2012, 04:02 AM   #6
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 435

Rep: Reputation: Disabled
I thought wubi.exe made a few folders that aren't deleted after you remove the program. I could be wrong though as it's been a long time since I used wubi on an old computer.
 
Old 04-15-2012, 09:39 AM   #7
webmanoffesto
LQ Newbie
 
Registered: May 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Smile Problem Solved

Problem solved by using either an old keyboard with PS/2 connector, or by using new USB Keyboard with a PS/2 adapter plugged into the PS/2 jack.
 
Old 04-15-2012, 10:13 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,411
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
I wouldn't consider that a solution, rather a work-around. May I ask you for the manufacturer and model of your mainboard?
 
Old 04-16-2012, 02:36 AM   #9
webmanoffesto
LQ Newbie
 
Registered: May 2010
Posts: 10

Original Poster
Rep: Reputation: 0
SIW Portable says

ASRock ConRoe1333-D667 R2.0
http://www.asrock.com/mb/overview.as...33-D667%20R2.0
BIOS - 4Mb AMI BIOS
- AMI Legal BIOS
- Supports "Plug and Play"
- ACPI 1.1 Compliance Wake Up Events
- Supports Jumperfree
- SMBIOS 2.3.1 Support
 
Old 04-16-2012, 08:19 AM   #10
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,411
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
Try that:
- Attach your PS/2-keyboard, start the machine and go into the BIOS (F2-key)
- Press left to go to the "Advanced" page
- Go into the "USB Configuration" sub-menu
- Enable the option "Legacy USB support"
- Press F10 to save the settings and confirm the security question.

Now your USB keyboard should work.
 
1 members found this post helpful.
Old 04-17-2012, 07:37 AM   #11
webmanoffesto
LQ Newbie
 
Registered: May 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Smile It Worked! Thanks :-)

Quote:
Originally Posted by TobiSGD View Post
Try this:
- Attach your PS/2-keyboard, start the machine and go into the BIOS (F2-key)
- Press left to go to the "Advanced" page
- Go into the "USB Configuration" sub-menu
- Enable the option "Legacy USB support"
- Press F10 to save the settings and confirm the security question.
Now your USB keyboard should work.
That worked great. Thanks so much.
 
  


Reply

Tags
grub, ubuntu, windows, wubi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to access wubi installed ubuntu files from windows? roggggor Ubuntu 1 11-23-2011 07:39 AM
Need help connecting to internet through ubuntu 8.04 installed through Wubi girsdeciple Linux - Newbie 2 07-09-2009 05:39 PM
Wubi (ubuntu) installed with windows xp - how do i get rid of xp? jrjone General 8 06-03-2009 08:01 PM
Just installed Ubuntu with Wubi. Is linux right for me? PSBubcha Linux - Newbie 7 03-29-2009 03:09 AM
how to use ubuntu wubi installed system for new clean install waynenener Ubuntu 3 03-01-2009 12:55 AM


All times are GMT -5. The time now is 11:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration