LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-02-2014, 08:55 AM   #1
opus-outlaw
LQ Newbie
 
Registered: Jan 2008
Posts: 15

Rep: Reputation: 0
Wrong Time Displayed


Just finished installing SolydK-64. (based on Debian testing)
The displayed time is incorrect. (5 hrs. early)

The BIOS date and time are correct.

I used sudo dpkg-reconfigure tzdata, to reset time zone.

sandy@opus:~/Desktop$ date
Sat Feb 1 14:32:36 EST 2014
sandy@opus:~/Desktop$

I live in Montreal, Canada the local time when the date command was executed was: 19:32 ....


Thank you in advance for any advice / suggestions on how to correct this problem.

Tom
 
Old 02-02-2014, 09:15 AM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,999

Rep: Reputation: Disabled
Suggestion #1 would be that perhaps your Time Zone isn't configured correctly, but the "EST" seems to indicate that it is.

Suggestion #2 would be that your system is perhaps configured to interpret the hardware clock as being set to UTC. Not sure where the parameter controlling this can be found in Debian.

Suggestion #3 would be to check the kernel RTC_SYSTOHC and RTC_HCTOSYS configuration settings, as they only work if your hardware clock is set to UTC.
 
1 members found this post helpful.
Old 02-02-2014, 09:46 AM   #3
goumba
Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Wheezy (7.0), Jessie (future 8) and Sid (unstable)
Posts: 551
Blog Entries: 3

Rep: Reputation: 66
Quote:
Originally Posted by Ser Olmy View Post
Suggestion #1 would be that perhaps your Time Zone isn't configured correctly, but the "EST" seems to indicate that it is.

Suggestion #2 would be that your system is perhaps configured to interpret the hardware clock as being set to UTC. Not sure where the parameter controlling this can be found in Debian.

Suggestion #3 would be to check the kernel RTC_SYSTOHC and RTC_HCTOSYS configuration settings, as they only work if your hardware clock is set to UTC.
For #2:

In /etc/adjtime, you'll find the line "UTC" (should be by itself on a line). Change this to "LOCAL" and you should be set.
 
1 members found this post helpful.
Old 02-02-2014, 01:36 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 13,046

Rep: Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740Reputation: 1740
Are you dual booting with MS windows ???

if so your options are little to NONE

windows MUST have the clock on the Motherbord set to YOUR local time zone

linux likes to have it set to UT ( Greenwich mean time )

but there is an overide to use the MICROSOFT setting
-- there is no such overide on windows

so you HAVE to use the windows setting , if you are dual booting .
 
Old 02-02-2014, 01:48 PM   #5
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,999

Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
windows MUST have the clock on the Motherbord set to YOUR local time zone
No, if you set the registry dword value "RealTimeIsUniversal" to "1", Windows will treat the hardware clock as providing UTC time. This registry value can be found (or created if it isn't already there) under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation.
Quote:
Originally Posted by John VV View Post
linux likes to have it set to UT ( Greenwich mean time )
Some kernel settings do indeed assume the hardware clock is providing UTC (Coordinated Universal Time, which unlike GMT is not a time zone), but one can easily override this.
 
Old 02-02-2014, 05:45 PM   #6
opus-outlaw
LQ Newbie
 
Registered: Jan 2008
Posts: 15

Original Poster
Rep: Reputation: 0
First things first let me thank each of you for responses.

Next up I must apologize, I was mistaken and now believe my hardware clock (BIOS) is "defeactive".
(It seems to "lose" time rather quickley)

Found an interesting post here on how to use ntpdate to solve this problem.

Tom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk-3 non-sensitive radio buttons displayed wrong Rod3775 Linux - Software 0 12-28-2013 04:45 AM
Wrong time displayed on top bar dale_chip Linux - Newbie 1 02-24-2008 04:30 AM
... wrong displayed in browser timmy01 Linux - Software 4 10-27-2005 06:57 AM
idesk - icon in upper left corner displayed wrong titopoquito Linux - Software 0 06-19-2005 03:08 AM
time displayed KDE santiagosilva Linux - Newbie 3 02-20-2004 04:51 PM


All times are GMT -5. The time now is 06:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration