LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Window Manager Issues in Mint (http://www.linuxquestions.org/questions/linux-desktop-74/window-manager-issues-in-mint-4175468074/)

Robynsveil 07-01-2013 07:17 PM

Window Manager Issues in Mint
 
I am running Mint 64-bit 14 (nadia) Windows Manager: Mutter (Muffin) on an i3 (4 cores 540@3.06gHz), 16 GiB RAM, NVidia GTX 580 graphics, using the Cinnamon desktop.

This problem appeared recently. When I open certain programs -- like Google Earth but also VirtualBox -- the Cinnamon panel disappears and control icons on the app window disappear as well.
[CTRL][ALT][BackSpace] restores everything.

I have done a memory test which revealed nothing except that the installed memory is apparently sound: no errors.

I'm not at all certain where to even start looking. I've reset themes and icons and all that to default but the problem persists. Please let me know if there's information I need to provide to help diagnose this system.

Thanks in advance to all who stop and consider my little problem. :)

pressman57 07-01-2013 07:48 PM

You may take a look at /var/log/Xorg.whatever (I'm not on Mint). You might also create another user and see if the problems exists with him.

Robynsveil 07-01-2013 08:47 PM

Thank you Pressman. I did as you suggested, created a new user, and logged in as that user. I then brought up Google Earth with exactly the same behaviour: the panel disappeared.

Here is a copy of /var/log/Xorg.0.log... I hope it's okay that I post it in its entirety here:

Quote:

[ 7445.674]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[ 7445.674] X Protocol Version 11, Revision 0
[ 7445.674] Build Operating System: Linux 2.6.24-32-xen x86_64 Ubuntu
[ 7445.674] Current Operating System: Linux Robyns-Desktop 3.7.0-7-generic #15-Ubuntu SMP Sat Dec 15 16:34:25 UTC 2012 x86_64
[ 7445.674] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.7.0-7-generic root=UUID=6c34f653-4edc-4a56-956d-4729c5626c99 ro quiet splash
[ 7445.675] Build Date: 08 May 2013 02:37:22PM
[ 7445.675] xorg-server 2:1.13.4~git20130508+server-1.13-branch.10c42f57-0ubuntu0ricotz~quantal (For technical support please see http://www.ubuntu.com/support)
[ 7445.675] Current version of pixman: 0.28.2
[ 7445.675] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 7445.675] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 7445.675] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Jul 2 11:40:31 2013
[ 7445.675] (==) Using config file: "/etc/X11/xorg.conf"
[ 7445.675] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 7445.675] (==) ServerLayout "Default Layout"
[ 7445.675] (**) |-->Screen "Screen0" (0)
[ 7445.675] (**) | |-->Monitor "Monitor0"
[ 7445.676] (**) | |-->Device "Device0"
[ 7445.676] (**) |-->Input Device "Keyboard0"
[ 7445.676] (**) |-->Input Device "Mouse0"
[ 7445.676] (**) Option "Xinerama" "0"
[ 7445.676] (==) Automatically adding devices
[ 7445.676] (==) Automatically enabling devices
[ 7445.676] (==) Automatically adding GPU devices
[ 7445.676] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 7445.676] Entry deleted from font path.
[ 7445.676] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[ 7445.676] Entry deleted from font path.
[ 7445.676] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[ 7445.676] Entry deleted from font path.
[ 7445.676] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[ 7445.676] Entry deleted from font path.
[ 7445.676] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[ 7445.676] Entry deleted from font path.
[ 7445.676] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[ 7445.676] Entry deleted from font path.
[ 7445.676] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/Type1,
built-ins
[ 7445.676] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 7445.676] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 7445.676] (WW) Disabling Keyboard0
[ 7445.676] (WW) Disabling Mouse0
[ 7445.676] (II) Loader magic: 0x7f641e9a7d00
[ 7445.676] (II) Module ABI versions:
[ 7445.676] X.Org ANSI C Emulation: 0.4
[ 7445.676] X.Org Video Driver: 13.1
[ 7445.676] X.Org XInput driver : 18.0
[ 7445.676] X.Org Server Extension : 7.0
[ 7445.678] (--) PCI:*(0:1:0:0) 10de:1080:3842:1580 rev 161, Mem @ 0xf6000000/16777216, 0xe8000000/134217728, 0xf2000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x????????/524288
[ 7445.678] (II) Open ACPI successful (/var/run/acpid.socket)
[ 7445.678] Initializing built-in extension Generic Event Extension
[ 7445.678] Initializing built-in extension SHAPE
[ 7445.678] Initializing built-in extension MIT-SHM
[ 7445.678] Initializing built-in extension XInputExtension
[ 7445.678] Initializing built-in extension XTEST
[ 7445.678] Initializing built-in extension BIG-REQUESTS
[ 7445.678] Initializing built-in extension SYNC
[ 7445.678] Initializing built-in extension XKEYBOARD
[ 7445.678] Initializing built-in extension XC-MISC
[ 7445.678] Initializing built-in extension SECURITY
[ 7445.678] Initializing built-in extension XINERAMA
[ 7445.678] Initializing built-in extension XFIXES
[ 7445.678] Initializing built-in extension RENDER
[ 7445.678] Initializing built-in extension RANDR
[ 7445.678] Initializing built-in extension COMPOSITE
[ 7445.678] Initializing built-in extension DAMAGE
[ 7445.678] Initializing built-in extension MIT-SCREEN-SAVER
[ 7445.678] Initializing built-in extension DOUBLE-BUFFER
[ 7445.678] Initializing built-in extension RECORD
[ 7445.678] Initializing built-in extension DPMS
[ 7445.678] Initializing built-in extension X-Resource
[ 7445.678] Initializing built-in extension XVideo
[ 7445.678] Initializing built-in extension XVideo-MotionCompensation
[ 7445.678] Initializing built-in extension SELinux
[ 7445.678] Initializing built-in extension XFree86-VidModeExtension
[ 7445.678] Initializing built-in extension XFree86-DGA
[ 7445.678] Initializing built-in extension XFree86-DRI
[ 7445.678] Initializing built-in extension DRI2
[ 7445.678] (II) LoadModule: "glx"
[ 7445.679] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[ 7445.697] (II) Module glx: vendor="NVIDIA Corporation"
[ 7445.697] compiled for 4.0.2, module version = 1.0.0
[ 7445.697] Module class: X.Org Server Extension
[ 7445.697] (II) NVIDIA GLX Module 304.88 Wed Mar 27 14:46:57 PDT 2013
[ 7445.697] Loading extension GLX
[ 7445.697] (II) LoadModule: "nvidia"
[ 7445.697] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[ 7445.697] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 7445.697] compiled for 4.0.2, module version = 1.0.0
[ 7445.697] Module class: X.Org Video Driver
[ 7445.697] (II) NVIDIA dlloader X Driver 304.88 Wed Mar 27 14:28:14 PDT 2013
[ 7445.697] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 7445.697] (++) using VT number 7

[ 7445.702] (II) Loading sub module "fb"
[ 7445.702] (II) LoadModule: "fb"
[ 7445.702] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 7445.702] (II) Module fb: vendor="X.Org Foundation"
[ 7445.702] compiled for 1.13.4, module version = 1.0.0
[ 7445.702] ABI class: X.Org ANSI C Emulation, version 0.4
[ 7445.702] (II) Loading sub module "wfb"
[ 7445.702] (II) LoadModule: "wfb"
[ 7445.702] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 7445.702] (II) Module wfb: vendor="X.Org Foundation"
[ 7445.702] compiled for 1.13.4, module version = 1.0.0
[ 7445.702] ABI class: X.Org ANSI C Emulation, version 0.4
[ 7445.702] (II) Loading sub module "ramdac"
[ 7445.702] (II) LoadModule: "ramdac"
[ 7445.702] (II) Module "ramdac" already built-in
[ 7445.703] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 7445.703] (==) NVIDIA(0): RGB weight 888
[ 7445.703] (==) NVIDIA(0): Default visual is TrueColor
[ 7445.703] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 7445.703] (**) NVIDIA(0): Option "Stereo" "0"
[ 7445.703] (**) NVIDIA(0): Stereo disabled by request
[ 7445.703] (**) NVIDIA(0): Option "MetaModes" "1680x1050 +0+0"
[ 7445.703] (**) NVIDIA(0): Enabling 2D acceleration
[ 7446.035] (II) NVIDIA(GPU-0): Display (LG Electronics L226WTP (DFP-0)) does not support
[ 7446.035] (II) NVIDIA(GPU-0): NVIDIA 3D Vision stereo.
[ 7446.037] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 580 (GF110) at PCI:1:0:0 (GPU-0)
[ 7446.037] (--) NVIDIA(0): Memory: 1572864 kBytes
[ 7446.037] (--) NVIDIA(0): VideoBIOS: 70.10.20.00.80
[ 7446.037] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 7446.037] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[ 7446.039] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 580 at PCI:1:0:0
[ 7446.039] (--) NVIDIA(0): CRT-0
[ 7446.039] (--) NVIDIA(0): CRT-1
[ 7446.039] (--) NVIDIA(0): LG Electronics L226WTP (DFP-0) (connected)
[ 7446.039] (--) NVIDIA(0): DFP-1
[ 7446.039] (--) NVIDIA(0): DFP-2
[ 7446.039] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[ 7446.039] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
[ 7446.039] (--) NVIDIA(0): LG Electronics L226WTP (DFP-0): 330.0 MHz maximum pixel clock
[ 7446.039] (--) NVIDIA(0): LG Electronics L226WTP (DFP-0): Internal Dual Link TMDS
[ 7446.039] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[ 7446.039] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[ 7446.039] (--) NVIDIA(0): DFP-2: 330.0 MHz maximum pixel clock
[ 7446.039] (--) NVIDIA(0): DFP-2: Internal Single Link TMDS
[ 7446.039] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 7446.039] (**) NVIDIA(0): device LG Electronics L226WTP (DFP-0) (Using EDID
[ 7446.039] (**) NVIDIA(0): frequencies has been enabled on all display devices.)
[ 7446.040] (II) NVIDIA(0): Validated MetaModes:
[ 7446.040] (II) NVIDIA(0): "1680x1050+0+0"
[ 7446.040] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[ 7446.070] (--) NVIDIA(0): DPI set to (87, 83); computed from "UseEdidDpi" X config
[ 7446.070] (--) NVIDIA(0): option
[ 7446.070] (--) Depth 24 pixmap format is 32 bpp
[ 7446.070] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 7446.070] (II) NVIDIA: access.
[ 7446.077] (II) NVIDIA(0): Setting mode "1680x1050+0+0"
[ 7446.109] Loading extension NV-GLX
[ 7446.153] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 7446.153] (==) NVIDIA(0): Backing store disabled
[ 7446.153] (==) NVIDIA(0): Silken mouse enabled
[ 7446.153] (==) NVIDIA(0): DPMS enabled
[ 7446.153] Loading extension NV-CONTROL
[ 7446.153] Loading extension XINERAMA
[ 7446.153] (II) Loading sub module "dri2"
[ 7446.153] (II) LoadModule: "dri2"
[ 7446.153] (II) Module "dri2" already built-in
[ 7446.153] (II) NVIDIA(0): [DRI2] Setup complete
[ 7446.153] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 7446.153] (--) RandR disabled
[ 7446.156] (II) SELinux: Disabled on system
[ 7446.157] (II) Initializing extension GLX
[ 7446.166] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[ 7446.168] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[ 7446.168] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 7446.168] (II) LoadModule: "evdev"
[ 7446.168] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[ 7446.169] (II) Module evdev: vendor="X.Org Foundation"
[ 7446.169] compiled for 1.13.0, module version = 2.7.3
[ 7446.169] Module class: X.Org XInput Driver
[ 7446.169] ABI class: X.Org XInput driver, version 18.0
[ 7446.169] (II) Using input driver 'evdev' for 'Power Button'
[ 7446.169] (**) Power Button: always reports core events
[ 7446.169] (**) evdev: Power Button: Device: "/dev/input/event1"
[ 7446.169] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 7446.169] (--) evdev: Power Button: Found keys
[ 7446.169] (II) evdev: Power Button: Configuring as keyboard
[ 7446.169] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[ 7446.169] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 7446.169] (**) Option "xkb_rules" "evdev"
[ 7446.169] (**) Option "xkb_model" "pc105"
[ 7446.169] (**) Option "xkb_layout" "us"
[ 7446.169] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[ 7446.169] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 7446.169] (II) Using input driver 'evdev' for 'Power Button'
[ 7446.169] (**) Power Button: always reports core events
[ 7446.169] (**) evdev: Power Button: Device: "/dev/input/event0"
[ 7446.169] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 7446.169] (--) evdev: Power Button: Found keys
[ 7446.169] (II) evdev: Power Button: Configuring as keyboard
[ 7446.169] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0/event0"
[ 7446.169] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[ 7446.169] (**) Option "xkb_rules" "evdev"
[ 7446.169] (**) Option "xkb_model" "pc105"
[ 7446.169] (**) Option "xkb_layout" "us"
[ 7446.169] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=9 (/dev/input/event11)
[ 7446.169] (II) No input driver specified, ignoring this device.
[ 7446.169] (II) This device may have been added with another device file.
[ 7446.170] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event12)
[ 7446.170] (II) No input driver specified, ignoring this device.
[ 7446.170] (II) This device may have been added with another device file.
[ 7446.170] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event13)
[ 7446.170] (II) No input driver specified, ignoring this device.
[ 7446.170] (II) This device may have been added with another device file.
[ 7446.170] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event14)
[ 7446.170] (II) No input driver specified, ignoring this device.
[ 7446.170] (II) This device may have been added with another device file.
[ 7446.170] (II) config/udev: Adding input device HDA Intel MID Line Out (/dev/input/event10)
[ 7446.170] (II) No input driver specified, ignoring this device.
[ 7446.170] (II) This device may have been added with another device file.
[ 7446.170] (II) config/udev: Adding input device HDA Intel MID Line (/dev/input/event6)
[ 7446.170] (II) No input driver specified, ignoring this device.
[ 7446.170] (II) This device may have been added with another device file.
[ 7446.170] (II) config/udev: Adding input device HDA Intel MID Front Mic (/dev/input/event7)
[ 7446.170] (II) No input driver specified, ignoring this device.
[ 7446.170] (II) This device may have been added with another device file.
[ 7446.171] (II) config/udev: Adding input device HDA Intel MID Rear Mic (/dev/input/event8)
[ 7446.171] (II) No input driver specified, ignoring this device.
[ 7446.171] (II) This device may have been added with another device file.
[ 7446.171] (II) config/udev: Adding input device HDA Intel MID Front Headphone (/dev/input/event9)
[ 7446.171] (II) No input driver specified, ignoring this device.
[ 7446.171] (II) This device may have been added with another device file.
[ 7446.171] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/event3)
[ 7446.171] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev keyboard catchall"
[ 7446.171] (II) Using input driver 'evdev' for 'Microsoft Microsoft® Nano Transceiver v2.0'
[ 7446.171] (**) Microsoft Microsoft® Nano Transceiver v2.0: always reports core events
[ 7446.171] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Device: "/dev/input/event3"
[ 7446.171] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Vendor 0x45e Product 0x745
[ 7446.171] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found keys
[ 7446.171] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as keyboard
[ 7446.171] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input3/event3"
[ 7446.171] (II) XINPUT: Adding extended input device "Microsoft Microsoft® Nano Transceiver v2.0" (type: KEYBOARD, id 8)
[ 7446.171] (**) Option "xkb_rules" "evdev"
[ 7446.171] (**) Option "xkb_model" "pc105"
[ 7446.171] (**) Option "xkb_layout" "us"
[ 7446.171] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/event4)
[ 7446.171] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev pointer catchall"
[ 7446.171] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev keyboard catchall"
[ 7446.171] (II) Using input driver 'evdev' for 'Microsoft Microsoft® Nano Transceiver v2.0'
[ 7446.171] (**) Microsoft Microsoft® Nano Transceiver v2.0: always reports core events
[ 7446.171] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Device: "/dev/input/event4"
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Vendor 0x45e Product 0x745
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found 9 mouse buttons
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found scroll wheel(s)
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found relative axes
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found x and y relative axes
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found absolute axes
[ 7446.172] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Forcing absolute x/y axes to exist.
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found keys
[ 7446.172] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as mouse
[ 7446.172] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as keyboard
[ 7446.172] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Adding scrollwheel support
[ 7446.172] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: YAxisMapping: buttons 4 and 5
[ 7446.172] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 7446.172] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.1/input/input4/event4"
[ 7446.172] (II) XINPUT: Adding extended input device "Microsoft Microsoft® Nano Transceiver v2.0" (type: KEYBOARD, id 9)
[ 7446.172] (**) Option "xkb_rules" "evdev"
[ 7446.172] (**) Option "xkb_model" "pc105"
[ 7446.172] (**) Option "xkb_layout" "us"
[ 7446.172] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: initialized for relative axes.
[ 7446.172] (WW) evdev: Microsoft Microsoft® Nano Transceiver v2.0: ignoring absolute axes.
[ 7446.172] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) keeping acceleration scheme 1
[ 7446.172] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration profile 0
[ 7446.172] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration factor: 2.000
[ 7446.172] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration threshold: 4
[ 7446.172] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/mouse0)
[ 7446.172] (II) No input driver specified, ignoring this device.
[ 7446.172] (II) This device may have been added with another device file.
[ 7446.172] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/event5)
[ 7446.172] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev keyboard catchall"
[ 7446.172] (II) Using input driver 'evdev' for 'Microsoft Microsoft® Nano Transceiver v2.0'
[ 7446.172] (**) Microsoft Microsoft® Nano Transceiver v2.0: always reports core events
[ 7446.172] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Device: "/dev/input/event5"
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Vendor 0x45e Product 0x745
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found 1 mouse buttons
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found scroll wheel(s)
[ 7446.172] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found relative axes
[ 7446.173] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found absolute axes
[ 7446.173] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found absolute multitouch axes
[ 7446.173] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found x and y absolute axes
[ 7446.173] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found keys
[ 7446.173] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Forcing relative x/y axes to exist.
[ 7446.173] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as mouse
[ 7446.173] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as keyboard
[ 7446.173] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Adding scrollwheel support
[ 7446.173] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: YAxisMapping: buttons 4 and 5
[ 7446.173] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[ 7446.173] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.2/input/input5/event5"
[ 7446.173] (II) XINPUT: Adding extended input device "Microsoft Microsoft® Nano Transceiver v2.0" (type: KEYBOARD, id 10)
[ 7446.173] (**) Option "xkb_rules" "evdev"
[ 7446.173] (**) Option "xkb_model" "pc105"
[ 7446.173] (**) Option "xkb_layout" "us"
[ 7446.173] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: initialized for relative axes.
[ 7446.173] (WW) evdev: Microsoft Microsoft® Nano Transceiver v2.0: ignoring absolute axes.
[ 7446.173] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) keeping acceleration scheme 1
[ 7446.173] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration profile 0
[ 7446.173] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration factor: 2.000
[ 7446.173] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration threshold: 4
[ 7446.173] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/js0)
[ 7446.173] (II) No input driver specified, ignoring this device.
[ 7446.173] (II) This device may have been added with another device file.
[ 7446.173] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[ 7446.173] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 7446.173] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 7446.173] (**) AT Translated Set 2 keyboard: always reports core events
[ 7446.173] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[ 7446.173] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[ 7446.173] (--) evdev: AT Translated Set 2 keyboard: Found keys
[ 7446.173] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[ 7446.173] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input2/event2"
[ 7446.173] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[ 7446.173] (**) Option "xkb_rules" "evdev"
[ 7446.173] (**) Option "xkb_model" "pc105"
[ 7446.173] (**) Option "xkb_layout" "us"
[ 7459.504] (II) NVIDIA(GPU-0): Display (LG Electronics L226WTP (DFP-0)) does not support
[ 7459.504] (II) NVIDIA(GPU-0): NVIDIA 3D Vision stereo.
[ 7459.504] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 7459.504] (**) NVIDIA(0): device LG Electronics L226WTP (DFP-0) (Using EDID
[ 7459.504] (**) NVIDIA(0): frequencies has been enabled on all display devices.)
[ 7459.704] (II) NVIDIA(GPU-0): Display (LG Electronics L226WTP (DFP-0)) does not support
[ 7459.704] (II) NVIDIA(GPU-0): NVIDIA 3D Vision stereo.
[ 7459.705] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 7459.705] (**) NVIDIA(0): device LG Electronics L226WTP (DFP-0) (Using EDID
[ 7459.705] (**) NVIDIA(0): frequencies has been enabled on all display devices.)
[ 7460.591] (II) XKB: reuse xkmfile /var/lib/xkb/server-8AA988DD479FAABEC4FC3CCCF4CC29B4948840B4.xkm
[ 7460.644] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.257] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.260] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.263] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.265] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.268] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.271] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.273] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7462.276] (II) XKB: reuse xkmfile /var/lib/xkb/server-53628FFEAE787BDF7F5128B07068E2A1D9DEC814.xkm
[ 7480.520] (II) NVIDIA(GPU-0): Display (LG Electronics L226WTP (DFP-0)) does not support
[ 7480.520] (II) NVIDIA(GPU-0): NVIDIA 3D Vision stereo.
[ 7480.520] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 7480.520] (**) NVIDIA(0): device LG Electronics L226WTP (DFP-0) (Using EDID
[ 7480.520] (**) NVIDIA(0): frequencies has been enabled on all display devices.)
I have no idea what I should be looking for... I do notice some disquieting "No input driver specified, ignoring this device." statements, however.

pressman57 07-01-2013 09:47 PM

Sorry I can't be of more help. I don't see anything in your /Xorg.0.log really worrisome. I've got Mint LMDE with
cinnamon installed in a VM, so I installed Google Earth from the LMDE repos and it works fine; no disappearing panel etc. I did notice there's an update of Mutter. At least in LMDE.

Robynsveil 07-02-2013 06:50 AM

Thanks for trying, Pressman :) I'll look into updating Mutter - might need to bark up the graphics tree, perhaps.

Peter von Bertoldi 07-02-2013 09:07 AM

Same happens to me, in both, desktop and laptop, but not in the fresh install, after I add all the apps and goodies I use. Also if an app opens and closes fast a mmessage windows, it leaves in place a 'ghost' image of it, and have to Alt+f2 r to clean the screen.
My guess it has something to do with some Gnome app interfering with Cinnamon. BTW, I had the same problem with Nadia 64 Cinnamon.

Robynsveil 07-02-2013 05:55 PM

Thanks Peter... so it seems a not totally uncommon problem? Wonder if I should file a bug report with Mint? Not all programmes cause this to happen... just certain ones, like Google Earth. Blender, for example, does not. Bringing up the Cinnamon settings dialogue doesn't, but trying to navigate within this app to a file does.
My laptop and netbook both run Mint Nadia (64-bit and 32-bit, respectively) and neither have issues with this.

pressman57 07-02-2013 09:19 PM

Aren't both Google Earth and Vbox 32 bit apps? Perhaps it's a problem with 32-bit libs.

Peter von Bertoldi 07-03-2013 12:24 PM

Well, a bit more info: I've tried a few progs, having always running Krusader 2.4.0-b3, Firefox 22.0 and Great Little Radio Player 1.4.2 on my dual head desktop.
W/o problems:
Google Earth 7.1.1.1580
LibreOffice 4.0.4.2
Adobe Reader 9.5.5
Synaptic 0.8~exp2raring1
RStudio 0.97.551 and R 3.0.1
VirtualBox 4.2.12 r84980
And started systematically w/Accessories:
Archive Manager, Ark, Calculator, Character Map, ChmSee, Disks (run the SMART tests), Files, another Files, Font Viewer, Gourmet Recipe Manager, Metamorphose2, Main Menu, PDF Mod, Screenshot and Shutter.
Decided to install Hugin (2011.4.0.cf9be9344356) as I needed to make a panorama when it did it once and was able to recuperate, and a few minutes later did it again, and this time had to [CTRL][ALT][BackSpace].
Then tried again VirtualBox and this time it did it, and after a few seconds it recuperated, but the icons on the desktop where of larger size.
It might not be a bad idea to file a bug report. I also use a NVIDIA (Quadro FX 1500) with the NVIDIA driver ver 304.88

Robynsveil 07-03-2013 05:05 PM

Good work, Peter. :)

Given the fact that neither my laptop (NVidia GT 230M/PCIe/SSE2, running driver 3.3.0 NVidia 304.88) nor my netbook appear to have this problem despite running the same OS and version and all are updated at roughly the same time, I'm inclined to think this has something to do the graphics card, perhaps? Yours sounds like a newer, more powerful card. Mine: GeForce GTX 580/PCIe/SSE2 runs driver 4.2.0 NVidia 304.88.

So, testing LibreOffice 4.0... as soon I bring up the main LibreOffice launcher, the panel disappears. When I click on, say, Writer, bring it up then close it, the Writer window remains in the background, control mechanisms such as minimise and '[X] close' have disappeared but the menu is still visible. The behaviour is not consistent: say I bring up Calc... the panel disappears, then reappears under the application. I close Calc and open it again... the panel is still there and working.

I bring up Firefox - panel and controls are there and working - bring up Google Earth on top of this, the panel disappears, and when I close GE using the app menu (which has an odd OS/2 feel about it) the controls for Firefox have disappeared and the menu, whilst visible, does not work: nothing happens clicking on the menu options like 'File'.

In Firefox (new session created with [CTRL][ALT][Backspace]), File -> Open, as soon as the navigate dialogue appears, the panel and controls disappear. However, (new session), the same dialogue in Calc does not produce the same result: this time the panel and window controls are all there and working.

VLC Media Player loads fine but File -> Open removes the panel and window controls. However, the menu still works.

The System Settings widget (launched from the panel) works fine.

The Cinnamon Settings widget works fine.

Synaptic Package Manager works fine, including dialogues.

Terminal works fine.

GIMP 2.8 works fine.

Openshot 1.4.3 works fine.

OctaneRender Standalone 1.10 causes panel to vanish.

pressman57 07-03-2013 07:19 PM

Has anyone tried the Nouvuea (or even VESA) drivers to see if the problem persists? I'm running the 304.xx drivers in Arch with KDE and Gnome Shell with no problems whatsoever.

Peter von Bertoldi 07-04-2013 05:06 PM

Well gentlemen, I am already off in Toronto (soon to be promoted to grandpa), so till Mon or Tue will not be with my desktop, but if time allows will test the notebook (also Olivia 64 Cinnamon), the display is an Intel VGA compatible controller, but all the settings and software are the same. By default we can assume if it doesn't show the same behaviour the problem is with the video.
For example I was able to use Hugin w/o problem.
and GE shows:
Google Earth 7.1.1.1580 (beta)
Build Date 4/19/2013
Renderer OpenGL
Operating System Linux (3.8.0.0)
Video Driver Intel Open Source Technology Center
and no problem either.
More to follow ...

Robynsveil 07-04-2013 05:30 PM

Congratulations, Peter! :)

I'm of the same mind as you are, given the fact that this behaviour is only seen on my desktop, not my laptop or netbook. Obviously, the netbook wouldn't be subject to this if it *is* a graphics card / driver issue.

If this is indeed reproducible and a real issue, where would you suggest I bring it to the developer's attention? And which developer? Mint or NVidia?

Peter von Bertoldi 07-05-2013 08:06 AM

I would say Mint, they must have the link to send it upstream. Also before deciding to stay in Mint I've tried OpenSuse and Fedora 18, and they did not show this behaviour.
And thanks, is a boy!!!!

Knightron 07-05-2013 09:44 AM

It sounds to me like it's interfering with the cinnamon shell. Mutter is the Gnome window manager, Cinnamon uses Muffin; and Mutter being out of date shouldn't affect this issue.
I'm curious to know if anything strange occures when you open these apps under a different desktop environment.


All times are GMT -5. The time now is 09:35 AM.