LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 10-20-2008, 04:02 AM   #1
vpv
LQ Newbie
 
Registered: Sep 2005
Location: Bulgaria
Distribution: Debian GNU/Linux
Posts: 19

Rep: Reputation: 0
Window Maker and cyrillic keyboard layout


I am running Windowmaker on Debian 4.0. I would like to be able to switch my keyboard layout between English and Cyrillic cp1251. However I cannot find how to do this in the Windowmaker preferences. I also cannot find any tool for Windowmaker for switching between different keyboard layouts, such as for example the Keyboard Indicator for GNOME. Does anyone know how can I write in cyrillic in Windowmaker? Thanks for your help!
 
Old 10-20-2008, 07:12 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,974

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
If you want to switch between languages, you should edit /etc/X11/xorg.conf. Find the "Keyboard" section and add the following:
Code:
Option "XkbLayout"   "us,ru"
Option "XkbOptions"  "grp:ctrl_shift_toggle"
That means you can use the "Ctrl+Shift" keys to toggle languages.
Just make a backup of xorg.conf before editing it.

Regards
 
Old 10-20-2008, 06:04 PM   #3
vpv
LQ Newbie
 
Registered: Sep 2005
Location: Bulgaria
Distribution: Debian GNU/Linux
Posts: 19

Original Poster
Rep: Reputation: 0
it works!

Quote:
Originally Posted by bathory View Post
If you want to switch between languages, you should edit /etc/X11/xorg.conf. Find the "Keyboard" section and add the following:
Code:
Option "XkbLayout"   "us,ru"
Option "XkbOptions"  "grp:ctrl_shift_toggle"
That means you can use the "Ctrl+Shift" keys to toggle languages.
Just make a backup of xorg.conf before editing it.

Regards
Thank you very much for your reply! I added the above lines in my xorg.conf file and it works, BUT not for all applications. E.g.: in Firefox now i am able to write in cyrillic and to switch quickly between English and Bulgarian with "Ctrl+Shift" and this is already a big help. However when i try to write in cyrillic in a terminal emulator (Xterm, mrxvt) or in text editor such as Emacs, only squares or unreadable symbols are displayed. Do you have a clue how can i fix this?

Thanks for you help!
 
Old 10-21-2008, 05:04 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,974

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
For xterm and mrxvt I can help, but for Emacs I don't, since I don't use it. Anyway, to be able to write cyrillic in xterm, you can edit /path/to/X11/app-defaults/XTerm and use a cyrillic font. Or run xterm like this:
Code:
xterm  -fn "-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-koi8-r"
For mrxvt you can edit ~/.mrxvtrc and change "Mrxvt.font" accordingly.

Last edited by bathory; 10-22-2008 at 09:59 AM.
 
Old 10-22-2008, 08:27 AM   #5
vpv
LQ Newbie
 
Registered: Sep 2005
Location: Bulgaria
Distribution: Debian GNU/Linux
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
For xterm and mrxvt I can help, but for Emacs I don't since I don't use it. Anyway, to be able to write cyrilliv in xterm, you can edit /path/to/X11/app-defaults/XTerm and use a cyrillic font. Or run xterm like this:
Code:
xterm  -fn "-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-koi8-r"
For mrxvt you can edit ~/.mrxvtrc and change "Mrxvt.font" accordingly.
Thanks for your reply! It worked and I can write in cyrillic now in mrxvt and xterm too! Also i accidentally found that there is a Unicode version of xterm in which i can write in cyrillic even without passing the above -fn option. For the unicode xterm the xorg.conf file modification was enough.

Thanks for all your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to toggle between keyboard maps in console-cyrillic? bezdomny Linux - Software 2 08-03-2008 07:59 PM
Window Maker and keyboard autorepeat option w1k0 Slackware 0 05-28-2008 12:40 PM
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 07:43 PM
New To Window Maker sovietpower Slackware 3 12-19-2003 01:40 AM
x-window and keyboard layout linuxxx Linux - Software 0 10-12-2001 09:31 AM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration