LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 12-02-2006, 08:09 PM   #1
yearnjia
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Rep: Reputation: 0
Question Why I can't input chinese with scim


I have installed SCIM in Fedora CORE 5 and it looks good. I can switch input by CTRL-BARSPACE. But I cannot input chinese in all applications. I can see the charaters in SCIM bar, but when I finish inputing, or some english charaters like TZF;EaG leaving there. What's wrong?
 
Old 12-04-2006, 02:08 AM   #2
Kirmonkey
Member
 
Registered: Jan 2004
Location: UK
Distribution: Debian
Posts: 194

Rep: Reputation: 30
Do you have the appropriate Chinese fonts installed?

Can you input Chinese in a simple application like gedit or kwrite?
 
Old 12-04-2006, 06:30 AM   #3
yearnjia
LQ Newbie
 
Registered: Dec 2006
Posts: 2

Original Poster
Rep: Reputation: 0
No. I can't type chinese in every app. I think something wrong with a global setting
 
Old 12-04-2006, 07:13 AM   #4
Kirmonkey
Member
 
Registered: Jan 2004
Location: UK
Distribution: Debian
Posts: 194

Rep: Reputation: 30
Make sure the following packages are installed, you don't have your distribution indicated which makes helping a little more difficult, this infromation I have quoted below comes from www.ubuntuguide.org

Quote:
sudo apt-get install scim
sudo apt-get install scim-chinese
sudo apt-get install scim-config-socket
sudo apt-get install scim-gtk2-immodule
sudo apt-get install scim-tables-zh
wget -c http://easylinux.info/uploads/fireflysung-1.3.0.tar.gz
sudo tar zxvf fireflysung-1.3.0.tar.gz -C /usr/share/fonts/truetype/
sudo chown -R root:root /usr/share/fonts/truetype/fireflysung-1.3.0/
sudo fc-cache -f -v
This works on all Debian based systems though.
 
Old 01-29-2009, 05:15 PM   #5
youngfowl
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
Chinese Input - Guaranteed to work with Lenny (Debian 5.0)

Dear all,

After struggling to find the answer everywhere, I found it at this URL :

http://phpxref.org/docs/debian/ch09.en.html

1) RECONFIGURE the consoles to ensure US, for the other console types you will need to add it in later in /etc/scim/global
(skip to Step (5) if you are using non-US locale)


dpkg-reconfigure --priority=high console-data


dpkg-reconfigure --priority=high xserver-xorg


2) CHECK to see the locales on your account by typing in terminal
user@debian $ locale

3) INSTALL SCIM

- Install the Japanese input tool package scim-anthy with its recommended packages such as im-switch.

- Execute "im-switch -c" from user's shell and select "scim".

- Relogin to user's account.

- Verify setting by "im-switch -l".

- Setup input method and mode by right clicking GUI toolbar. (You can reduce menu choice of input method)

- Start SCIM input method by CTRL-SPACE

4) ENJOY !!!

5) USE THIS OPTION FOR NON-US LOCALE :

In order to start SCIM under the non-CJK and non-en_US locale, you need to add list of those locales in UTF-8 to the ~/.scim/global or /etc/scim/global file as:

/SupportedUnicodeLocales = en_US.UTF-8,en_GB.UTF_8,fr_FR.UTF-8
 
  


Reply

Tags
debian


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No idea what's going on (about chinese input using SCIM) MichaelYoung Debian 1 10-19-2006 07:54 AM
chinese input SCIM -d doesn't work xjchen001 Linux - Newbie 1 09-15-2005 09:14 PM
Chinese input using SCIM in OpenOffice satellite360 Linux - Software 4 05-17-2005 09:21 AM
SCIM chinese input works selectively (Mandrake 10) houshuang Linux - Software 50 05-10-2005 12:02 AM
how do i write chinese using scim? lemuel Linux - Newbie 10 02-24-2005 04:28 PM


All times are GMT -5. The time now is 11:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration