LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Why can no program write to my /home partition in Gnome? (Gentoo/amd64) (http://www.linuxquestions.org/questions/linux-desktop-74/why-can-no-program-write-to-my-home-partition-in-gnome-gentoo-amd64-722192/)

Itsamnaaj 04-28-2009 04:30 AM

Why can no program write to my /home partition in Gnome? (Gentoo/amd64)
 
Hello everyone, I have a tiny problem in Gnome 2.24 on Gentoo/amd64.

Not long ago I bought a 1 TB SATA hard drive. Being influenced by FreeBSD as I am, I partitioned it up into 7 partitions: /boot, swap, /, /var, /tmp, /usr and /home. However, upon switching to Gnome from Xfce I started noticing small problems in Gnome. Nautilus, and most other programs trying to access my /home folder, were blatantly ignoring my file permissions (which are set to 777). Neither logged in as user nor root could I change the file permissions in Nautilus. Here's what the Nautilus info window looks like:

http://img257.imageshack.us/img257/5...ermissions.png

Here's my /etc/fstab:

Code:

/dev/sda1                /boot                ext2                noauto,noatime        1 2
/dev/sda2                none                swap                sw        0 0
/dev/sda4                /                ext4                noatime        0 1
/dev/sda5                /var                ext4                noatime        0 0
/dev/sda6                /tmp                ext4                noatime        0 0
/dev/sda7                /usr                ext4                noatime        0 0
/dev/sda8                /home          ext4                noatime,users,rw,exec        1 2
/dev/scd0                /mnt/cdrom        auto                noauto,ro        0 0
shm                        /dev/shm        tmpfs          nodev,nosuid,noexec        0 0

All my /home permissions are rwxrwxrwx.

I have already tried all the humanly possible with octal permissions, /etc/fstab and GDM configuration (I set RelaxPermissions=2 in GDM's custom.conf). So my question is this: how do I enable every program to write to my /home partition?

Thanks in advance,

Itzamna

Itsamnaaj 04-29-2009 09:49 AM

Never mind, I solved it.

http://forum.winehq.org/viewtopic.php?p=23911#23911


All times are GMT -5. The time now is 08:56 AM.