LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-23-2013, 09:24 PM   #1
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 164

Rep: Reputation: 22
web browsers open mp3 files


I would like to be able to click on a link to a mp3 file in a web browser and select the option to either save the file or open it in the program of my choice. This has always been the expected behaviour until recently.

Now whenever I click on an mp3 file, the web browser opens it in an unidentified built-in media player.

Browsers - problem exists with firefox, chromium and opera.
Distro/Desktop Env - Have found this in OpenSuse 12.2 with Xfce and in Mint 12 with Mate

No plugins are enabled. All media players and browser plugins I could find have been uninstalled, except VLC player (not plugin) which is what I want to use to open the mp3. Browser preferences are ignored. Changing File manager preferences has no effect. I am unable to find any desktop settings which might change the problem.

Has anybody else found this a problem and fixed it?
 
Old 02-23-2013, 10:04 PM   #2
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,875

Rep: Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523Reputation: 1523
It's expected HTML5 behaviour. Your options are to either right-click instead of left-clicking on the MP3 file, or (possibly) look for an "addon" that will give you the behaviour you're used to.
 
Old 02-23-2013, 10:22 PM   #3
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 164

Original Poster
Rep: Reputation: 22
In Linux Mint I uninstalled libtotem0 (and dependencies) and gecko-mediaplayer to get the desired behaviour.

Still can't find a solution for firefox on OpenSuse
 
Old 02-23-2013, 10:23 PM   #4
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 164

Original Poster
Rep: Reputation: 22
Thanks dugan, I will see if I can find a suitable add-on
 
Old 02-27-2013, 03:08 AM   #5
fortran
Member
 
Registered: Nov 2011
Location: Cairo, Egypt
Distribution: CentOS, RHEL, Fedora
Posts: 300
Blog Entries: 2

Rep: Reputation: 50
For Firefox :
Edit -> Preferences -> Applications
mp3 -> set here save file in the dropdown.
It worked for me

If file starts playing in firefox, you can click on File -> save as,
it saves the mp3 file on your desired location.
.
 
Old 02-27-2013, 04:59 AM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,554

Rep: Reputation: 239Reputation: 239Reputation: 239
Edit -> Preferences -> Applications Icon

You have a handler for the media type. You can uninstall the handler or change the browser to behave your way. Or go old school and right mouse -> view source and wget the mp3 URL.
 
Old 02-27-2013, 06:56 AM   #7
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,569
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by Shadow_7 View Post
Edit -> Preferences -> Applications Icon

You have a handler for the media type. You can uninstall the handler or change the browser to behave your way. Or go old school and right mouse -> view source and wget the mp3 URL.
or terminal >
Code:
 exo-preferred-applications
 
Old 02-28-2013, 07:05 AM   #8
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 164

Original Poster
Rep: Reputation: 22
Browser preferences are ignored for mp3

Edit -> Preferences -> Applications mp3 ... Always ask ... Save File ... Open with VLC ....

Changes nothing. All ignored. MP3 are still opened in the mystery built in player.

exo-preferred-applications is not available as a terminal command

Right-click will require extensive user training - we have 100+ people using this system.
 
Old 02-28-2013, 08:49 PM   #9
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,087

Rep: Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533Reputation: 1533
In Opera, it's Preferences-->Advanced-->Downloads-->[Select File Type]->Edit, then select the desired application.

http://help.opera.com/Linux/9.52/en/downloads.html

I have used this to disable internal players and it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Web browsers cannot open the local web servers? shams Linux - Networking 4 08-24-2012 01:14 AM
web browsers try to open PHP files in gedit digital_citizen Linux - Newbie 2 07-06-2008 01:50 PM
LXer: Comparison Between Linux Web Browsers - Review of 5 Linux Browsers LXer Syndicated Linux News 0 05-17-2008 02:21 PM
XMMS fails to open some mp3 files, while opening some other mp3's ditch* Linux - Software 3 03-05-2005 04:35 AM
Jerky mouse when web browsers download web page stodge Linux - Software 1 07-08-2003 11:29 PM


All times are GMT -5. The time now is 05:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration