LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-02-2013, 11:38 PM   #1
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 164

Rep: Reputation: 22
want nemo file manager to ignore case


I can not find a preference for Nemo file manager to ignore case when listing files and folders

Current behaviour lists them as:

Alpha
Beta
aardvark
antelope
etc

I would like them listed as:

aardvark
Alpha
antelope
Beta
etc

Is this possible?
 
Old 08-03-2013, 03:02 AM   #2
Doc CPU
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 999

Rep: Reputation: 294Reputation: 294Reputation: 294
Hi there,

Quote:
Originally Posted by Greenfuse View Post
I can not find a preference for Nemo file manager to ignore case when listing files and folders

Current behaviour lists them as:

Alpha
Beta
aardvark
antelope
etc
that's exactly what I'd prefer, but usually the default is rather what you want:

Quote:
Originally Posted by Greenfuse View Post
I would like them listed as:

aardvark
Alpha
antelope
Beta
etc

Is this possible?
Yes. But I assume you won't find an appropriate setting in Nemo (which I only know by its name, nothing more). Instead, most applications (including file managers) consider the sort order as defined by the system locale. Your current sort order is probably LC_COLLATE="C".

If you want another sort order, you might edit the file /etc/profile and change the LC_COLLATE line, or add it if it isn't present yet. Set this variable to something you like, for example en_US.UTF-8 (assuming that locale exists on your system).

[X] Doc CPU
 
Old 08-03-2013, 07:24 AM   #3
Greenfuse
Member
 
Registered: Nov 2004
Distribution: gentoo, arch centos
Posts: 164

Original Poster
Rep: Reputation: 22
Changing LC_COLLATE in /etc/locale.conf did the trick. Thanks for a good answer Doc CPU.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] disable '--ignore-case' in 'sort' ta0kira Ubuntu 5 07-18-2011 09:29 AM
ignore case in if statement shell scripting saiteju Programming 2 02-27-2010 01:49 AM
LXer: Nemo Review: A New File Manager for Linux LXer Syndicated Linux News 0 04-24-2008 05:30 PM
LXer: Nemo file manager organizes around a calendar LXer Syndicated Linux News 0 12-10-2007 11:40 PM
Any arguement that can be used with 'ls' command to ignore case? davidas Linux - Newbie 5 02-26-2006 04:46 AM


All times are GMT -5. The time now is 08:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration