LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-18-2007, 08:08 PM   #1
szim90
Member
 
Registered: Nov 2006
Distribution: Debian Testing
Posts: 39

Rep: Reputation: 15
Volume Key bindings in Gnome


Hello.

When I first installed Debian (when Ubuntu dropped powerpc support a while ago), I noticed that when I changed the volume with the keyboard, the volume popup window that I had gotten used to from Ubuntu did not appear, even though the volume level changed. So, after some research, I found that by setting the the keys as shortcuts in the gnome keyboard shortcuts preference, I had my volume popup back, and volume control worked fine.

About a week ago, keyboard volume control stopped working correctly. If I hit volume up, the window would appear, and the level indicator might go up, but the balance was off. I opened gnome volume control and I noticed that when I pressed the volume up button, one volume slider went up a different amount than the other slider.

I also noticed that if I tried this while watching a movie, like in mplayer, one volume slider could even go down while pressing the up button.

However, if I unset the keys in gnome keyboard preferences, the keys still control the volume, and maintain the balance. Why would they work without Gnome, and why would letting them be controlled by Gnome cause the balance to go off?

I am running Debian testing on a ppc with the 2.6.18 kernel.

Thank you for any help with this problem,
Sean
 
Old 09-21-2007, 04:29 PM   #2
bestofmed
Member
 
Registered: Jul 2004
Location: Jemna, Tunisia
Posts: 46

Rep: Reputation: 15
check this

there's a very interesting doc that talks about multimedia keyboard keys in Linux. It has extensive information about configuring multimedia keys under different linux environments (including the X server itself). You can even control the amount of volume raising!
http://gentoo-wiki.com/HOWTO_Use_Multimedia_Keys
happy configuring !
 
Old 09-21-2007, 07:15 PM   #3
szim90
Member
 
Registered: Nov 2006
Distribution: Debian Testing
Posts: 39

Original Poster
Rep: Reputation: 15
Ok. I read through the page, and, after running find on my computer, I found that I didn't have any Xmodmap files anywhere on the system. So, I setup the keymaps and ran xmodmap as described in the article, but when I reset the keybindings in gnome (again, following the instructions in the article), I still had the same problem – the one channel moved more than the other channel (though, again, if I left gnome unset volume control still worked, but gnome was not aware of it). You mentioned you can control the amount the system raises the volume when you strike a key, and I saw a references to that in the article if you use the remoot script you can control how much alsa changes when you press a volume key. Is there a way to set that for gnome volume control? Also, if I don't have any modmap files on my system, how is it possible that the system volume (alsa) still changes when I press a volume key?

Thank you for your help,
Sean
 
Old 09-22-2007, 07:16 AM   #4
bestofmed
Member
 
Registered: Jul 2004
Location: Jemna, Tunisia
Posts: 46

Rep: Reputation: 15
alternative solution

There's an easy way to enable multimedia keys correctly including configuring them. Try using keyTouch (which I recommend) or LinEAK:

keyTouch
LinEAK

I hope that it will resolve all your problems.
 
Old 09-27-2007, 06:45 PM   #5
szim90
Member
 
Registered: Nov 2006
Distribution: Debian Testing
Posts: 39

Original Poster
Rep: Reputation: 15
Thank you for the information. I'm looking into both options.

I'm worried though that LinEAK or keyTouch will suffer the same conflict with the current volume controller that Gnome currently does. I was curious, on debian, do you know where the default media keyboard info is (the stuff Debian sets up when you install Debian) – if I wanted to disable the current keyboard volume control to prevent conflicts with LinEAK or keyTouch, how would I do that? I'm not sure what program is currently telling alsa that a specific keypress means volume up or down. Does alsa have its own keyboard control?

Thank you everyone for all of your help with this.

Regards,
Sean
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
key bindings TomalakBORG Linux - General 4 05-02-2005 09:27 AM
How do i make key bindings in GNOME? snwright Linux - Software 8 02-24-2004 09:11 PM
Key Bindings rmanocha Linux - Newbie 2 10-22-2003 09:05 PM
Bad key or directory name (gnome volume control) okasion Linux - Hardware 0 05-05-2003 06:12 PM
Key bindings in KDE 3.1 thebeardedladie Linux - Newbie 0 04-19-2003 04:15 AM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration