LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 07-11-2012, 06:05 PM   #1
Hidden Windshield
Member
 
Registered: Jul 2010
Distribution: Lubuntu Lucid Lynx
Posts: 62

Rep: Reputation: 26
Using IceWM with LXDE


I have a desktop with Lubuntu installed. I prefer to use focus-follows-mouse mode (which OpenBox supports), but I don't want to raise the window when I click the client area (which, as far as I can tell, OpenBox doesn't support).

So, fine, I see that IceWM does. So, I install the icewm package, edit "/etc/xdg/lxsession/Lubuntu/desktop.conf" and change "window_manager=openbox-lubuntu" to "window_manager=icewm", log out, and log back in. Hey, presto, I'm using IceWM with LXDE.

But, there are two major problems:
  1. There's an extra panel hidden behind the normal LXDE panel, with its own menu, task manager, notification area, etc. It was apparently put there by IceWM. I thought a window manager was just supposed to manage windows? Normally, I would just ignore it, but it's intercepting my shortcut keys.
  2. I can't actually get IceWM into focus-follows-mouse mode. Everything I've read says to put "ClickToFocus=0" and "RaiseOnClickClient=0" in "~/.icewm/preferences", but it ignores anything I put there. How do I get it to do the one thing I installed it to do?

Last edited by Hidden Windshield; 07-12-2012 at 01:57 PM. Reason: Forgot the desktop.conf part.
 
Old 07-11-2012, 07:53 PM   #2
ShadowCat8
Member
 
Registered: Nov 2004
Location: Arcadia, CA
Distribution: Gentoo, Arch, (RedHat4.x-9.x, FedoraCore 1.x-4.x, Debian Potato-Sarge, LFS 6.0, etc.)
Posts: 209

Rep: Reputation: 43
Greetings,

Well, I am running LXDE over Openbox on my system here, and I have that exact behavior without issue.

For me, I went to the Start button => Preferences => Openbox Configuration Manager => Mouse, and then on that tab, at the very top is the option to have the focus follow the mouse, and third checkbox below that one is the option "Raise windows when the mouse pointer moves over them". I have that unchecked and it works fine for me.

Do you still have Openbox installed or did you remove it when you loaded IceWM?

HTH. Let us know.
 
Old 07-12-2012, 01:49 PM   #3
Hidden Windshield
Member
 
Registered: Jul 2010
Distribution: Lubuntu Lucid Lynx
Posts: 62

Original Poster
Rep: Reputation: 26
Yes, I found all of that. My issue with OpenBox is not raise on mouse over, but raise on mouse click. I want to be able to interact with a window, both mouse and keyboard, without raising it to the top of the stack.
 
Old 07-13-2012, 03:33 PM   #4
ShadowCat8
Member
 
Registered: Nov 2004
Location: Arcadia, CA
Distribution: Gentoo, Arch, (RedHat4.x-9.x, FedoraCore 1.x-4.x, Debian Potato-Sarge, LFS 6.0, etc.)
Posts: 209

Rep: Reputation: 43
And, that's how it works for me... exactly.

I often *have* to work in certain windows without raising them to the top on my desktops. Especially when one of the windows is a remote session. In a remote session, I usually only need to watch the output of one terminal on the remote system, so I have that at the bottom as I work in other windows over it. Then, when I need to interact with the remote system, I just bring the mouse over the remote session window, it grabs focus on it's own, and I am able to type and move the remote mouse around without bringing the remote session window to the top. Of course, if I have to see the entire remote desktop after starting the session, I just click on the window and it brings it to the top.

My configuration on the 'Mouse' tab of the Openbox Configuration Manager is as follows:
Focusing Windows:
  • Checked - Focus windows when the mouse pointer moves over them
  • Unchecked - Move focus under the mouse when switching desktops
  • Unchecked - Move focus under the mouse when the mouse is not moving
  • Unchecked - Raise windows when the mouse pointer moves over them
  • Delay before focusing and raising windows: 200 ms
Titlebar:
  • Double click on the titlebar: Shades the window
  • Double click time: 200ms

HTH. Let us know.
 
Old 07-14-2012, 12:56 PM   #5
Hidden Windshield
Member
 
Registered: Jul 2010
Distribution: Lubuntu Lucid Lynx
Posts: 62

Original Poster
Rep: Reputation: 26
That's very interesting, because whenever I click a window in OpenBox, it raises the window to the top of the stack, period, even though I have the same setup you do. (Well, ok, I have "Double click on the titlebar: Maximizes the window" rather than shading it, but I somehow don't think that would have any effect.)

However, as I was playing around with this, I discovered "~/.config/openbox/lubuntu-rc.xml":

Code:
    <context name="Client">
      <mousebind button="Left" action="Press">
        <action name="Focus"/>
        <action name="Raise"/>
      </mousebind>
      <mousebind button="Middle" action="Press">
        <action name="Focus"/>
        <action name="Raise"/>
      </mousebind>
      <mousebind button="Right" action="Press">
        <action name="Focus"/>
        <action name="Raise"/>
      </mousebind>
    </context>
So, I wondered what would happen if I took out those "Raise" actions out of the XML. So I did, and sure enough, it worked. I have no idea how those got there, since I haven't edited that file since the system was installed, except through the OpenBox Configuration Manager.

Anyway, thanks for the help.
 
Old 01-02-2014, 01:46 PM   #6
pgraham
LQ Newbie
 
Registered: Jan 2014
Posts: 1

Rep: Reputation: Disabled
Thanks for this, it is exactly what I was looking for. Although I left the middle click binding so that I can raise a window with a middle click.
 
  


Reply

Tags
focus, icewm, lxde, windowmanager


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lubuntu- Wireless works fine in LXDE, but not icewm or openbox FunkyPenguin Linux - Newbie 7 01-17-2011 06:11 PM
Opensuse 11.2 lxde or PclinuxOs 2009.4 lxde damipereira Linux - Distributions 1 02-16-2010 02:51 AM
Any Icewm/Icewm-experimental experts here? linus72 Linux - General 3 01-18-2010 06:45 AM
Opinions on lightweight desktops: icewm, jwm, lxde, etc. walterbyrd Linux - Software 12 12-18-2009 06:41 PM
where is the startup script of icewm when there is no ~/.icewm frenchn00b Linux - General 2 08-14-2008 05:36 PM


All times are GMT -5. The time now is 03:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration