LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-30-2009, 08:26 PM   #1
mitchellray
Member
 
Registered: Feb 2009
Posts: 44

Rep: Reputation: 15
User Shutdown Works from XFCE but not from KDE - Slackware12.2


Hello,
My personal desktop is an AMDk-7. It is loaded with Slackware12.2 and Fedora10. Both o/s are functional, although I have a long way to go to get them running well enough to turn an unsuspecting user loose on 'em.


Ordinary users (myself) are able to shutdown w/poweroff from XFCE in Slackware12.2 but not from KDE. It does not require sudo as I still have not made any additions.
Also, when I boot Fedora10 on the same hdd, ordinary users can shutdown and poweroff from the KDE gui.
I would like any explanations and also wonder if there must be something broken in the KDE that came with Slackware12.2.

Thank you.
M
 
Old 03-31-2009, 04:32 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,134
Blog Entries: 52

Rep: Reputation: Disabled
Try adding yourself to the power group. Do this, as root:
Code:
usermod -a -G power yourusername
I think that should do it.
 
Old 03-31-2009, 05:46 AM   #3
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,807

Rep: Reputation: 234Reputation: 234Reputation: 234
It works for me. My user is in these groups:

users, lp, floppy, audio, video, cdrom, plugdev, scanner

Do you have any old KDE configuration files in your home directory?

Was this an upgrade or a fresh installation?
 
Old 03-31-2009, 11:27 AM   #4
mitchellray
Member
 
Registered: Feb 2009
Posts: 44

Original Poster
Rep: Reputation: 15
Not sure '-a' option

Hello brianL and rkelsen,
Thank you for the responses.

I get this output on input 'usermod -a -G power (myusername)'

'usermod: invalid option -- a' and I am not sure which operator? to replace it with.


I am running a fresh install of Slackware12.2 and also have a fresh install on the same drive of Fedora10.

edit:
I just checked using kuser, and myself and another user that is also unable to shutdown/poweroff are in the 'power' group.

Again, we are both able to shutdown/poweroff from XFCE gui, but not from KDE.
M

Last edited by mitchellray; 03-31-2009 at 11:41 AM. Reason: additional info
 
Old 03-31-2009, 12:07 PM   #5
rogan
Member
 
Registered: Aug 2004
Distribution: Slackware
Posts: 37

Rep: Reputation: 8
Lead...

Whoever may shutdown must also be able to run /sbin/shutdown
(that's what happens when you press that cute little button in the dialog)

Cheers
 
Old 04-01-2009, 01:07 PM   #6
mitchellray
Member
 
Registered: Feb 2009
Posts: 44

Original Poster
Rep: Reputation: 15
Permission appears to be there and XFCE gui allows

Hello rogan,
/sbin/shutdown -hP now
shutdown: you must be root to do that!

and
/sbin$ ls -l shutdown
-rwxr-xr-x 1 root root 16864 2008-04-02 19:40 shutdown*
Aren't these the appropriate permissions?

Again, XFCE gui in Slackware 12.2 allows the shutdown and poweroff by ordinary users.
KDE has the "session manager" which seems to suggest that a user could perform the command, but it does not seem to follow its own settings.

Interestingly, the apparently same version of KDE in Fedora10 on the same drive does allow the ordinary user shutdown/poweroff with no action taken to alter parameters (out of the box).
Thank you.
M
 
Old 04-01-2009, 02:48 PM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,134
Blog Entries: 52

Rep: Reputation: Disabled
Are you booting into the default run-level 3, or have you changed it to 4?
 
Old 04-02-2009, 12:09 PM   #8
mitchellray
Member
 
Registered: Feb 2009
Posts: 44

Original Poster
Rep: Reputation: 15
INIT: entering: runlevel 3

Hello brianL,
Near the end of the boot process, the output indicates that the system is entering runlevel 3.
(the above title may not be exactly as the output syntax prints)

Maybe I am recanting superfluous information, the system can be shut down and powered off from the XFCE gui, although there is some output complaining about User not being root. The process completes.

I think, and maybe I'm mistaken, that it should not matter which gui I am using; I should still be able to get the same action from the same command (using the same shell?).

M
 
Old 04-02-2009, 12:59 PM   #9
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,134
Blog Entries: 52

Rep: Reputation: Disabled
I've always edited /etc/inittab, and changed the default run level to 4 (to boot straight into KDE desktop). When you do that, you get the options to log out, restart, or shutdown, from the main menu. At level 3 I think you only get logout with KDE. Not sure whether it makes any difference from the shell or Konsole.
 
Old 04-03-2009, 09:33 PM   #10
mitchellray
Member
 
Registered: Feb 2009
Posts: 44

Original Poster
Rep: Reputation: 15
Change default to runlevel: 4

Hello brianL,
I edited inittab.
I changed default to runlevel: 4 and voila.

Now I boot directly to a login screen that gives choices of user (including root) as well as gui(s). Fantastic!
Thanks to all who input.
Mitchellray
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
camera works on kde, but not on xfce? ninja master Linux - Software 14 12-29-2008 01:32 PM
Cannot shutdown as user on kde debian Proszbje Debian 1 12-30-2007 05:27 PM
API for X that works with KDE XFCE etc. binarybob0001 Programming 9 11-18-2006 05:52 AM
How can I shutdown as a user from KDE? vasudevadas Slackware 7 12-21-2005 04:17 AM
xfce shutdown sethgeekx86 Slackware 2 04-22-2004 03:49 PM


All times are GMT -5. The time now is 09:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration