LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   User Shutdown Works from XFCE but not from KDE - Slackware12.2 (http://www.linuxquestions.org/questions/linux-desktop-74/user-shutdown-works-from-xfce-but-not-from-kde-slackware12-2-a-715621/)

mitchellray 03-30-2009 08:26 PM

User Shutdown Works from XFCE but not from KDE - Slackware12.2
 
Hello,
My personal desktop is an AMDk-7. It is loaded with Slackware12.2 and Fedora10. Both o/s are functional, although I have a long way to go to get them running well enough to turn an unsuspecting user loose on 'em.


Ordinary users (myself) are able to shutdown w/poweroff from XFCE in Slackware12.2 but not from KDE. It does not require sudo as I still have not made any additions.
Also, when I boot Fedora10 on the same hdd, ordinary users can shutdown and poweroff from the KDE gui.
I would like any explanations and also wonder if there must be something broken in the KDE that came with Slackware12.2.

Thank you.
M

brianL 03-31-2009 04:32 AM

Try adding yourself to the power group. Do this, as root:
Code:

usermod -a -G power yourusername
I think that should do it.

rkelsen 03-31-2009 05:46 AM

It works for me. My user is in these groups:

users, lp, floppy, audio, video, cdrom, plugdev, scanner

Do you have any old KDE configuration files in your home directory?

Was this an upgrade or a fresh installation?

mitchellray 03-31-2009 11:27 AM

Not sure '-a' option
 
Hello brianL and rkelsen,
Thank you for the responses.

I get this output on input 'usermod -a -G power (myusername)'

'usermod: invalid option -- a' and I am not sure which operator? to replace it with.


I am running a fresh install of Slackware12.2 and also have a fresh install on the same drive of Fedora10.

edit:
I just checked using kuser, and myself and another user that is also unable to shutdown/poweroff are in the 'power' group.

Again, we are both able to shutdown/poweroff from XFCE gui, but not from KDE.
M

rogan 03-31-2009 12:07 PM

Lead...
 
Whoever may shutdown must also be able to run /sbin/shutdown
(that's what happens when you press that cute little button in the dialog)

Cheers

mitchellray 04-01-2009 01:07 PM

Permission appears to be there and XFCE gui allows
 
Hello rogan,
/sbin/shutdown -hP now
shutdown: you must be root to do that!

and
/sbin$ ls -l shutdown
-rwxr-xr-x 1 root root 16864 2008-04-02 19:40 shutdown*
Aren't these the appropriate permissions?

Again, XFCE gui in Slackware 12.2 allows the shutdown and poweroff by ordinary users.
KDE has the "session manager" which seems to suggest that a user could perform the command, but it does not seem to follow its own settings.

Interestingly, the apparently same version of KDE in Fedora10 on the same drive does allow the ordinary user shutdown/poweroff with no action taken to alter parameters (out of the box).
Thank you.
M

brianL 04-01-2009 02:48 PM

Are you booting into the default run-level 3, or have you changed it to 4?

mitchellray 04-02-2009 12:09 PM

INIT: entering: runlevel 3
 
Hello brianL,
Near the end of the boot process, the output indicates that the system is entering runlevel 3.
(the above title may not be exactly as the output syntax prints)

Maybe I am recanting superfluous information, the system can be shut down and powered off from the XFCE gui, although there is some output complaining about User not being root. The process completes.

I think, and maybe I'm mistaken, that it should not matter which gui I am using; I should still be able to get the same action from the same command (using the same shell?).

M

brianL 04-02-2009 12:59 PM

I've always edited /etc/inittab, and changed the default run level to 4 (to boot straight into KDE desktop). When you do that, you get the options to log out, restart, or shutdown, from the main menu. At level 3 I think you only get logout with KDE. Not sure whether it makes any difference from the shell or Konsole.

mitchellray 04-03-2009 09:33 PM

Change default to runlevel: 4
 
Hello brianL,
I edited inittab.
I changed default to runlevel: 4 and voila.

Now I boot directly to a login screen that gives choices of user (including root) as well as gui(s). Fantastic!
Thanks to all who input.
Mitchellray


All times are GMT -5. The time now is 05:45 PM.