LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   updated openSuSE 11.4 to 12.1 - now refuses to boot runlevel3 - for starters (http://www.linuxquestions.org/questions/linux-desktop-74/updated-opensuse-11-4-to-12-1-now-refuses-to-boot-runlevel3-for-starters-925307/)

Lunar 01-23-2012 01:25 PM

updated openSuSE 11.4 to 12.1 - now refuses to boot runlevel3 - for starters
 
Hello,
I updated openSuSE 11.4 / KDE 4.6 to os 12.1 / KDE 4.7 and among the 100 or so problems is this one that is making me nuts.

I have set and verified that inittab is set to id:3:default, I've checked using YaST2 (as anyone knows, what you set in YaST config does NOT always really happen) and by everything I can find, my system should boot to runlevel 3 and NOT KDE Desktop (KDM / KWIN)

the system is an IBM ThinkCentre and Has always been a pain with the audio and video, but never the config files being ignored..

at boot, it hangs for 10 minutes (no exaggeration, 10 minutes) just after it sets up eth0, IP address 10.5.0.193 which I specify. It does the same thing using DHCP, that is why I assigned, thinking it was waiting on the server because I changed and maybe messed up the wait time..

I've not sat there the whole 10 mins so I don't know what happens, but 10 mins latter, when I go back, KDE is up, ever time.

Any ideas?
I can give you any info you need; messages, inittab rc.x,, what ever.

Thank you in advance,
Landis.

LionsMane 01-23-2012 03:20 PM

To get the default run level to actually stay at 3, I had to open the YaST module for editing runlevel, go into expert mode, and explicitly check flip the runlevel to something other than three and then back to three. Once I save the changes, the next boot was fine.

I am still unclear what is the flag / signifier that controls the default runlevel. I seems the inittab is not the controlling file in the 3.x kernel.

I am not user about the 10 minute lag as I haven't seen anything like that. But I understand that the boot process can be multithreaded in the newer boot structure. Unlike the early 2.6, where the symlinks for init.d had an S and digits to specify execution order, the 3.0 init.d files need dependency values is the files themselves to determine which order to run services.

Good luck!

-Don

---------- Post added 01-23-12 at 04:21 PM ----------

To get the default run level to actually stay at 3, I had to open the YaST module for editing runlevel, go into expert mode, and explicitly check flip the runlevel to something other than three and then back to three. Once I save the changes, the next boot was fine.

I am still unclear what is the flag / signifier that controls the default runlevel. I seems the inittab is not the controlling file in the 3.x kernel.

I am not user about the 10 minute lag as I haven't seen anything like that. But I understand that the boot process can be multithreaded in the newer boot structure. Unlike the early 2.6, where the symlinks for init.d had an S and digits to specify execution order, the 3.0 init.d files need dependency values is the files themselves to determine which order to run services.

Good luck!

-Don


All times are GMT -5. The time now is 08:55 PM.