Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 07-11-2008, 03:22 PM   #1
LQ Newbie
Registered: Jun 2008
Posts: 15

Rep: Reputation: 0
Unable to connect to NetApp SAN using RHEL 4 and software iSCSI Initiator

I have a NetApp FAS960 filer that I'm using as an iSCSI SAN. I have six RHEL 4 Enterprise Server machines that are successfully connecting to it and one that is not. I'm using unique initiator names. The SAN is on a private network so I'm not using CHAP authentication or multipathing. I'm using the same iscsi.conf file in all hosts. I'm seeing the following error in my logs when I try to connect:

"Jul 11 10:04:59 lemay kernel: scsi: unknown device type 31"

This machine is configured exactly the same as all the other hosts. I'm at wits end. Any suggestions would help. Thanks.
Old 07-11-2008, 03:25 PM   #2
LQ Newbie
Registered: Jun 2008
Posts: 15

Original Poster
Rep: Reputation: 0

This belongs under the Linux-Server section. I must have mis-clicked.
Old 07-11-2008, 03:26 PM   #3
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
Check your hardware; swap the same cable with the other working machines first and test all hardware before you continue.
Old 07-11-2008, 03:28 PM   #4
LQ Newbie
Registered: Jun 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Did all of that. I can ping the SAN from the host and vise-versa.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
iSCSI initiator gives problems after relogging initiator service devkpict Linux - Software 0 06-27-2008 08:24 AM
OpenSuse - iSCSI Initiator ultradj83 Linux - Networking 0 03-29-2008 06:11 AM
iscsi connection error every 10 seconds (netapp) Fernando F. Linux - Server 0 10-15-2007 10:17 AM
CentOS 4.4 iscsi-initiator IanDMac Linux - Software 0 01-01-2007 02:04 PM
iSCSI Initiator? robby2 Linux - Software 1 08-31-2004 07:41 AM

All times are GMT -5. The time now is 03:56 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration