LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 10-22-2006, 10:07 PM   #1
BigFoot13
Member
 
Registered: Sep 2006
Location: ~/
Distribution: Kubuntu 8.04 Hardy
Posts: 115

Rep: Reputation: 15
Tweaks to improve performance in KDE


I was wondering if there were any tweaks to improve the performance in KDE. Some programs take long to open. I really don't mind the time it takes to log on since I don't log out often, but programs like OpenOffice and FireFox take awhile to load. My hard disk is rather slow, but the light is not on or flickering, so that is not it. The CPU is under some load, but not that much, and I have decent RAM. Here are my specs:

Mobile AMD Sempron 3000+
1 GB DDR400 RAM
80 GB IDE hard disk

Full specs here

Thanks
 
Old 10-23-2006, 01:05 AM   #2
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Does Kubuntu support prelinking?? I have read it speeds things up a bit.

Second thing, I would put Gentoo on that puppy. Gentoo is the fastest distro I have ever seen. Once you get the flags set up, everything is custom for your rig and speed is a lot better.

My $0.02 worth.

 
Old 10-23-2006, 01:34 AM   #3
mipia
Member
 
Registered: May 2003
Location: lake michigan
Distribution: Debian, Mint, Slackware
Posts: 457

Rep: Reputation: 35
Huh, I have an Athlon XP 2600 and Ubuntu with Gnome absolutely flies... odd.
Didn't know there would be that much difference between a Sempron and an Athlon. Wierd. If its taking long to load apps I really doubt its because of KDE. With one Gig of RAM there should be no problem there. It might be the applications that you are using. I used Openoffice once and never touched it again. I stick with Abiword and the like. The time it takes the data to get from your hard drive to your RAM is what is doing it. Slow hard drive? Might be the culprit.
I assume you are using the K7 kernel instead of the default i386 correct?

Last edited by mipia; 10-23-2006 at 01:36 AM.
 
Old 10-23-2006, 03:40 PM   #4
BigFoot13
Member
 
Registered: Sep 2006
Location: ~/
Distribution: Kubuntu 8.04 Hardy
Posts: 115

Original Poster
Rep: Reputation: 15
I am using the i386 version. The Sempron is a K8 (socket 754 with 1600 MHz FSB) chip, its pretty good. For the most part, it is much faster than Windows, and alomst all applications are up on the desktop in no time at all. For some reason though, Firefox/Thunderbird and OpenOffice take awhile to load, as well as adept, though this is reasonable.

My hard drive is rather slow (4200 RPM with 8 MB cache), but Kubuntu takes advantage of my RAM a lot better than Windows, it uses about 850 MB of RAM normally. The hard disk usually doesn't get used much except when I install programs.

I downloaded a program called PowerTweak, but when I run it in the konsole, I get this:
Code:
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
Error creating socket to : /var/run/powertweakd Connection refused
MSR driver not loaded.

Last edited by BigFoot13; 10-23-2006 at 03:58 PM.
 
Old 10-23-2006, 08:38 PM   #5
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
What you need is a faster drive. Sounds like CPU and memory are fine but that 4200 rpm drive is going to kill you bigtime. Even the fast ones is slow.

I have never heard of PowerTweak. I'm not sure how it would help with the bottleneck you have right now.

Do you have hdparm installed? It may help some.

 
Old 10-23-2006, 08:47 PM   #6
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Re: KDE

Ahh, being a Gentoo user I would say to remove those KDE components that are not being used.

I am not sure if modular KDE is available easily for other distributions.

I run KDE, Firefox, Thunderbird, and OpenOffice ... without delay.



Compaq Evo N600c
Mobile PIII 1GHz
512MB Ram
 
Old 10-24-2006, 10:03 AM   #7
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
Quote:
Originally Posted by BigFoot13
I am using the i386 version. The Sempron is a K8 (socket 754 with 1600 MHz FSB) chip, its pretty good. For the most part, it is much faster than Windows, and alomst all applications are up on the desktop in no time at all. For some reason though, Firefox/Thunderbird and OpenOffice take awhile to load, as well as adept, though this is reasonable.
Those take a long time to load regardless. On my SuSE workstation firefox takes a bit of time to load, and my SuSE box isn't much different from your box:

AMD Athlon 64 3000+ 2.0GHz 1666 MHz FSB
512 MB DDR400 SD-RAM
74 GB WD Raptor 10,000 RPM SATA150 HDD
nVidia GeForce 6800 AGP 8x 512MB GDDR2

I would highly reccommend a faster hard drive. Better yet: get two smaller hard drives (about fifty gigs each) and RAID 0 them together. Two 7200RPM drives in RAID0 would be about 1/4 faster than my Raptor.

If you have the cash, I'd even suggest considering RAID 0+1, which would require four disks. That's mirror them and strip them, so you'd have the same speed, and you'd have the added bonus that if one drive fails the other drives are backups, so you can continue working and get a replacement drive, with no data lost and no expensive data recovery.

Search www.computergeeks.com if you want to know the first place I look for cheap drives.

IIRC the way you RAID things in linux is with LVM. Good luck!
 
Old 10-24-2006, 01:52 PM   #8
BigFoot13
Member
 
Registered: Sep 2006
Location: ~/
Distribution: Kubuntu 8.04 Hardy
Posts: 115

Original Poster
Rep: Reputation: 15
This is a laptop, RAID is not supported. I don't think my hard disk is the problem. In Windows, it was on a lot when I opened programs, but Lunix seems to utilize my RAM much better. It loads a lot more things onto the RAM, and when I open these programs, my disk light only flickers a little bit, and I don't hear the disk ticking.
 
Old 10-24-2006, 03:27 PM   #9
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
Oh, a laptop. I was sort of off-handedly wondering where you could dig up a 4200 RPM desktop hard drive...

Yeah, I know of no cure for the slow laptop hard drive. My X40 is the same speed of drive, and the only thing that cures it is by switching to the smaller, more nimble Gentoo distro. But Gentoo isn't for everyone, so I won't be so assumptive as to suggest it to you.
 
Old 10-25-2006, 02:08 PM   #10
BigFoot13
Member
 
Registered: Sep 2006
Location: ~/
Distribution: Kubuntu 8.04 Hardy
Posts: 115

Original Poster
Rep: Reputation: 15
Would the K7 Kernel help? Should I install that instead of using the 386?
 
Old 10-25-2006, 03:43 PM   #11
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
Depends on the CPU type.

k7 = Athlon/AthlonXP
k7-smp = Dual-CPU/dual core k7
k8 = Athlon64/Sempron/Athlon64FX/Opteron64
k8-smp = Dual-core/X2 k8

I forget the mappings for the Intel chips.
 
Old 10-26-2006, 04:20 PM   #12
BigFoot13
Member
 
Registered: Sep 2006
Location: ~/
Distribution: Kubuntu 8.04 Hardy
Posts: 115

Original Poster
Rep: Reputation: 15
Then I should go for the K8. How would I switch to that?
 
Old 10-26-2006, 05:19 PM   #13
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
apt-get install linux-2.6.x-rx-ubuntu-k8 or whatever.

It's an installable option. Then:

1) In terminal:
o Go to /boot/ (cd /boot)
o ls - you should see your current kernel, and then the new one. Copy the output into a text file or something.
o Go to /boot/grub
o Edit menu.lst (nano is my fav. editor for this)
o Make a new kernel entry modeled after your current one. Replace the old kernel files and stuff with the corresponding new ones. It's hard to explain without a example in front of me, but that's how it's done.
o Make the new kernel the default and reboot.

If it doesn't work you'll have to reset the computer and boot the old kernel and tweak until it works.

HTH/YMMV
 
Old 10-27-2006, 01:31 PM   #14
BigFoot13
Member
 
Registered: Sep 2006
Location: ~/
Distribution: Kubuntu 8.04 Hardy
Posts: 115

Original Poster
Rep: Reputation: 15
I get this error when trying to install the K8 kernel
Code:
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package linux-2.6.x-rx-ubuntu-k8
 
Old 10-27-2006, 05:17 PM   #15
gruntwerk
Member
 
Registered: Dec 2003
Location: PA
Distribution: fc9
Posts: 89

Rep: Reputation: 15
re:firefox, maybe its ipv6 causing problems?

to turn off the IPv6 in firefox
type about:config in the address bar and hit Enter
type ipv6 in the filter box and hit enter
right-click and toggle to true
restart Firefox
try to connect

if this speeds things up then you know its an ipv6 problem and you should turn off ipv6..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tweaks to improve streaming audio quality? mediocre Slackware 4 08-18-2006 01:02 PM
Performance Tweaks Forum dh2k LQ Suggestions & Feedback 2 05-12-2006 08:20 AM
Samba performance tweaks linuxmandrake Linux - Networking 1 10-17-2005 06:37 PM
Performance tweaks Cinder Debian 3 03-26-2004 05:49 AM
Kernel tweaks/patches to improve responsiveness? sb73542 Linux - General 3 08-26-2003 02:47 PM


All times are GMT -5. The time now is 10:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration