LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 07-07-2008, 08:40 PM   #1
Slick666
Member
 
Registered: Feb 2006
Distribution: Ubuntu 8.04; Debian Etch
Posts: 167

Rep: Reputation: 33
Turning off Screen Blanking


What I'm trying to do is exactly whats stated in the title. I've searched and found lot of information both here and in the forums but nothing I have tried seems to work.

What I'm trying to do is find the commands to turn on and off the screen blanking. I plan on using them in a script that I call to play DVD's so that when I'm using the machine I have the screen blanking and screensaver like a normal desktop but when I pop in a dvd and play it the screen blanking will turn off.

The distro I'm using kubuntu 8.04 with KDE 3.5 but I think this would apply to many KDE based desktops. What I have tried is

* Turning off the screensaver in KDE
* "xset -dpms"
* "xset s off"

What I've research so far these should do it bu alas it has not worked.

Is there something I'm missing? Does anyone have any ideas or is there a better approach than the one I'm taking?
 
Old 07-08-2008, 02:53 AM   #2
Stéphane Ascoët
Member
 
Registered: Feb 2004
Location: Orleans, 120 km south of Paris
Distribution: Mandrake, Freeduc (the one I'm making), Slackware, MacOS X
Posts: 115

Rep: Reputation: 20
Post

http://community.ofset.org/index.php..._how_to#Screen
 
Old 07-08-2008, 09:50 AM   #3
FirstBorn
Member
 
Registered: Jul 2008
Location: Hell - aka - Florida
Distribution: Too bad they don't have a distro called Prozaklinux - I use Mandy ... (Mandriva 2008.1)
Posts: 64

Rep: Reputation: 15
Something misunderstood in instructions

Quote:
Originally Posted by Stéphane Ascoët View Post
Hi Stephane,

Thanks for that link.

This part is generating errors:
Code:
by the name of the script file you've created. Then

update-rc.d nameofthescriptwithoutpath defaults 19<pre> replacing <pre>nameofthescriptwithoutpath
The file was named "powersave" and saved into the /etc/init.d directory.

The command I typed in (as su, of course) was:
Code:
update-rc.d powersave defaults
... and generated the following error:
Code:
update-rc.d powersave defaults
I've also attempted their code (using 19 after defaults)

Any idea of how to get this done right.

I think that they have errors in the instructions.

Thanks,
Christopher
 
Old 07-08-2008, 09:58 AM   #4
Stéphane Ascoët
Member
 
Registered: Feb 2004
Location: Orleans, 120 km south of Paris
Distribution: Mandrake, Freeduc (the one I'm making), Slackware, MacOS X
Posts: 115

Rep: Reputation: 20
Question

Quote:
Originally Posted by FirstBorn View Post
Hi Stephane,

Thanks for that link.
Look if there is a console-tools config file somewhere. There should be a place inside to set the powersave function.
 
Old 07-08-2008, 10:14 AM   #5
FirstBorn
Member
 
Registered: Jul 2008
Location: Hell - aka - Florida
Distribution: Too bad they don't have a distro called Prozaklinux - I use Mandy ... (Mandriva 2008.1)
Posts: 64

Rep: Reputation: 15
Tried That

Quote:
Originally Posted by Stéphane Ascoët View Post
Look if there is a console-tools config file somewhere. There should be a place inside to set the powersave function.
Hi Stephane,

I've gone into "Configure KDesktop" and
"Mandriva Control Center" to disable
ANY Powersave Option to no avail.

Am I missing something?
Any Ideas?

Thanks,
Christopher

Last edited by FirstBorn; 07-08-2008 at 10:16 AM. Reason: Reworded Text
 
Old 07-08-2008, 10:30 AM   #6
Stéphane Ascoët
Member
 
Registered: Feb 2004
Location: Orleans, 120 km south of Paris
Distribution: Mandrake, Freeduc (the one I'm making), Slackware, MacOS X
Posts: 115

Rep: Reputation: 20
Red face

Quote:
Originally Posted by FirstBorn View Post
I've gone into "Configure KDesktop" and
"Mandriva Control Center" to disable
How can you launch Mandriva CC if you're under kUbuntu?

Quote:
Am I missing something?
Any Ideas?
Yeah, graphical tools suck. You should have a /etc/console-tools/config file where you can set powersave options.
 
Old 07-08-2008, 10:46 AM   #7
FirstBorn
Member
 
Registered: Jul 2008
Location: Hell - aka - Florida
Distribution: Too bad they don't have a distro called Prozaklinux - I use Mandy ... (Mandriva 2008.1)
Posts: 64

Rep: Reputation: 15
I'm not the OP

Quote:
Originally Posted by Stéphane Ascoët View Post
How can you launch Mandriva CC if you're under kUbuntu?


Yeah, graphical tools suck. You should have a /etc/console-tools/config file where you can set powersave options.
Hi Stephane,

I'm not the original poster of this Q.

I was going to post a Q until I see that someone here already did.

I'm using Mandriva 2008.0.

Is there anything in Mandriva that I can use to fix this same issue
as the Original Poster of this thread?

Thanks,
Christopher
 
Old 07-08-2008, 10:59 AM   #8
Stéphane Ascoët
Member
 
Registered: Feb 2004
Location: Orleans, 120 km south of Paris
Distribution: Mandrake, Freeduc (the one I'm making), Slackware, MacOS X
Posts: 115

Rep: Reputation: 20
Exclamation

Quote:
Originally Posted by FirstBorn View Post
Hi Stephane,

I'm not the original poster of this Q.
Oh, excuse me! I've never succeeded doing such settings with Mandriva. This why I don't like this distribution: like m$, they choose for us how thing should go.
 
Old 07-08-2008, 11:32 AM   #9
lurko
Member
 
Registered: Jun 2006
Location: Ontario, Canada
Distribution: Debian
Posts: 448

Rep: Reputation: 35
If you use MPlayer you might want to look at its options for disabling screensavers:
Quote:
Originally Posted by mplayer manpage
-stop-xscreensaver
Turns off xscreensaver at startup and turns it on again on exit.

---

-heartbeat-cmd
Command that is executed every 30 seconds during playback via system() - i.e. using the shell.

NOTE: MPlayer uses this command without any checking, it is your responsibility to ensure it does not cause security problems (e.g. make sure to use full paths if "." is in your path like on Windows).

This can be "misused" to disable screensavers that do not support the proper X API for this. If you think this is too complicated ask the author of the screensaver program to support the proper X APIs for this.

EXAMPLE for xscreensaver: mplayer -heartbeat-cmd "xscreensaver-command -deactivate" file

EXAMPLE for gnome screensaver: mplayer -heartbeat-cmd "gnome-screensaver-command -p" file
xdotool might be good app to have the heartbeat command run, you could set it to hit a key not bound to any functions of mplayer, or to move the mouse 1 pixel to the side(I think, I've not used it for faking mouse input) every 9.5 min (if the cursor's already over the edge it should probably remain unseen).
 
Old 07-08-2008, 05:22 PM   #10
FirstBorn
Member
 
Registered: Jul 2008
Location: Hell - aka - Florida
Distribution: Too bad they don't have a distro called Prozaklinux - I use Mandy ... (Mandriva 2008.1)
Posts: 64

Rep: Reputation: 15
Answer is: Configure kPowersave

Quote:
Originally Posted by Stéphane Ascoët View Post
Oh, excuse me! I've never succeeded doing such settings with Mandriva. This why I don't like this distribution: like m$, they choose for us how thing should go.
Hi Stephane,

k, found the answer.
Have to go to "Configure kPowersave" and
Tick or Check the box next to:
"Enable specific screensaver settings"
Then, Tick or Check next to "Disable screen saver"
Then, Tick or Check next to "Enable specific display power management"
Then, Tick or Check next to "Disable display power management"
Click "OK"
Problem Solved!

Just a Heads UP and FYI.

Thanks,
Christopher
 
Old 07-09-2008, 08:37 AM   #11
lurko
Member
 
Registered: Jun 2006
Location: Ontario, Canada
Distribution: Debian
Posts: 448

Rep: Reputation: 35
Quote:
Originally Posted by myself View Post
xdotool ...snip...
Actually xdotool might be a good way to accomplish this all by itself. If you have a loop in your script that has xdotool hit an unbound key every 9.5 mins then the screen will probably never blank.

I had similar trouble disabling blanking (again) on my TV after a recent xorg update. I use a separate Xserver for tvout though, so this probably doesn't apply to Slick666's issue, but for what it's worth, in the ServerLayout section defining my TV's setup, I have these options:
Code:
        Option          "BlankTime" "0"
        Option          "StandbyTime" "0"
        Option          "SuspendTime" "0"
        Option          "OffTime" "0"
Nothing else I tried would make any difference. I'd tried everything you had, "xset -dpms" "xset s off" "xset s 0 0" and something you haven't (though I don't suspect this applies to your situation), "X -dpms". Starting X (the second Xserver) with -dpms did the trick when this issue popped up for me months ago, but with a recent xorg update I started to get the blanking after 10 mins again. Adding those options to the ServerLayout was the only thing I could find that made any difference. Not really a solution for single displays though.
 
Old 07-12-2008, 04:15 PM   #12
geesh
Member
 
Registered: Feb 2004
Posts: 47

Rep: Reputation: 15
What worked for me on debian or mepis 7 was to go to /etc/x11 and in the TWO configs (xorg.conf) and (xorg.conf.in) disable or change from true to false all instances of DPMS in any monitor lines.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Blanking b0mb3r Slackware 6 03-16-2005 03:39 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
screen blanking rekonrad Linux - General 2 09-07-2003 08:23 PM
RH 9.0 screen blanking corrupter Linux - Distributions 0 06-04-2003 10:11 AM
Screen Blanking/non-X ldieter Linux - General 0 03-11-2002 10:05 PM


All times are GMT -5. The time now is 01:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration