Visit the LQ Articles and Editorials section
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 06-11-2010, 09:43 AM   #1
LQ Newbie
Registered: Oct 2009
Posts: 5

Rep: Reputation: 0
trying to ./configure GLib. returns error ***Working zlib and headers not found *** u

trying to ./configure GLib; returns error:*** Working zlib and headers not found*** Unable to find a zlib download. Please direct - gtw

many thanks knudfl!

ran sudo apt-get install zlib1g-dev returned

E: Couldn't find package zliblg-dev

Please re-direct - gtw

ran item 1 again, the return is below:

Package zlib1-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package zlib1-dev has no installation candidate

still trying to run Canon MP560
cannot see thanks tag

Got your prompt!
Cannot see where to continue the thread; so I used edit!
As you can see above I am no further forward

Last edited by gtwaby; 06-19-2010 at 09:27 AM. Reason: unable to advance!
Old 06-11-2010, 11:26 AM   #2
LQ 5k Club
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2015, Slack14.1 DebJessie, + 50+ other Linux OS, for test only.
Posts: 15,636

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991
Welcome to LQ. .. ..

Installing a new 'glib' will trash parts of Gnome etc.

1) Missing zlib ( development files ) : sudo apt-get install zlib1g-dev
( The main zlib ( run time files ) is already installed.)

2) I don't think you will need a new 'glib'.
It is installed by default. Install the missing glib parts:

sudo apt-get install libglib2.0-dev

Suggest : Make a list with the installed packages ..
dpkg --get-selections > selections.txt


Last edited by knudfl; 06-11-2010 at 11:33 AM.
1 members found this post helpful.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
zlib not found when running ./configure quordandis Linux - Software 9 11-28-2010 07:51 AM
configure: error: Qt (>= Qt 3.0.2) (headers and libraries) not found Sargalus Linux - Software 20 02-23-2010 12:40 AM
no matching comp found: client zlib none, lost connection jorge_ivan Linux - Networking 0 08-14-2006 07:09 PM
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found M$ISBS Linux - Software 11 07-12-2006 09:07 PM
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found Guitarist88 Linux - Newbie 2 08-13-2004 12:15 PM

All times are GMT -5. The time now is 04:20 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration