LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-15-2007, 06:26 PM   #1
athens101
LQ Newbie
 
Registered: Aug 2004
Posts: 26

Rep: Reputation: 15
Tovid .30 ffmpeg video = arse?


Ok, I just installed the new Tovid and noted that is was using ffmpeg for video encoding. Cool since it's faster but even with the --quality set to 9 or 10 it looks like arse. Pixels abound etc etc... Even on my SDTV

I went back to .28 and grated it's slower but now the DVD output looks like DVD not a telesync KVCD. Am I doing something wrong here?
 
Old 02-16-2007, 02:05 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
The format for ffmpeg's bitrate argument seems to have changed recently, because I was having similar problem the other day when using ffmpeg standalone.

Even though I was entering the bitrate command as I usually did, such as "-b 700", the final file instead had the default bitrate (200k for mpeg1), and the shell output as it was encoding would show the bitrate as zero! But I finally figured it out with some Googling and a careful reading of the man file. It turns out that the -b option is now being read as bits per second, instead of kilobits, and since the bitrate I gave was now too low for the format, it instead was falling back to the default. Changing the command to "-b 700k" fixed it.

I don't know exactly when this behavior changed, but it must be pretty new. The Tovid wiki changelog shows that versions from 0.29 up support the "k" suffix. So perhaps your trouble is kind of the reverse of mine. If you're using an older version of ffmpeg that's still expects the old style, then Tovid 0.30 would be handing it a bitrate option it can't recognize, forcing it to fall back to the default. So make sure you're using the newest versions of both ffmpeg and Tovid.

Last edited by David the H.; 02-16-2007 at 02:15 PM.
 
  


Reply

Tags
encoding, ffmpeg, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg: Could not find video grab device drhind Linux - Desktop 0 01-15-2007 06:13 PM
h.264 Matroska video choppy under ffmpeg? mrchaos Linux - Software 0 12-28-2005 02:27 AM
splitting video files with ffmpeg triXlife Linux - Software 0 12-27-2005 07:29 PM
i want to sync my video using ffmpeg Jeon, Chang-Min Linux - Software 0 11-17-2005 03:04 PM
tovid DVD/VCD video converter GUI wapcaplet LinuxQuestions.org Member Success Stories 2 07-06-2004 02:27 PM


All times are GMT -5. The time now is 09:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration