LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 12-24-2009, 11:42 AM   #1
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: Arch / Mint 17
Posts: 297
Blog Entries: 3

Rep: Reputation: 50
Title-bars disappear when desktop effects are enabled.


Hello,

I have a problem, my install works fine, but when I enable desktop effects from the "appearance" menu, the title bars on all my windows disappear. My graphics card is the Nvidia GeeForce 4 and I'm using the proprietary drives. Attached is my xorg.conf.

Thanks,
Bratmon
Attached Files
File Type: txt xorg.conf.txt (3.3 KB, 2 views)
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 12-24-2009, 03:42 PM   #2
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

I'm not sure exactly what distro and/or "desktop effects" manager you have, but this page has some excellent troubleshooting tips for Compiz:

http://wiki.compiz.org/Troubleshooting

For example:
Quote:
No Window Borders

When you start Compiz, your window borders disappear and you can no longer see each window's title, or minimize/maximize/close buttons. There are many potential causes for this very common problem, and is usually indicative of a Compiz or X server misconfiguration, or a misunderstanding of how Compiz is supposed to work.

Is a Window Decorator Running?

Check whether a window decorator is running. Enter the following command into a console window to find out:
Quote:
ps ax | egrep '(decorator|emerald)'
If you don't see any commands starting with "emerald", "gtk-window-decorator", or "kde-window-decorator", then no window decorator is running. Try starting Emerald with the following command:
Quote:
emerald --replace
'Hope that helps .. PSM
 
2 members found this post helpful.
Old 12-24-2009, 04:55 PM   #3
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: Arch / Mint 17
Posts: 297
Blog Entries: 3

Original Poster
Rep: Reputation: 50
My distro is Ubuntu 9.10, as told by the sidebar and the effects are Ubuntu's "hide the branding". I'm traveling right now, I'll post again when I get home.

Last edited by Bratmon; 12-28-2009 at 08:49 PM.
 
Old 12-24-2009, 05:09 PM   #4
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
In Fedora, turning on 'desktop effects' causes Metacity to be replaced with Compiz Fusion.

Not sure if it's the same in Ubuntu, but I would think so.
 
Old 12-28-2009, 09:09 PM   #5
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: Arch / Mint 17
Posts: 297
Blog Entries: 3

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by paulsm4 View Post
Hi -

I'm not sure exactly what distro and/or "desktop effects" manager you have, but this page has some excellent troubleshooting tips for Compiz:

http://wiki.compiz.org/Troubleshooting

For example:


'Hope that helps .. PSM
Thanks, it turns out the problem was with my nvida card. It works fine now.
 
Old 06-18-2010, 08:56 PM   #6
mitchd123
LQ Newbie
 
Registered: Jan 2009
Distribution: Ubuntu 14.04
Posts: 17

Rep: Reputation: 0
Thanks for posting this response Paulsm4

I had lost my titlebar so there was no way to maximize minimize or close

I was unable to open a terminal windows. All that would appear was a white square

It turned out the my Nvidia card was set at a DefaultDepth 16 rather than DefaultDepth 24 in my /etc/X11/xorg.conf

THANK YOU!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop effects could not be enabled scarypajamas Linux - General 3 06-28-2009 07:09 PM
Desktop effects could not be enabled chango77745 Linux - Newbie 5 05-11-2008 01:05 PM
Desktop effects could not be enabled???? ziggy92 Linux - Software 3 05-05-2008 10:41 PM
desktop effects cannot be enabled av.dubey Linux - Newbie 10 01-21-2008 05:04 PM
Menu bars (on top and bottom of desktop) disappear in Ubuntu 7.10 Olahh Ubuntu 1 11-06-2007 12:23 PM


All times are GMT -5. The time now is 04:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration