LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 04-17-2013, 02:40 PM   #1
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 189

Rep: Reputation: Disabled
Time keeping problem is ir software or hardware?


What keeps changing my desktop clock 12 hr time to 24 hr time and losing correct time in the hardware clock?
When the desktop time changes I check BIOS clock and notice that it can either be the same or different.
I'm using Mint14Cinnamon. I set desktop to non network and close Date &Time settings. I work with programs on the computer a while and go back to Date&Time settings and Network setting is checked. This can happen also when shutting down and re booting.
I've reset CMOS by removing battery and 20 minutes later replace the battery with new one said to be good until 2015.
I just got this board back from a second RMA for previous two boards having same/similar problems.
Is Mint broken? Is motherboard in need of a 3rd RMA? Should I go back to Windoze?
Use to be an Ubuntu user until they flaked it out with Unity. It seems Mint is doing th same with it's desktop options.
Bring back the desktop used in Ubuntu 10.04 and 10.10 please...
I swear since Ubuntu 10.04 Linux has gone the way of Windoze. Thanx if you can help!!!%)SW
This is a year old build: TA75M/A4-3300/8gbKingstonPC3HyperX1333/Seagate1tb/LGcd/dvd drive/ Antec Basiq430w.
 
Old 04-17-2013, 03:23 PM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,041

Rep: Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761
Desktop clock changes? No clue -- that should be in your desktop settings somewhere or other.

Time changes? Clue. Download (if not already there), install and configure NTP (Network Time Protocol). If I'm not not mistaken, "South Central Moontana" is in Australia? When you configure /etc/ntp.conf, add entries of this form in the in the server area:
Code:
server	127.127.1.0	# local clock
fudge	127.127.1.0 stratum 10	
#server  pool.ntp.org
server  0.au.pool.ntp.org
server  1.au.pool.ntp.org
server  2.au.pool.ntp.org
In the above, the local clock lines should be there -- they're there so if no external time source is available NTP will sync to itself until one becomes available. I checked, those entries are "live."

If, for some reason there are no pool servers available to you at your location using the above notation, you may -- may! -- wish to do the following (but probably not):

There are 27 NTP public time servers listed for Australia at http://support.ntp.org/bin/view/Serv...alia&scope=all, ping them, you're looking for three that are electrically close to you (the shortest time), add the addresses of those three to your /etc/ntp.conf file. You do not need more than three; if one is not available, NTP will automatically drop to the next.

Use the pool servers if at all possible.

Don't know diddly about your distribution, but do know that NTP is available from their software download site and it would be worth your time (get it?) to install, configure and use it -- it keeps your software clock and hardware clock on time.

Hope this helps some.
 
Old 04-17-2013, 07:49 PM   #3
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 189

Original Poster
Rep: Reputation: Disabled
Talking Desktop clock changes? No clue

Thanx tronayne, I'm a bit command line challenged due to dementia [I need prompting to get going and stay on track] but I did use synaptic to get NTP from repositories and installed it. Wonder why Mint didn't include it installed?
I don't remember having to do this with Ubuntu 10&11...
Now I've gotta find NTP in the menus and see if I can manipulate the settings to suit me.
BTW Moontana is my joke expression for Montana in the USofA. I'm actually in the Billings area---biggest city in state at about 100,000 blokes/lads/lassies/people.
I really ought to put more in my profile aye?!? Too much dementia and too little time!!!
I appreciate the help tronayne!!! %)SW
 
Old 04-17-2013, 10:30 PM   #4
jACK-ah
LQ Newbie
 
Registered: Feb 2013
Posts: 27

Rep: Reputation: Disabled
Bro I think the sell I not sure but I thinnk that coul be the problem the cell inside you cpu Its round type cell is gone week insert a new one and set the time again
 
Old 04-17-2013, 11:58 PM   #5
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 189

Original Poster
Rep: Reputation: Disabled
Thanx for the reply. I'm sure I mentioned that I replaced the battery after leaving it out for 20-30 minutes so CMOS would reset and I'd have better power for the sys clock.
 
Old 04-18-2013, 06:41 AM   #6
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,041

Rep: Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761Reputation: 761
Well, OK, Montana, USA (had a cataract op Monday, not seeing too clearly with both eyes yet --other one gets fixed the 29th -- but, boy! that new lens sure is bright).

So, you want to use three US pool servers:
Code:
server	127.127.1.0	# local clock
fudge	127.127.1.0 stratum 10	
#server  pool.ntp.org
server  0.us.pool.ntp.org
server  1.us.pool.ntp.org
server  2.us.pool.ntp.org
Thing is, the two clocks are not "connected;" the hardware clock sets the software clock when you boot and runs in the kernel with interrupts. Using NTP, the software clock is kept accurate and the hardware is nudged into the correct time periodically so that eventually it's more or less accurate (neither one is ever going to be like your $30 wristwatch, corrections need to be applied, NTP does that for you).

Winders does that by default (Windows users are not expected to know how the pick their noses, let alone fiddle with computer clocks and the like), many Linux distributions install and enable NTP, some do, some don't and it's left to you to turn it on -- you've got one of those.

Can't hurt, will help.
 
Old 04-18-2013, 12:42 PM   #7
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 804

Rep: Reputation: 157Reputation: 157
1sweetwater!, depending on kernel settings, your system clock may be set from the hardware clock during boot up, and the hardware clock set from the system clock during shutdown. Some distributions may have other controls for syncing the clocks. You can issue the following (as root) to see if your hardware clock and your system clock are out of sync.

Code:
hwclock ; date
The first output will be the hardware clock date and time and the second is the system clock date and time, both displayed in local time, even if your hardware clock is set to UTC. They should be identical or very close, within a second.

If they aren't, then you can set the system clock using ntpd with the -q option and then set the hardware clock from the system clock. Do this as root.

Code:
ntpd -q && hwclock --systohc
Now if you are running the ntpd service full time, your system clock should stay correct, and you should check to be sure that the hardware clock is being set from the system clock during shutdown.
 
Old 04-20-2013, 05:08 AM   #8
1sweetwater!
Member
 
Registered: Nov 2011
Location: South Central Montana USA
Distribution: Debian derivitives switched to Mint from Ubuntu but play with them all time and brain permitting...
Posts: 189

Original Poster
Rep: Reputation: Disabled
Time keeping problem is it software or hardware?

Well, decided to remove Mint Cinnamon; it was either not inclined to let me do things via menus or had a corrupt install. Replaced it with Mint Mate and it was easier to work with and I think I have the time thing solved. Desktop has been reporting correct for a day or so.
If not I'll be back!!!%)SW















i
 
  


Reply

Tags
cinnamon, clock, cmos


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get hardware AND software OpenGL rendering at the same time? robjoski Linux - Software 2 04-01-2009 09:08 PM
clock not keeping time leupi Linux - Software 10 03-22-2006 01:32 AM
Sound Card problem(every time i install linux i have diffirent hardware problem) jacka1l Linux - Newbie 7 08-11-2005 06:10 AM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration