LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Thunar keybindings - help me like this file manager (http://www.linuxquestions.org/questions/linux-desktop-74/thunar-keybindings-help-me-like-this-file-manager-4175454277/)

JWJones 03-16-2013 12:46 AM

Thunar keybindings - help me like this file manager
 
I've pretty much moved my default DE to Xfce on all machines, and I'm liking it more and more. But I need to know how to configure Thunar to make use of the "page forward" and "page back" keys on the Thinkpad (rather than using alt-left arrow, alt-right arrow). This works by default in both Nautilus and PCManFM, and Dolphin can be easily configured to do so.

I have searched the forum, and the web, and cannot seem to find a way to do this. On my Debian box, I simply swapped out Thunar for PCManFM, but I really just want to find a solution for this using Thunar.

dru8274 03-16-2013 04:10 PM

I had the same problem with thunar too, but it is fixed for now.

Thunar uses the gtk2 library, so it should be easy enough to change hotkeys using the standard method. From the archwiki
Quote:

Enabling Customizable Keyboard Shortcuts

You can customize your GTK+ applications' keyboard shortcuts (those are called accelerators in GTK+ terminology) by hovering your mouse over a menu item and pressing your desired key combination.
However, this feature is disabled by default. So to enable it, your ~/.gtkrc-2.0 or ~/.gtkrc-2.0.mine files should contain this line
Code:

gtk-can-change-accels=1
At this point, I was able to change my hotkeys using the above method. But then for some unknown reason, they would always change back to default sometime later. So to effect a more permanent change in my hotkeys, I looked at the ~/.config/Thunar/accels.scm file. By default it looks like this
Code:

$ head -6 ~/.config/Thunar/accels.scm
; Thunar GtkAccelMap rc-file        -*- scheme -*-
; this file is an automated accelerator map dump
;
; (gtk_accel_path "<Actions>/ThunarLauncher/sendto-desktop" "")
; (gtk_accel_path "<Actions>/ThunarStandardView/create-folder" "<Primary><Shift>n")
; (gtk_accel_path "<Actions>/ThunarWindow/view-side-pane-menu" "")

All the lines are preceded with a semi-colon, so they are comment lines that do nothing. So to add my hotkeys, I added some uncommented lines
Code:

(gtk_accel_path "<Actions>/ThunarWindow/back" "<Primary>Left")
(gtk_accel_path "<Actions>/ThunarWindow/open-parent" "<Primary>Up")

which in my case equate to setting the hotkey for Go-->Back to Ctrl-Left, and Go-->Parent to Ctrl-Up. For that file, <Primary> equates to the ctrl key, and <Alt> is the alt-key.

And after all that, my two hotkey changes were permanent. So perhaps you can follow my method and do the same. I am still using thunar-1.2.3, whereas the latest version is 1.6 or greater. So depending on the version, your results may vary.

Happy with ur solution... then tick "yes" and mark as Solved!

JWJones 03-16-2013 05:08 PM

Ah, OK, I did try:

gtk-can-change-accels=1

On a live DVD session, and then hovering/changing keybinding, but it didn't work, perhaps because it was a live session. I will have to try this on my Debian and/or Slackware Xfce boxes when I return to work on Monday (running LMDE Cinnamon on the Thinkpad right now).

Thanks!

Edit: The whole point of this was to get this working on the Thinkpad, not on a desktop machine, which doesn't have the "page forward" and "page back" keys! Duh, me! OK, gonna try this now.

JWJones 03-16-2013 05:47 PM

OK, I got this to work in a live session! Now I can transition the Thinkpad to Xfce. Thanks again!


All times are GMT -5. The time now is 05:30 PM.