LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-27-2009, 04:45 AM   #1
huntly001
LQ Newbie
 
Registered: Aug 2009
Distribution: debian (stable at the moment)
Posts: 3

Rep: Reputation: 0
Question The volume increments using alsa are impractical!


g'day
i've got a problem using alsa (v1.0.16); the volume change increments are pretty useless on my dell e6400 running debian stable.

specifically, the lower 80% of the sliders produce no (noticable) change in volume; i.e. silence, while the last 20% yeilds (close to) 100% of the change in volume making it hard to control and achieve a good listening level.

i doubt it's the soundcard, as windoze has volume sliders that's easy to control.

is there a way i can adjust the effect the sliders have on volume output to produce a more even spread of change?

thanks in advance!
 
Old 08-27-2009, 05:29 AM   #2
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
adjust different settings for the output. I always use alsamixergui because I think it's neater...but you should see what your pcm/wave/master are all set too. There are different sliders I'm guessing that control the sound outside of your master volume, which if they are set odd can cause the master to adjust differently. Just a thought though.
 
Old 08-27-2009, 06:31 AM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,364

Rep: Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895
Rather than use a gui, I find it best to stick with the CLI alsamixer.

On my box I find it best to set all the sliders (MASTER/PCM/WAVE/TONE if you have them) around 70%. Any higher than that results in distortion, and any less results in sound that's way too quiet. Even at 70% it's already too quiet but going higher destroys the quality. Interestingly, sound under MS Windows can go much louder without the distortion, as did OSS/Free back in the pre-ALSA days.

When I reinstall the next release of Slackware I'm going to try adding OSS back in to it. If that doesn't provide reasonable results then I might have to consider jumping ship. One of the *BSDs maybe or god forbid, Windows 7. You can say what you like about Vista, but the sound mixer produces very reasonable results and the individual slider per application is a great feature.

I've been putting up with the low volume sound on linux for a few years now and sadly, I've come to the conclusion that sound on Linux, and especially ALSA is a big ball of suck that doesn't show any signs of getting much better anytime soon.
 
Old 08-27-2009, 07:05 AM   #4
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
Quote:
Originally Posted by GazL View Post
Rather than use a gui, I find it best to stick with the CLI alsamixer.

On my box I find it best to set all the sliders (MASTER/PCM/WAVE/TONE if you have them) around 70%. Any higher than that results in distortion, and any less results in sound that's way too quiet. Even at 70% it's already too quiet but going higher destroys the quality. Interestingly, sound under MS Windows can go much louder without the distortion, as did OSS/Free back in the pre-ALSA days.

When I reinstall the next release of Slackware I'm going to try adding OSS back in to it. If that doesn't provide reasonable results then I might have to consider jumping ship. One of the *BSDs maybe or god forbid, Windows 7. You can say what you like about Vista, but the sound mixer produces very reasonable results and the individual slider per application is a great feature.

I've been putting up with the low volume sound on linux for a few years now and sadly, I've come to the conclusion that sound on Linux, and especially ALSA is a big ball of suck that doesn't show any signs of getting much better anytime soon.
Your spot on, ALSA has terrible sound at high levels... The problem is OSS isn't 100% compat anymore, I've already ran into a few annoying glitches. Such as I play CS:S, with OSS the sound lags .5 secconds.... It's not WINE it's CS:S but I can't figure out a way to fix it. So far that's the only glitch I can't fix, but since it's the only game I play anymore it drives me up the wall. =( I want OSSv4 wit no bugs!!! lol Then I'd be happy.
 
Old 08-28-2009, 12:09 AM   #5
huntly001
LQ Newbie
 
Registered: Aug 2009
Distribution: debian (stable at the moment)
Posts: 3

Original Poster
Rep: Reputation: 0
thanks for the suggestions! but, i've been in and out of all the mixers and settings a few times (setting levels, flicking switches etc.) but nothing has fixed it.
i've tried setting the PCM and Wave sliders to certain levels and shifting the master and vice versa to see how it behaves, but it's always the same problem. (it's not an issue when it's plugged into my amp (via the headphone socket) as the levels all have to be @ 100% regardless.) but when my headphones are in use there is just too steep of a gradient in the last 20% of volume (especially using the vol buttons on the keyboard...)
 
Old 08-28-2009, 10:29 AM   #6
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
http://www.4front-tech.com/wiki/inde...v4_from_source

I had to use the command 'make deb' so I could uninstal the package easily. =) This is a good work around for ALSA and works incredibly well.
 
Old 08-29-2009, 04:14 PM   #7
windtalker10
Member
 
Registered: Nov 2007
Location: Kentucky
Distribution: Slackware13.1
Posts: 214

Rep: Reputation: 38
I'm using alsa myself with an intel sound card and an inexpensive altec speaker system.
Not concert material by any means but more than adequate for home use.
XMMS is used to play tunes with.
Xine is used for vids.
My system is a desktop btw.
In alsamixer, everything with a slider bar is unmuted and set at 100% except master.
The only thing that does not have a slider bar that is unmuted is headphones.
line jac unmuted will turn off all of my sounds for some reason.
Master is set at 55% with headphones and maybe 10% without headphones.
These levels are more than adequate for normal use.
I also do not have several kids playing in the background and televisions going soooo.

There isn't much to setting alsa up.
Make sure it's installed.
Run alsamixer as user, set things up the way you want, then exit by striking the esc key.
If everything works, then as root do alsactl store.
If not, try changing the settings by muting and unmuting various things in alsamixer.
Tedious with trial and error but that's how I found out line jac doesn't like my system.
If you have a desktop icon for controlling your sound levels, there may be a setting through there that isn't properly set.

I have at times set master at 100% for whatever reason but find it tends to make my ears bleed from bursting ear drums.
Enough base and it reminds me of the kids with the vibrating cars who don't obey their parents because they can no longer hear them.
I've been using Linux a little over 5 years with this same system set up and have not found distortion of any kind at any level.
In fact, my sounds are improved over those XP Pro had to offer.
I have used my pc as a sound system at get togethers and was asked to turn it down because people were having trouble talking.
I ran OSS with Arch and had the same favorable results.
Alsa may not be the culprit nor OSS imo.
If alsa/oss were the culprit, I would think everyone would have the same types of problems.
 
Old 08-29-2009, 06:44 PM   #8
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Rep: Reputation: 30
Quote:
Originally Posted by windtalker10 View Post
In alsamixer, everything with a slider bar is unmuted and set at 100% except master.

Master is set at 55% with headphones and maybe 10% without headphones.
I set my sound the same way and it works well. Noteworthy is that the other day Alsa was updated and suddenly the sound went away. It took a while of playing around to figure out that the various sound settings had been lowered. Once I readjusted the sliders (including the ones to the far far right) to the previously mentioned levels everything was fine.
I have no distortion and enjoy using my desktop as a multimedia center.
 
Old 08-29-2009, 09:31 PM   #9
windtalker10
Member
 
Registered: Nov 2007
Location: Kentucky
Distribution: Slackware13.1
Posts: 214

Rep: Reputation: 38
Quote:
Originally Posted by donnied View Post
I have no distortion and enjoy using my desktop as a multimedia center.
I dunno what hardware/equipment others may be using who do have problems beyond what a poster decides to offer up.
In some instances I know some are trying to make a lappy into a boom box and somehow I just don't think the speakers from a lappy are going to rattle many windows.
For those who had decent sound from Windows but not alsa/oss, don't blame alsa/oss, blame the sound card manufacturer for not making things open source.
 
Old 08-30-2009, 04:34 AM   #10
GazL
Senior Member
 
Registered: May 2008
Posts: 3,364

Rep: Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895Reputation: 895
Quote:
Originally Posted by windtalker10 View Post
For those who had decent sound from Windows but not alsa/oss, don't blame alsa/oss, blame the sound card manufacturer for not making things open source.
The fact that the *BSDs, the GPL'd OSSv4 and even the old OSS/Free that used to be in the kernel all those years ago don't have these quality/volume issues with sound suggests to me that pointing the blame at the manufacturers and suggesting it's an open/closed source issue is a red herring.
 
Old 08-31-2009, 05:25 AM   #11
huntly001
LQ Newbie
 
Registered: Aug 2009
Distribution: debian (stable at the moment)
Posts: 3

Original Poster
Rep: Reputation: 0
not quite

thanks for all your input, just for clarification i basically never have the laptop speakers in use (for obvious reasons).
also the problem isn't distortion; with everything set to 100% there's no (for the purpose of the discussion) distortion coming through the amp.
i've got no problem adjusting volume for when i switch between having the amp and headphones plugged into the jack, but the problem is the gradient of change the sliders has on the volume.
i'm currently considering thumbing through the alsa source and trying to find anything that could help there (silly idea considering i'm pretty useless in the realm of coding) and compiling a new module to plug into the module; please stop me if you've got any better ideas!
cheers!
 
Old 09-02-2009, 12:42 AM   #12
windtalker10
Member
 
Registered: Nov 2007
Location: Kentucky
Distribution: Slackware13.1
Posts: 214

Rep: Reputation: 38
Sorry for the late response.
I still don't think the problem is with alsa.
I use headphones myself the majority of the time as not everyone in the house is refined enough to enjoy the lofty notes produced by Alabama, Ferlin Husky or Rodney Atkins.
I use the kde 3.5 desktop and control my volume through Kmix.
I have master selected for the master channel and that is the only slider that ever changes.
As already stated, all the rest are set for 100%.
When I increase or decrease the volume through kmix, it's moving the master slider of course.
Your op says you have what I would call a dead zone in your volume control if I am understanding properly.
I'm more inclined to think the issue is more along the line of possibly compatibility, which I doubt or settings somewhere, which I'm leaning more towards.
I do know there is a program that I saw somewhere that may cure your issue.
I never used it but it was supposed to enhance your audio in media players as well as make sure everything was played at the same "volume" when listening to multiple songs loaded in your media player.
If the music you're listening to, and I'm assuming that's what the issue is, there is also the possibility the files are corrupted.

Last edited by windtalker10; 09-02-2009 at 12:48 AM.
 
Old 09-04-2009, 09:20 AM   #13
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
hmm Well I do know different soundcards act differently under alsa... but as far as deadzones... I usually just use alsamixergui and fumble through it, I like my graphical sliders more... =P I still think a slider isn't where it's supposed to be.
 
  


Reply

Tags
alsa, volume


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Volume Control: Intel 82801DB-ICH4 (Alsa mixer) won't save volume levels. cayspekko Linux - Newbie 2 01-31-2008 12:17 AM
ALSA volume control Normanya Linux - Software 5 06-21-2005 10:41 PM
DISCUSSION: Impractical HOWTO's: NetBSD on a Macintosh Powerbook 160 unSpawn LinuxAnswers Discussion 0 08-23-2004 07:41 PM
Alsa volume restriction vasco1984 Linux - Software 2 05-14-2004 01:03 PM
ALSA Volume Controls Cyclops Linux - Software 3 10-18-2003 12:00 AM


All times are GMT -5. The time now is 01:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration