LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Temporarily disable notifications in KDE (http://www.linuxquestions.org/questions/linux-desktop-74/temporarily-disable-notifications-in-kde-822278/)

cantab 07-26-2010 01:49 PM

Temporarily disable notifications in KDE
 
I want a way to temporarily disable the notification popups in KDE. Preferably without having to wade through a load of screens. Basically it's for when I'm watching movies or playing games full-screen.

Any good ideas for doing this? Maybe a system tray applet, or a shell command would be good also.

amani 07-27-2010 08:48 AM

Is 'putting the window above others' not sufficient?

cantab 07-28-2010 04:20 PM

Right-clicking the title bar and going Advanced > Keep Above Others does not work, no.

amani 07-30-2010 12:57 PM

System Settings --> Notifications (there will be plenty)

cantab 07-31-2010 05:53 AM

I really can't be going through them all though. Are those settings in a config file somewhere? That way I could create an alternate file with them all turned off, and then just switch between them (and maybe have to make the program reread its config).

MTK358 07-31-2010 07:57 AM

1 Attachment(s)
See the attachment.

cantab 07-31-2010 08:00 AM

MTK358, thanks.

amani 08-03-2010 10:28 AM

that is simpler

cantab 08-08-2010 01:25 PM

Re-opening this issue. MTK358's method doesn't do what I want, since programs like Kopete revert to using their own notification mechanism, which again pops up over what I was doing.

MTK358 08-08-2010 02:05 PM

If, for example, Kopete has its own from-scratch built-in notification mechanism (i.e. create a new decoration-less window and delete it after a certain delay), then I don't think there is a way to turn it off outside the application itself.

cantab 08-08-2010 02:08 PM

Well those notifications don't appear if the system tray notifications are still on.

So, essentially, what needs to happen is Kopete needs to "see" the system tray notifications as active, but when it makes a notification the system tray essentially ignores it.

resumedocket 08-15-2010 11:06 PM

I work on Windows. My toolbox is Linux.


All times are GMT -5. The time now is 06:25 AM.