LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-23-2013, 12:56 PM   #1
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Rep: Reputation: 32
Tearing in framebuffer


I've had problems with tearing since ... forever. The only time I've had it right was with a Knoppix live CD but I'm using Debian so that's not very much of use.

Now I've put my hopes in trying to get tearing away in the framebuffer. Main reason, I want to wach (tear-free) movies in fb.

Now, how do I do that?

Thanks

> hardware is a ASUS E35M1-I deluxe with an HD6310 as a video card. I'm running Debian 7

Last edited by bucovaina78; 09-23-2013 at 12:58 PM.
 
Old 09-23-2013, 05:36 PM   #2
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 515

Rep: Reputation: 102Reputation: 102
Why do you want to watch movies via fb? xv is way better.
If you use fglrx, you will get tearing unless you use either tear free opption in the aticcc control panel (lowers performance in games) or use the xbmc media player for playback.

Also you can try the opensource driver with kernel 3.11 or later (with radeon.dpm=1), mesa 9.2 or higher, radeon ddx driver 7.2 and drm 2.4.46.
This new opensource driver has tear free playback with any interface and it has vdpau hw decoding (works with mplayer/smplayer/gnome-mplayer, even with flash but only on youtube). It also implements proper power management and clock switching, using roughly the same power as fglrx (maybe a bit more, but on my desktop A8-5500 i see exactly the same temperatures).
 
Old 09-24-2013, 01:55 AM   #3
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by gradinaruvasile View Post
Why do you want to watch movies via fb?
I'm aware of the fact that my approach isn't very usual. That's because I'm hoping it's going to be easier to remove tearing in fb. I've been struggling with this problem in X for so long now and with different setups I always had the same problems. Aside of that, I like the console a lot and I'd prefere it, if I could move the "watching movies" part of what I do to the console as well. Provided I haven't got tearing, that is.

Quote:
Originally Posted by gradinaruvasile View Post
xv is way better.
Very likely you're right and I wouldn' expect you to not give me this advice.

Quote:
Originally Posted by gradinaruvasile View Post
If you use fglrx, you will get tearing unless you use either tear free opption in the aticcc control panel (lowers performance in games) or use the xbmc media player for playback.
Well, at a clean install, Debian doens't give me image when i'm on console (F1-F6), they're there, I can blindely login as root and reboot but no image. If I install firmware-linux-nonfree, that problem is solved. Lateron I tried the fglrx drivers and I lost the consoles again and had to reinstall. Since I use the console a lot, I'm a bit reluctant on installing these drivers that make me lose the console.

Quote:
Originally Posted by gradinaruvasile View Post
Also you can try the opensource driver with kernel 3.11 or later (with radeon.dpm=1), mesa 9.2 or higher, radeon ddx driver 7.2 and drm 2.4.46.
This new opensource driver has tear free playback with any interface and it has vdpau hw decoding (works with mplayer/smplayer/gnome-mplayer, even with flash but only on youtube). It also implements proper power management and clock switching, using roughly the same power as fglrx (maybe a bit more, but on my desktop A8-5500 i see exactly the same temperatures).
Thanks for the advice, I will give it a shot if all else fails.

But still the question remains open. How do I remove tearing in fb?
 
Old 09-25-2013, 05:07 AM   #4
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 515

Rep: Reputation: 102Reputation: 102
I had the blank virtual terminals issue when i used fglrx with some newer kernel (3.8 or 3.9).
Solution: set the console resolution to that of the native screen resolution. This will work with or without fglrx.
You do this by adding something like (this is my setup, i have a 1280x1024 monitor):

Code:
GRUB_GFXPAYLOAD_LINUX=1280x1024x24,1280x1024
GRUB_GFXMODE=1280x1024x24
to /etc/default/grub then running "update-grub".
If the entries already exists, modify and uncomment them.
 
Old 09-25-2013, 10:03 PM   #5
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
My /boot/grub/grub.cfg (at least the relevant part) currently looks like this. I think that's what you're saying?

Code:
if loadfont /share/grub/unicode.pf2 ; then
  set gfxmode=1920x1080
  load_video
  insmod gfxterm
  set gfxpayload=keep
  insmod part_msdos
  insmod ext2
  set root='(hd1,msdos1)'
  search --no-floppy --fs-uuid --set=root 8180cff5-e237-47e4-b95c-5e9eed08d223
  set locale_dir=($root)/grub/locale
  set lang=nl_BE
  insmod gettext
fi
 
Old 09-26-2013, 01:57 AM   #6
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 515

Rep: Reputation: 102Reputation: 102
Basically yes. Does it work for you?
I had to specify explicitly in both entries, because the "GRUB_GFXMODE=keep" wouldnt work. Other simple method is using the vga=792 (or other number, depending on your resolution) in the kernel command line - this was simplest but the kernel kept complaining about it being a deprecated and soon-to-be-removed option.
 
Old 09-27-2013, 05:53 AM   #7
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 271

Original Poster
Rep: Reputation: 32
I added both lines and it didn't change much. I already had the other tty's available since I installed firmware-linux-nonfree. The main problem is tearing. It's till there even after I added the lines suggested
 
  


Reply

Tags
tearing framebuffer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tearing PLANTROON Linux - Desktop 11 02-10-2013 11:38 AM
tightvncviewer tearing 10110111 Linux - Software 2 01-23-2010 02:14 AM
framebuffer confusion with Hauppauge PVR 350 framebuffer /dev/fb0 tofino_surfer Linux - General 4 09-18-2008 11:36 PM
nVidia GL Tearing FLOODS Fedora 1 04-09-2005 10:04 AM
VESA framebuffer vs Intel framebuffer in Slackware 10.0 with default kernel brancalessio Slackware 3 01-20-2005 03:21 PM


All times are GMT -5. The time now is 07:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration