LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 01-05-2011, 12:20 PM   #1
faint545
LQ Newbie
 
Registered: Nov 2010
Posts: 14

Rep: Reputation: 0
Angry Switching Soundcards in Lubuntu 10.10


I just installed Lubuntu 10.10 and I've come across a little snag. I've been trying to figure out how to switch between the sound cards I have and it'd driving me nuts. Something this simple shouldn't be difficult. I have 1 sound card and 1 USB headset. I want to be able to switch between the two.

I've tried asoundconf-gtk and that no longer works

Code:
alex@Kerberos2:/usr/bin$ asoundconf-gtk 
sh: /usr/bin/asoundconf: not found
You need to make sure asoundconf is active!
By default, asoundconf's configuration file is ~/.asoundrc.asoundconf
and must be included in ~/.asoundrc. Open this file to make sure it is!
I've looked around to see if anyone has come across this problem and I have, however the solutions no longer work...

There is no GUI interface that comes with Lubuntu to change the default sound card.
 
Old 01-05-2011, 01:02 PM   #2
fair_is_fair
Member
 
Registered: May 2005
Posts: 511

Rep: Reputation: 51
Does alsamixer do anything for you?

Open a terminal and type sudo alsamixer
 
Old 01-05-2011, 01:07 PM   #3
faint545
LQ Newbie
 
Registered: Nov 2010
Posts: 14

Original Poster
Rep: Reputation: 0
That was the first thing I tried. It doesn't allow you to set a default output device. Only change the volumes and such.
 
Old 01-05-2011, 01:27 PM   #4
fair_is_fair
Member
 
Registered: May 2005
Posts: 511

Rep: Reputation: 51
Does alsamixer show both sound cards and volume controls for such? Is one card not working at all? Sometimes its just a matter of muting channels you do not want or need.
 
Old 01-05-2011, 01:28 PM   #5
faint545
LQ Newbie
 
Registered: Nov 2010
Posts: 14

Original Poster
Rep: Reputation: 0
Yes. Both devices are visible in alsamixer.

Quote:
Sometimes its just a matter of muting channels you do not want or need.
That doesn't work.

Last edited by faint545; 01-05-2011 at 03:02 PM.
 
Old 01-16-2011, 05:09 AM   #6
demosthenese
LQ Newbie
 
Registered: Sep 2010
Distribution: debian sid/xfce
Posts: 24

Rep: Reputation: 4
I followed the instructions here to set the default automatically when plugging/unplugging:

http://www.jordswart.org/archives/63

Works for me (using Debian Sid).
 
Old 01-16-2011, 06:30 AM   #7
almatic
Member
 
Registered: Mar 2007
Distribution: Debian
Posts: 547

Rep: Reputation: 67
you can also get the asoundconf binary out of the alsa trunk.
Afaik it has been removed because they want to make you use pulseaudio.
 
Old 07-23-2012, 07:18 PM   #8
nepalnt21
LQ Newbie
 
Registered: Apr 2012
Distribution: debian
Posts: 26

Rep: Reputation: Disabled
im having the same problem, but i do not know how to create config files, as per what i believe the instructinos are in the link of the second to last post
 
Old 07-24-2012, 11:13 AM   #9
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,071

Rep: Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788
You can see various ways of selecting a sound card in the documentation for Debian, Arch, and Gentoo. There is no guarantee that any will work in Ubuntu; at least, I've never succeeded. Good distros have a GUI configuration tool like gnome-volume-control. If that's not in the Ubuntu repository, maybe it's time to switch to Mint, Pinguy, or Solus...

Last edited by DavidMcCann; 07-24-2012 at 11:15 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching between soundcards nonis Linux - Hardware 2 04-21-2009 12:08 PM
LXer: TIP: Switching Soundcards In Ubuntu LXer Syndicated Linux News 0 12-03-2008 05:50 PM
Switching Soundcards pacman99 Fedora 0 05-31-2006 02:09 PM
Switching between two soundcards - how? z-vet Linux - Hardware 0 12-13-2004 07:44 PM
Switching between active soundcards? Mikbad Linux - Newbie 0 10-09-2004 10:51 AM


All times are GMT -5. The time now is 07:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration